1. aaron2195's Avatar
    Hey guys, I've been looking around the internet for days now and still can't find a solution to my problem, so here goes. I recently had my galaxy s4 repaired by a third party repairer, I've had phones repaired by them before and they've been fine. Anyway, the phones working well, except it doesn't read the sim card, I just get a circle with a line through it displayed where the signal strength should be. It also doesn't allow me to search for networks at all. I've tried factory resetting the phone also, several times. The phone detects when a sim card isn't inserted, so it's got me thinking that maybe it isn't the sim card reader, however the sim works fine in other phones. Is it possible something could of been damaged when it was being fixed? I'd really like to know if there's any information for this out there before I go spending more money on the thing.
    Thanks,
    Aaron.
    Samsung Galaxy S4 - Problem with sim card/network after repair-screenshot_2013-11-10-09-01-06-1-.jpg
    11-09-2013 05:16 PM
  2. K-City's Avatar
    Hey Aaaron,

    I am having the exact issue you were. I have tried everything, still no joy . Were you able to fix it and how?

    Karin
    12-25-2013 01:50 AM
  3. STARGATE's Avatar
    Hello guys!
    Who's your carrier?

    I had a similar problem back in July and I got it sorted out but I'm with Sprint.

    Sent From Inside The TARDIS in a Galaxy S4 Away!
    12-26-2013 11:58 AM
  4. cream7379's Avatar
    I've been having the same problem for a month now not being able to make a call or use the Internet. Only if I connect to wifi can I use the Internet. I've tried everything factory reset 2 times still nothing. If you got yours to work please let me know what you did to fix it I would appreciate it a lot. I don't have insurance and samsung said it's out of warranty and I really don't want to get another phone
    02-22-2014 08:49 PM
  5. Kavindi's Avatar
    Same problem.... Help
    02-23-2014 10:57 AM
  6. Mamaz Polutele's Avatar
    Hey there

    Ive got the same problem as well and i sent mine of to get fixed n it was working fine but when they decided to recheck the phone b4 they send it back and it wasnt working,they reckon it might be a software problem coz i did replace the sim tray n it stil didnt work so i might have to reboot the phone,but if any of use manage to fix your guys phone can u help me out as wel.lol

    Thanks
    04-02-2014 12:00 AM
  7. metle_geek's Avatar
    Either that or the system board isn't reading it seems to be a problem I was talking to a guy a week ago about this and they changed his system board and it worked I blame faulty soldering personally or bad ribbon cables

    Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app
    04-02-2014 03:36 AM
  8. Sewajan Afridi's Avatar
    Hey guys, I've been looking around the internet for days now and still can't find a solution to my problem, so here goes. I recently had my galaxy s4 repaired by a third party repairer, I've had phones repaired by them before and they've been fine. Anyway, the phones working well, except it doesn't read the sim card, I just get a circle with a line through it displayed where the signal strength should be. It also doesn't allow me to search for networks at all. I've tried factory resetting the phone also, several times. The phone detects when a sim card isn't inserted, so it's got me thinking that maybe it isn't the sim card reader, however the sim works fine in other phones. Is it possible something could of been damaged when it was being fixed? I'd really like to know if there's any information for this out there before I go spending more money on the thing.
    Thanks,
    Aaron.
    Click image for larger version. 

Name:	Screenshot_2013-11-10-09-01-06[1].jpg 
Views:	35 
Size:	95.5 KB 
ID:	90912
    04-15-2014 02:20 AM
  9. crazyjones's Avatar
    Same issue am having with my galaxy s4. I've tried everything;factory resetting,battery pulls,efs folder back-up,firmware re-installation,imei repair tools,fixing paper under the simcard and still nothing! This is so frustrating...Was anyone able to find a working solution?
    07-02-2014 08:39 AM
  10. Lauren Hummel's Avatar
    Any update on how you fixed this??? Having this problem as well....
    07-11-2014 08:00 PM
  11. Jorge Regalado's Avatar
    any luck with this issue, same story here! after replacement of the screen in a note II. any luck?
    09-11-2014 07:59 PM
  12. moegoldstein's Avatar
    Hey everyone, I had this issue as well and was about to give up when I came across this checklist to do after a repair. When I pressed the phone cover back on after the screen replacement, I must have loosened a connection. so following the advice of this itemized list to look for if you see that network message after the repair, I was able to solve it by just tightening the external antenna connector. So being the good sport that I am I came back here, created a username a password because I adhere to a strict leave no man behind policy. good luck
    -its saying I cannot post links because Im new here so google the blog for broken lcd's + network message and galaxy
    07-11-2015 09:58 PM

Similar Threads

  1. Replies: 27
    Last Post: 07-19-2016, 08:19 AM
  2. Foxfi on a T-mobile S4
    By rsxtcy4me in forum T-Mobile Samsung Galaxy S4
    Replies: 4
    Last Post: 12-22-2013, 09:58 PM
  3. Samsung Galaxy Note 10.1 (2014) College Student considering note 10.1
    By ewgrosschris in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 8
    Last Post: 12-14-2013, 04:34 PM
  4. Foxfi on a T-mobile S4
    By rsxtcy4me in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 11-10-2013, 02:52 PM
LINK TO POST COPIED TO CLIPBOARD