12-21-2016 03:52 PM
38 12
tools
  1. Victor151's Avatar
    I started a fresh thread on this topic after updating my Galaxy S4 to OS 4.3. I am still have trouble using the SD card and am constantly getting "SD Card Unexpectedly Removed" messages. This happens when I am viewing photos located on the SD card. The phone then automatically tries to reinstall the SD card and, after few minutes, starts working again. Rinse, repeat. I really hoped that the OS update would fix this, since in seems like a software issue related to the SD card driver. I have a 64 GB, class 10 SD card that otherwise works perfectly in my computer. I have read through the entire 10 pages of the earlier posting on this topic and thought it was time to start a new one. Maybe put some more pressure on Samsung to fix this glitch. After all, the extended memory is one of the main reasons I bought this phone. And it really doesn't work. It's also the only problem I am having with the phone, which has otherwise been great.

    Samsung tech support told me that slower class 4 and 6 cards should work okay, but I haven't been able to verify this. Anybody finding a solution to this problem?
    12-09-2013 05:16 PM
  2. Haalcyon's Avatar
    Samsung tech support told me that slower class 4 and 6 cards should work okay, but I haven't been able to verify this. Anybody finding a solution to this problem?
    I've seen countless threads on this issue with Samsung phones, especially the S4. At first, thought it was isolated to Sandisk Ultra cards but doesn't seem to be. I will say that I've used Sandisk Extreme cards in the S4 and Note 3 without having any issues so you may want to give one of them a whirl.
    12-10-2013 04:23 AM
  3. capovawi's Avatar
    I have the same problem with my tablet Asus Memo Pad HD7 and a 32Gb micro SD card...
    12-10-2013 10:25 AM
  4. Fengshuistein's Avatar
    Yeah, mine also did the whole "unmounting / mounting" thing from the get-go (Verizon S4, purchased in May, with a Sandisk Ultra 64GB class 10 SD card), but got a lot worse after the 4.3 update. It would sometimes unmount itself 30-40 times over the course of an hour. Sandisk was gracious enough to replace the card under their warranty, but while I was awaiting the new SD card, my phone was SD-Free, and I gotta say, it has never behaved better - all the funky jitters / stutters / oddball stuff didn't happen. I've had the new card for several weeks, but I haven't even opened it yet, LOL. I'm a little hesitant to put another one back into the phone...

    -Phil
    12-10-2013 05:37 PM
  5. Kat319's Avatar
    Yeah, mine also did the whole "unmounting / mounting" thing from the get-go (Verizon S4, purchased in May, with a Sandisk Ultra 64GB class 10 SD card), but got a lot worse after the 4.3 update. It would sometimes unmount itself 30-40 times over the course of an hour. Sandisk was gracious enough to replace the card under their warranty, but while I was awaiting the new SD card, my phone was SD-Free, and I gotta say, it has never behaved better - all the funky jitters / stutters / oddball stuff didn't happen. I've had the new card for several weeks, but I haven't even opened it yet, LOL. I'm a little hesitant to put another one back into the phone...

    -Phil
    12-12-2013 10:09 AM
  6. Kat319's Avatar
    I am in total frustration. I have had same issue from get go with my S4. Been through countless re sets. Issued refurbished phone to try...same issue with those... had numerous Verizon techs tell me they have never hear of this issue and make me feel like some crazy lazy who like to call and play play with resetting my phone for hours on end. I too have exchanged my SD card with Sandisk. ( only an 16 gb so it's not limited to the high gbs like they say) I have been told to put a piece of heavy paper in with SD card slot to tighten the card hold. NOTHING WORKS. Finally a Verizon tech call Samsung and said they told him with their next software update it would fix. Well did the update and guess what...it still does it. I'm so ticked at Verizon for making this such a headache. It has to be a bad batch of phone because I can't believe every person who owns a s4 isn't having this issue. But because I waited a couple weeks after purchase to install an SD card and didn't know of this I was outside the one month limit for a new phone and only get refurbished ones which, of course, have been returned probably for the same reason!
    I take counless pictures and really need the extra storage. I even tried to upgrade to the 32 gb phone so I wouldn't need the card and they would not help. Now I'm stuck with this for 2 years unless there is finally a fix.
    12-12-2013 10:24 AM
  7. Kat319's Avatar
    I also had my card removed for a time and phone worked like a charm. Put back it and issues came back. So I'm in the same boat Phil. Hate to put the card back but hate to be without. Thinking of just saving to device and installing card once in a while to do a copy then removing it. It's a load of Crap to have to do with this phone of this caliber. It's top notch in all other respects and takes great pic's. I wish Samsung would come out of denial and just get it fixed.
    12-12-2013 10:32 AM
  8. Haalcyon's Avatar
    Have either of you tried your cards via card readers? Are you having the same results as when using the uSD card slot?

    Optimus G Pro
    12-12-2013 12:07 PM
  9. CehowardNote7's Avatar
    Well, the SD Gods must be shining on me.. On my S4, I had one of the FAKE 64gb, that was only 4gb, but it worked.. When I returned the S4, and got a Note 3, I got two Sanddisk Ultra 64gb.. I put one in my Note 3, and proceeded to load 13gb of movies, music and pictures. The card or the phone hasn't even blinked.. The only thing I did was when I first put the card in the Note3, I told the Note3 to format the card. Been working like a charm.

    On my wife's S4, she has PNY or PNC 16gb, and the other day she had the problem of saying the card was unreadable. Put it an card reader, tried to access, no dice.. Finally, I pulled a 20 or more year old command and that fixed it. Using Win 7, went to a DOS prompt, the card was listed as "I" drive, I typed in chkdsk I: Whammo, card readalbe, got the files off, card okay.

    My Ultra 64gb in my Note 3 has been flawless..
    STSVA likes this.
    12-12-2013 07:05 PM
  10. Victor151's Avatar
    Yes, I tried many of the suggestions in earlier postings. I had the phone re-format the SD card and then reloaded photos and music. Seemed to help for a bit, but didn't solve the problem. My 64gb, class 10 Sandisk ULtra SD card works just fine in a card reader on my computer. I have to conclude that this is not a card problem.
    12-13-2013 03:49 PM
  11. Ali Najaf's Avatar
    Bump

    I have the issue with my note 3

    I have a 32gb

    Any fix?

    Also every time I would lock then unlock my phone ... I would take 3 seconds for the lock screen to pop up and when it did I would see the message "sd card unexpectedly removed" 90% of the time
    12-14-2013 08:35 PM
  12. Haalcyon's Avatar
    Bump

    I have the issue with my note 3

    I have a 32gb

    Any fix?

    Also every time I would lock then unlock my phone ... I would take 3 seconds for the lock screen to pop up and when it did I would see the message "sd card unexpectedly removed" 90% of the time
    The fix for me was the Sandisk Extreme 64GB. The issues stopprd completely once I started using it. YMMV.
    12-15-2013 02:48 AM
  13. Ali Najaf's Avatar
    Anyone else have any solutions
    12-15-2013 01:14 PM
  14. Ali Najaf's Avatar
    Bump
    12-16-2013 05:26 PM
  15. JBizz86's Avatar
    Had this problem it went away with a new card tell 4.3 update. I left it in during update. Now the sd card has disappeared completely. I can't evwn put in an older card. Its odd.

    Sent from my SGH-M919 using Tapatalk
    12-17-2013 12:51 AM
  16. Kat319's Avatar
    Any further progress?
    For me it almost seems to be getting worse. I have my SD card in the phone but do not save to it automatically. I manually will copy to it. But I noticed recently when I went into by Gallery to view pictures on the phone, I am now getting the error that the SD card has been removed. It's crazy. Not even accessing it and it's affecting the device. I guess at this point i just give up and remove the card for fear of some sort of blip that may affect the files.
    01-10-2014 11:37 AM
  17. Yabedude's Avatar
    I've had this S4 for a month and bought a Lexar 600x 64gb 2 days after. I've lost all contents from the card twice already after seeing that error message. It's extremely frustrating.

    It won't mount without reformatting. Given it works fine and randomly fails, I would suggest that it's a software issue and not a hardware issue. Samsung drivers and failing or rather corrupting the FAT and causing content to appear to have been lost. Too bad there isn't an app to recover from this because it's just maddening.

    Posted via Android Central App
    02-01-2014 05:41 AM
  18. cprio's Avatar
    Note 3 on t-Mobile with a samsung 64gig high speed card.

    When I initially installed the card it would unmount itself constantly.... now I am getting a consistent error that the card has files that are unsupported and wants to reformat!!!!

    ARRGGGHHHHHHH!!!!!!
    02-02-2014 08:02 AM
  19. d_jimenez53's Avatar
    I removed a Dane-Elec 16 micro SD card without unmounting it from my Galaxy S# / Android 4.3.
    When I connect it to my laptop, the files cannot be found and I get a message to format the disk for use.
    Is there anything I can do to recover the files?
    02-11-2014 11:18 AM
  20. sad cricket's Avatar
    I think it is a hit or miss when it comes to Sandisk. Initially I had a 32g micro SD card that was a class 10 and from day 1 I would get the mounting error. I even formatted the disc correctly. Then I bought the same card but a Samsung 64g micro SD and never had a problem with it while running 4.2.2 or 4.3.
    02-11-2014 01:52 PM
  21. Tat Wadjet's Avatar
    I have had the same problem with my S4. BUT! If I restart the phone, the card will come back and work for a while.... until it unmounts itself again. I'm going to look into finding out what card I have and trying some of the others mentioned. It is driving me nuts. Only started with the update to 4.4.2. Prior to that, it worked fine. Update is what did it. And apparently they aren't going to fix it (which sucks)...
    Yavuz Keskin likes this.
    08-11-2014 08:31 PM
  22. Yavuz Keskin's Avatar
    I have an S4 and I had the same problem for a long time. I thrashed my first SD Card thinking that it was corrupt but then I realized My samsung or the software is the cause after installing my second SanDisk 32GB extreme class 10 SD Card just to see I have the same problem. It is very frustrating not to access my photos or applications when I need them. It just randomly unmounts the sd card over and over again. I don't know why samsung and Google keep ignoring this major problem. SD Card support is one of The best feature of the phone and I don't want to change my phone to a different brand just because of this issue since i am really tired of looking for solutions in the forums which there is none. Please fix it before it ruins your reputation.
    09-04-2014 12:53 AM
  23. Moltres_rider's Avatar
    I am having the SAME problem!!!! Tried restarting the phone off on removing SD card NOTHING WORKS!!!

    Posted via the Android Central App
    09-30-2014 04:05 PM
  24. David Clark11's Avatar
    my wife and I are having the same problem with our new galaxy s3 mini we read on a forum someplace about folding a little piece of paper and placing it under the card before putting it in and up to now this has worked. our sd cards are only 4gb though and want to get new ones so it wil be interesting if the problem persists with new cards
    10-01-2014 10:43 AM
  25. Kiryl's Avatar
    I was having the same error messages on my Moto E (stock Android 4.4.4). It will slow the phone down during wake-ups and also all of the app icons for apps located on SD card would disappear from the home screen. Very frustrating. In my case I traced it down to a single app that was causing it after being moved to SD card storage. It was the Amazon store app. While the phone is in the sleep mode it tries to perform some extensive file operations at the location it deployed to, which crashes the app itself and causes the OS/driver to lose the mount on the card. While it is obviously a defect in the OS, a workaround would be to move the offending app (in my case the Amazon store app) from SD card back into phone main storage. Hope this helps.
    11-18-2014 08:50 AM
38 12

Similar Threads

  1. Nexus 7 won't update to 4.4. Gives error message.
    By scolson1 in forum Google Nexus 7 Tablet (2012)
    Replies: 22
    Last Post: 12-27-2014, 05:33 PM
  2. text messages
    By r p1 in forum Moto X (2013)
    Replies: 11
    Last Post: 12-09-2013, 06:13 PM
  3. cant save to sd in newer custom roms
    By eeyore6802 in forum AT&T Galaxy Note 2
    Replies: 1
    Last Post: 12-09-2013, 01:22 PM
  4. 502 Bad Gateway nginx Error
    By DayThyme in forum General News & Discussion
    Replies: 2
    Last Post: 12-09-2013, 11:55 AM
  5. Transferring sd card from one phone to another
    By Elizabethj184 in forum Samsung Galaxy S3 in Canada (Bell/Telus/Rogers)
    Replies: 1
    Last Post: 12-09-2013, 10:46 AM
LINK TO POST COPIED TO CLIPBOARD