1. Mahesh Vishwanath's Avatar
    I am using a Samsung Galaxy S4 - genuine purchase and upgraded to Jelly bean(4.3) as per the Samsung official upgrade schedule.
    I am using the Sandisk 64gb SD card.

    One issue I am facing is that sometimes (sporadically), my camera says it cannot save images to my SD card...
    Then all the apps I have moved to my SD card also cannot be recognized...the apps image on the home screen also turns into an Android robot image.
    If I power off and on the phone, all works well.
    Is this a SD card issue or of the phone...any help in overcoming this issue would greatly help.
    12-12-2013 02:12 PM
  2. CehowardNote7's Avatar
    From what I have been reading, moving apps to the SD card is not a piece of cake..I am using a Sanddisk 64gb in my Note 3, and it works flawlessly. Did you have the phone format the card?
    UJ95x and Mahesh Vishwanath like this.
    12-12-2013 07:10 PM
  3. UJ95x's Avatar
    Like the above post said. Have you formatted the SD card?
    If so, on your PC or your phone? If you haven't, I'd recommend moving everything elsewhere, then formatting the card on your phone. That way it gets reset to the phone's stock settings

    Posted via Android Central App
    Mahesh Vishwanath likes this.
    12-12-2013 07:15 PM
  4. Mahesh Vishwanath's Avatar
    Thanks both...yes I had formatted my SD card first when I bought it on my phone itself.
    Also, I have moved some apps onto my SD card from the Settings-->Application Manager-->Move to SD card

    Anything else I should do now...
    12-18-2013 01:13 AM
  5. Ty Tiamiyu's Avatar
    I was struggling with this issue all day but finally found a solution. Just hold the power button on the left side of your S4 then when the options come up select reboot options at the bottom then select reboot. Your phone will then restart and It'll take a few seconds maybe a minute but your S4 will recognize the SD card and life will be back to normal. Good luck!
    03-14-2014 01:31 AM
  6. Sanjay Chandra's Avatar
    I think it's problem with your card or lose port.

    Sent from my GT-I9500 using AC Forums mobile app
    03-14-2014 08:41 AM
  7. ranajit saha's Avatar
    I think it's problem with your card or lose port.

    Sent from my GT-I9500 using AC Forums mobile app
    No it's not a problem with the SD card. I have checked with 3 sandisk SD cards- one normal 4gb and two class 10 16gb. But had and still having same problem. Samsung has changed my motherboard but it hasn't solved yet. Just SD getting formatted automatically has solved.

    Posted via Android Central App from Samsung GALAXY S4 (GT-I9500)
    03-14-2014 11:05 AM
  8. Tsepz_GP's Avatar
    Kind of sounds like it may be corrupting or the phone's card reader is faulty.
    03-14-2014 11:08 AM
  9. Sanjay Chandra's Avatar
    Did you try Samsung's SD-cards ? SanDisk sometimes has compatibility issues
    03-14-2014 11:37 AM
  10. Douglas Byrne Jr's Avatar
    Did you try Samsung's SD-cards ? SanDisk sometimes has compatibility issues
    Having same exact issue with my second Samsung 64gb class 10 micro sd card in gs4, best buy blue edition. Getting furious with this, files also randomly vanishing with no trace of their former existence. Called samsung, they said this is a normal issue with this decive, the lady said she will get upwards of a dozen calls daily regarding this exact issue. The trash it is for my gs4 (metaphorically speaking). Looks like I will succumb to the ladders of the non - expandable memory world. I will NOT accept that my precious files will randomly disappear like many gs4 users have. Think I will be calling that guy from craigslist about trading for an htc one.
    03-14-2014 02:18 PM
  11. Milan Wijesinghe's Avatar
    same issue with my both S4 and Grand, i got 32GB sd cards and there are not work with both phones
    04-11-2014 07:49 AM
  12. Terry Newman's Avatar
    the issue is only with 32 gb or bigger SD cards, i have purchased 3 - 32gb class 10 cards from different manf including Samsung and I get the same results. when attaching to PC via the usb port can not always find the ext- SD card on phone. format the SD from the phone load it on the PC down load files every thing works while loaded in PC. reinstall it into the phone and all photos and music file corrupt and are unreadable. loaded a 16gb card and everything work fine with USB or loading file on computer and reinstalling it in S4 phone. Samsung has something wrong with their OS to be able to use 32 gb or bigger cards
    05-07-2014 02:40 PM

Similar Threads

  1. S4 WiFi hookup problem solved
    By Rockman59 in forum AT&T Samsung Galaxy S4
    Replies: 1
    Last Post: 12-12-2013, 10:21 PM
  2. Google Experience Launcher Issues?
    By Papadakis in forum Moto X
    Replies: 6
    Last Post: 12-12-2013, 08:25 PM
  3. How to turn off 4G on Samsung S 3 Virgin Mobile (Sprint)
    By secrecyguy in forum General Help and How To
    Replies: 3
    Last Post: 12-12-2013, 08:17 PM
  4. Google Nexus 7 Tablet (2013) WiFi connection issues
    By chrisinnova in forum Google Nexus 7 Tablet (2013)
    Replies: 0
    Last Post: 12-12-2013, 11:22 AM
  5. Galaxy S4 Active Keyboard Case
    By aglobalthreatsk in forum Samsung Galaxy S4 Active
    Replies: 0
    Last Post: 12-12-2013, 10:28 AM