1. HydroRaideR's Avatar
    My new galaxy s4 is acting weird....
    I recently had the screen replaced because the phone fell and it broke.
    But now that it's replaced when I turn it on it goes to the samsung logo and everything but right when the purple logo comes on it turns itself off. To get it working again you must take out the battery and wait a few seconds so it can turn on again and goes through the same thing.
    I have no idea why but all I want to know is did anyone else have this problem and is it fixable?
    I don't have guarantee so I can't get a free new one
    12-16-2013 01:11 PM
  2. UJ95x's Avatar
    Can you boot into recovery mode? Hold down home, power and volume up at the same time until it vibrates. Let me know if it still does the same thing

    Posted via Android Central App
    12-16-2013 01:17 PM
  3. HydroRaideR's Avatar
    I tried that and a green robot like figure popped up with a few options on the top left.
    12-16-2013 01:20 PM
  4. UJ95x's Avatar
    That's download mode. You hit volume down instead of up
    Does it stay on at least?

    Posted via Android Central App
    12-16-2013 01:22 PM
  5. HydroRaideR's Avatar
    Yes it does but I'm pretty sure I hit the volume up button.
    12-16-2013 01:23 PM
  6. UJ95x's Avatar
    Hmm, what are the options? If you're in recovery I would try a factory reset to see if that works with the rebooting issue

    Posted via Android Central App
    12-16-2013 01:28 PM
  7. HydroRaideR's Avatar
    Now it turns on, but I can only stay on the phone for like 10 seconds.
    Then it turns itself off.
    And to get it on again I have to take out the battery and put it back in.
    12-16-2013 01:30 PM
  8. UJ95x's Avatar
    Turn it off, and turn it back on. When it's turning on hold the menu key (left of the home button) and this should boot into safe mode. See if that stays on for longer

    Posted via Android Central App
    12-16-2013 01:46 PM
  9. HydroRaideR's Avatar
    New problem,
    that button and the one on the right aren't working either :/
    12-16-2013 01:55 PM
  10. UJ95x's Avatar
    New problem,
    that button and the one on the right aren't working either :/
    OK. Then I'd suggest flashing a stock ROM via Odin. You can get these on SamMobile.com just make sure you get the one for your exact model number

    Posted via Android Central App
    12-16-2013 02:24 PM
  11. Fresneck5150's Avatar
    i have a andriod blu dash3.5 11 well this morning i rebooted my phone like ive done before but when it comes back on it stays on for about 15 secs then turns off then comes back on and thats what it does over and over again i dont know whats going on its like its stuck in reboot mode but ive tried pushing power button and volume up and its turns on but in little letters its says its in restore mode but it wont do anything but shut off come back on. cqan anyone help?
    08-08-2016 06:45 PM
  12. megan-1210's Avatar
    Can you boot into recovery mode? Hold down home, power and volume up at the same time until it vibrates. Let me know if it still does the same thing

    Posted via Android Central App
    I have the same problem with my Samsung S4 but my phone doesn't even get to the Samsung logo. When I hold down the power, home and volume up button nothing happens. If I do the same but with the volume down button it gives me the option to download a custom OS or cancel and restart the phone, no matter what I do the phone doesn't do anything except start switching on and then immediately switches off. I don't know what to do
    04-23-2020 05:30 AM
  13. B. Diddy's Avatar
    Welcome to Android Central! The first thing to try would be a replacement battery.
    Laura Knotek likes this.
    04-23-2020 01:20 PM
  14. blackhawkhot's Avatar
    I have the same problem with my Samsung S4 but my phone doesn't even get to the Samsung logo. When I hold down the power, home and volume up button nothing happens. If I do the same but with the volume down button it gives me the option to download a custom OS or cancel and restart the phone, no matter what I do the phone doesn't do anything except start switching on and then immediately switches off. I don't know what to do
    Put it on the charger, make sure it's getting a charge.
    The battery has at least 20%?
    04-23-2020 01:27 PM
  15. mustang7757's Avatar
    [Let's stay on topic ]
    blackhawkhot likes this.
    04-24-2020 10:47 AM
  16. megan-1210's Avatar
    Put it on the charger, make sure it's getting a charge.
    The battery has at least 20%?
    I had it on charge the whole day but it just switches on and off, same as before but with the charging icon.
    04-26-2020 05:32 PM
  17. blackhawkhot's Avatar
    I had it on charge the whole day but it just switches on and off, same as before but with the charging icon.
    Try a known good charger with a 3ft long known good cable. Longer cables are a known issue with charging.

    If you have access to a Digital Volt Meter you can pull the battery and measure it's voltage directly. A fully charged one will be around 4 volts.
    If the battery doesn't have enough voltage the device will not boot.
    Laura Knotek likes this.
    04-26-2020 05:48 PM

Similar Threads

  1. Tips on using My Magazine?
    By clevin in forum Samsung Galaxy Note 3
    Replies: 4
    Last Post: 01-08-2014, 05:57 PM
  2. GS4 On 4.3 AT&T MK2 --ROOTED ???RECOVERY???
    By Randall Blackwell in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 12-31-2013, 07:52 AM
  3. T-Mobile Galaxy s3 screen not working
    By Gib28 in forum T-Mobile Galaxy S III Rooting, ROM's, and Hack's
    Replies: 1
    Last Post: 12-17-2013, 03:13 PM
  4. Galaxy gear update?
    By chjackson in forum Samsung Galaxy Gear
    Replies: 5
    Last Post: 12-17-2013, 10:23 AM
  5. Enable AWS band on AT&T Moto X
    By steven0188 in forum Moto X
    Replies: 2
    Last Post: 12-16-2013, 07:52 PM
LINK TO POST COPIED TO CLIPBOARD