1. Dave-in-Decatur's Avatar
    Just out of curiosity, I turned on Developer Mode by going into Settings > More > About device and tapping Build number 7 times. Didn't see anything there I really wanted or needed to do, so I would like to turn it off. I turned off the options as such by using the slider at the top of the Developer options screen. However, I'd like to hide the Developer options section altogether, as it was before I did this; but I can't find out how.

    I did find this thread, whose best ideas are to do a factory reset (overkill for me for this purpose) and to clear the cache and data of the Settings app itself. I tried the latter, but the button to clear data is grayed out, and clearing the cache has no effect.

    So, is there any other way to do this, short of a factory reset? Thanks!
    12-28-2013 12:01 PM
  2. mhinc's Avatar
    Just out of curiosity, I turned on Developer Mode by going into Settings > More > About device and tapping Build number 7 times. Didn't see anything there I really wanted or needed to do, so I would like to turn it off. I turned off the options as such by using the slider at the top of the Developer options screen. However, I'd like to hide the Developer options section altogether, as it was before I did this; but I can't find out how.

    I did find this thread, whose best ideas are to do a factory reset (overkill for me for this purpose) and to clear the cache and data of the Settings app itself. I tried the latter, but the button to clear data is grayed out, and clearing the cache has no effect.

    So, is there any other way to do this, short of a factory reset? Thanks!
    Clearing cache or data won't do anything. You simply have to do a Factory Restore.
    12-28-2013 12:41 PM
  3. Haalcyon's Avatar
    If, while in Developer options, you press the menu key is there an option to "Reset" Developer mode?
    12-28-2013 12:44 PM
  4. electricpete's Avatar
    In the upper right corner of the developer options screen, there is a on/off toggle button. However, when you toggle off, all of the options you have set revert to default. When you toggle it back on again, you'll have to redo any changes ... they're not saved from last time. When you toggle it back on it also shows a warning that adjusting these options can cause problems (I don't recall seeing that warning the first time I turned it on by tapping multiple times on baseband).

    Sent from my SAMSUNG-SGH-I337 using Tapatalk
    12-28-2013 02:51 PM
  5. Dave-in-Decatur's Avatar
    As I mentioned, I already turned off the toggle slider. I'm trying to lose the thing altogether. I just checked, and there isn't a Reset (or anything else) on the Menu key in Developer options.

    Perhaps it does come down to a factory reset, which I'm not going to hassle with just for this. A good lesson learned on not doing anything on my phone that I don't know how to undo!
    12-28-2013 09:09 PM
  6. Melinium's Avatar
    the developper menu is hidden again when you install an update, after installing 4.3 i have to click seven time on the build number to get back the options
    12-29-2013 10:11 AM
  7. Dave-in-Decatur's Avatar
    Thanks, everyone. Looks like my options are do a factory reset or pray for an OTA update. Think I'll just live with it instead!
    12-30-2013 04:51 PM
  8. nielsns's Avatar
    Check this video:
    03-02-2014 07:11 AM
  9. Firasathuddin Ahmed's Avatar
    Great video this worked for me,thanks.
    04-20-2014 04:08 PM
  10. Dave-in-Decatur's Avatar
    As I said in my original post, I've seen advice
    to clear the cache and data of the Settings app itself. I tried the latter, but the button to clear data is grayed out, and clearing the cache has no effect.
    Some phones, apparently, have the option to clear data in the Settings app. My Verizon S4 does not.
    04-21-2014 03:11 PM
  11. Aiuspaktyn's Avatar
    You can use this free app: Hide Developer (Play Store)
    RobBrello likes this.
    04-29-2014 01:09 PM
  12. thephilster's Avatar
    Have the same problem. It seems the USB debugging option greys out (and disables) after a few uses of the development tool, and the phone has to be hard reset to get it back. Then, of course, after a while, it greys out the option again. Debugging is one thing, I do a backup of everything so a hard reset is just a pain. But I do notice it happens just before Verizon wants to install "phone software to allow communication with your device" Whether you do that or not, the USB debugging option is greyed out.

    Just an observation on my part!
    08-11-2014 10:31 AM
  13. Dipankar Bhowmik's Avatar
    Just go to setting>app>all>setting>clear data>ok
    that's it. you wont's find the developer option.
    tonyr6 and pronomix like this.
    12-07-2014 09:29 AM
  14. vasanthkmr134's Avatar
    Thanks friend, but one more help, i unlocked my htc m8 for expect to update lollipop and do proper way but finally it show fail not updated. Why it happen?
    12-18-2014 02:14 PM
  15. PankajMehta's Avatar
    1. Go to settings
    2. Click on more
    3. Click on application manager
    4. Click All
    5 scroll down and click on settings
    6. Lastly click on clear data
    Enjoy. Your Developer option is hidden again.
    pronomix, tonyr6, Custnam and 1 others like this.
    10-22-2015 07:55 AM
  16. salaisankar77's Avatar
    thank you very much now the developer menu is hidden
    11-03-2015 11:32 AM
  17. Custnam's Avatar
    Thank you. Worked perfect on my S6.
    01-23-2016 08:15 PM
  18. Kolts45's Avatar
    Thanks, everyone. Looks like my options are do a factory reset or pray for an OTA update. Think I'll just live with it instead!
    Hey Dave I just did same thing but if you go to applications then chose application manager the go to settings icon and chose that then click storage and clear data and it will get rid of it. Even samsung didn't know this and just said factory reset is the only way but if you do the above you will see it will get rid of it.
    08-28-2016 06:38 PM
  19. Feemy82's Avatar
    The Clear Data button is greyed out. Why??
    It's never been greyed out on my previous phones. This is an LG V20.

    Any fix other then factory reset?
    11-16-2016 04:16 PM
  20. acardshort's Avatar
    Brillant
    01-09-2017 11:44 AM
  21. kanka's Avatar
    try going into setings>apps>settings>storage>clear data.
    07-11-2017 04:04 PM

Similar Threads

  1. galaxy s4 i9505 LTE option not available
    By tharangarox in forum Samsung Galaxy S4
    Replies: 4
    Last Post: 05-11-2014, 06:44 PM
  2. Can't switch to android at the moment, what the best options?
    By RavenSword in forum General News & Discussion
    Replies: 121
    Last Post: 01-01-2014, 08:05 PM
  3. Replies: 3
    Last Post: 12-26-2013, 11:33 AM
  4. Screen rotation option greyed out?
    By LadySnowfaerie in forum Samsung Galaxy Note 10.1
    Replies: 2
    Last Post: 12-25-2013, 04:08 PM
LINK TO POST COPIED TO CLIPBOARD