1. mmikage's Avatar
    Hi!

    I would just like to ask if someone else had the problem of email contacts showing up in your SMS contact list and how you managed to remove them. I've disabled sync for all my email accounts since the beginning (from the first time I added the account to my phone) and have never enabled it. Also, I have tried setting the phone book to show only contacts with phone numbers and setting the phone book to show only contacts saved to my phone/device memory but whenever I open the Contacts list via the default SMS app, all the extra contacts from my GMail account show up and sometimes I end up adding the email contact instead of the phone. It's so frustrating since a lot of my email contact list are either from strangers I've emailed only once a long time before OR old email addresses of my actual contacts (thus my confusion with the names) that they're not using OR old yahoogroups/school-related email addresses OR service-related addresses like Booking.com and such, since the account I am using with Google Play is the one I've used since I was in High School. It's just too much clutter in my phonebook.

    And it's only happening on my SMS contact list. My actual phone's contact list via the default Phone app is clean. -_-

    Thanks in advance for the help.
    01-01-2014 11:30 PM
  2. STARGATE's Avatar
    Welcome to the forums!
    Since I let all my contacts sync I never thought about this.
    I'm about to go to bed, but I'll check into it tomorrow and post back. Sorry I can't give you any further assistance at the moment.

    Sent From Inside The TARDIS in a Galaxy S4 Away!
    01-01-2014 11:48 PM
  3. Miocl's Avatar
    Did you ever find a solution to this? I can't seem to find one anywhere, and I'm obviously the only one bothered by this "feature"
    03-25-2014 04:19 PM
  4. Dave-in-Decatur's Avatar
    A couple of thoughts. This is something that the SMS app is doing, not the phone or contacts apps, so settings made elsewhere won't help. There are probably only two things you can do about it: (1) Set aside an otherwise unused block of time (say, a staff meeting at work ), go through your Gmail account, and delete, delete, delete. Get rid of contacts, e-mail addresses, etc., that you don't really need, and you won't be bothered by them. Or (2) I haven't tried them, but I know there are other SMS apps available in Google Play, and one of them might have configuration options that would help you deal with this. Best of luck!
    03-26-2014 03:50 PM
  5. Julia Eden's Avatar
    Anybody fix this? Having the same problem, restarting phone does nothing, unsyncing to google does nothing, clearing message app data does nothing...
    05-15-2014 02:14 PM
  6. Tiredofstockapps's Avatar
    I'll repost here: I have note II. Here's my solution: in SMS, when you click create messaging icon, then click on phone book icon, you will see CONTACT tab listing everyone you have emailed and those in your phone book. Ignore that list. Scroll to the left to GROUP tab. Scroll down to MY CONTACT. It'll then show a list with the contacts on your phone (that is, you have already set your phone to display people with numbers only).

    You have to manually do this every time but it beats seeing random people you have emailed. And you don't have to group or clean Gmail database.

    I made a tutorial on youtube for those who are challenged. It is titled, Android Note II: remove email contacts from SMS stock app when choosing recipients --- I would post a link but I am still a newbie



    Hi!

    I would just like to ask if someone else had the problem of email contacts showing up in your SMS contact list and how you managed to remove them. I've disabled sync for all my email accounts since the beginning (from the first time I added the account to my phone) and have never enabled it. Also, I have tried setting the phone book to show only contacts with phone numbers and setting the phone book to show only contacts saved to my phone/device memory but whenever I open the Contacts list via the default SMS app, all the extra contacts from my GMail account show up and sometimes I end up adding the email contact instead of the phone. It's so frustrating since a lot of my email contact list are either from strangers I've emailed only once a long time before OR old email addresses of my actual contacts (thus my confusion with the names) that they're not using OR old yahoogroups/school-related email addresses OR service-related addresses like Booking.com and such, since the account I am using with Google Play is the one I've used since I was in High School. It's just too much clutter in my phonebook.

    And it's only happening on my SMS contact list. My actual phone's contact list via the default Phone app is clean. -_-

    Thanks in advance for the help.
    11-27-2014 05:25 AM
  7. rsweat1's Avatar
    Not an good answer. There should be some way of cleaning this off the SMS contact list. I went to Samsung support and they have no solution. Hoping Andriod would come up with something. Guess not. Pretty sorry software. Seriously considering iphone. Android is having to many issues they are not willing to address. Poor customer service.
    03-05-2015 09:40 AM
  8. rsweat1's Avatar
    Ok folks I found this issue. It is with the google sms app. It is a flaw with the app. I downloaded app Hangouts and it only shows contacts on your phone. I would not sync your google account with this. Google and it's apps is the problem. I turned off the google app on my Galaxy S4 and using Hangouts. Works great
    03-05-2015 10:01 AM
  9. hiodie's Avatar
    So I found what I think is the solution, or at least my solution. The issue is sort of with the Messaging app, but also with Gmail. In gmail, if you go to contacts, there is an "Other contacts" that basically includes anyone you've emailed. I deleted all of these, and then went to the settings in Gmail, under the General tab, about midway down, there is an option for "Create contacts for autocomplete." This needs to be changed to I'll add contacts manually to prevent it from filling back up. Re-sync your account on your phone, and only the contacts you have added (or did not delete under the Other contacts) will remain.
    Charles0923 likes this.
    03-19-2015 12:11 PM
  10. Charles0923's Avatar
    Tried it and works like a charm. The problem is in the Gmail contacts settings for autocomplete, which keeps a record of every email addy you ever sent or replied to. Clear that out and re-sync the Gmail account on your phone and you should get a much cleaner list in the messaging contact list.
    09-14-2015 02:57 PM
  11. VAnative21's Avatar
    So I found what I think is the solution, or at least my solution. The issue is sort of with the Messaging app, but also with Gmail. In gmail, if you go to contacts, there is an "Other contacts" that basically includes anyone you've emailed. I deleted all of these, and then went to the settings in Gmail, under the General tab, about midway down, there is an option for "Create contacts for autocomplete." This needs to be changed to I'll add contacts manually to prevent it from filling back up. Re-sync your account on your phone, and only the contacts you have added (or did not delete under the Other contacts) will remain.
    Still works... THANKS!
    02-19-2016 01:15 PM
  12. VAnative21's Avatar
    Appreciate your help... here's the G-Mail link if anyone needs it (replace spaces with a period): mail google com/mail/u/0/#contacts
    02-19-2016 01:16 PM
  13. thebossofme's Avatar
    click on compose email/ click on to/ click on my contacts/ select all contacts/ check all contacts you wish to remove/ click on save as group at the bottom of contact list/ type in name/ go into gmail contacts list/ click on groups/ select group you wish to remove/ click on delete and select option: delete group and contacts.
    02-28-2016 10:30 PM
  14. kflowry7's Avatar
    I had same problem and found it is caused by Google+ contacts. Go to Google+ and scroll down list of contacts to find those you don't want. You will have to delete each one by clicking the contact, then telling it to delete contact.
    05-19-2016 11:56 AM
  15. kflowry7's Avatar
    Look at my solution, below.
    klowry7
    05-19-2016 11:58 AM
  16. androiduserjp's Avatar
    Open up the default text messaging app, click the three dots in a row and tap settings. Click general and uncheck "Show email address. That will stop your email contacts from showing up when you start a new chat.
    07-26-2016 05:15 PM
  17. dluciano88's Avatar
    Are you on Marshmallow? I have Lollipop on a Note 4 and don't have that option "Click general and uncheck "Show email address".
    07-27-2016 09:08 PM
  18. EdNerd's Avatar
    I've got Android version 5.0.1. I don't have the three dots in my stock SMS app. I don't have any options to not show email addresses. I can't find any way to turn off option for "Create contacts for autocomplete." Seems like every time they "update" something, they remove more of our control!!

    Ed
    11-26-2016 08:57 AM
  19. Mendez David's Avatar
    I have a Samsung Galaxy 6.

    When ever I would type in Messenger I would always get email addresses showing up in my predictive dictionary and it would sometimes overwrite my text and fill in email address, driving me up a wall.

    After a lot of trial and error what I did to stop that was this:

    Go to Settings
    Scroll down to the green menu options
    Select 'Language & Input'
    Under 'Keyboard and Input preferences'
    select 'Samsung Keyboard'
    Under Other Settings
    select 'Reset Settings'
    Once in there you can select 'Reset Keyboard Settings' or 'Clear Personal Data'
    I hit 'Clear Personal Data' and it took all of my email contacts out of my dictionary. For good measure I went back and hit 'Reset Keyboard Settings' in case my phone was set up to re-import my contacts in sync mode.

    It's done the trick.
    06-05-2017 01:04 AM

Similar Threads

  1. GO SMS PRO problems
    By mvp4him3 in forum Droid RAZR MAXX
    Replies: 6
    Last Post: 03-22-2015, 12:05 AM
  2. Version of the Moto X with bigger than 4.7'' in screen?
    By shamefulzero in forum Moto X (2014)
    Replies: 31
    Last Post: 06-02-2014, 09:33 AM
  3. Replies: 2
    Last Post: 01-03-2014, 03:51 PM
  4. Contacts Input
    By appliancemedic in forum Google Nexus 7 Tablet (2013)
    Replies: 6
    Last Post: 01-01-2014, 08:27 PM
  5. Will phones obey humans in 2014?
    By frednoyb in forum General News & Discussion
    Replies: 1
    Last Post: 01-01-2014, 06:35 PM
LINK TO POST COPIED TO CLIPBOARD