1. Faisal Irfan Yar Khan's Avatar
    Hi guys,

    I am a newbie here, so I will just explain it in layman's terms. I am running Android 4.3 on Samsung Galaxy S4 GT-I9500 variant. Its not rooted. I have been using it since I bought it a year ago, with no problems. Since yesterday my Gmail, Play Store, Hangouts are not working and it always give "No Connection" error. I tried clearing up the cache, clearing up the data of Google Play Store and Google Play Services as many other forums and threads have advised, but it's not working. I also tried the factory reset, and it went crazier as I wasn't able to sign in my Google Account in the first place. After trying again and again and again it miraculously signed in, but I still cannot access Google's other apps. I thought somehow the host file can be responsible for it but I don't know how it could be or how to fix it, if it is the culprit. I will be grateful to you guys if you can help out here

    03-14-2014 09:39 AM
  2. Golfdriver97's Avatar
    Welcome to the forums.
    Try resetting app preferences. Settings>application manager>menu>reset app preferences. This sometimes helps with Play issues.
    03-14-2014 10:14 AM
  3. Faisal Irfan Yar Khan's Avatar
    Yes. I have tried that to. But it doesn't seems to work.
    03-14-2014 10:18 AM

Similar Threads

  1. Replies: 4
    Last Post: 03-27-2014, 06:01 AM
  2. Backup app settings/phone without problems
    By jomak123 in forum Android 4.4 KitKat
    Replies: 8
    Last Post: 03-14-2014, 06:55 PM
  3. WiFi notifications force-closing some apps
    By Atranox in forum Verizon LG G2
    Replies: 0
    Last Post: 03-14-2014, 09:33 AM
  4. Spelling list for Spelling Bee app
    By Colin Burton in forum Samsung Galaxy Tab 2
    Replies: 0
    Last Post: 03-14-2014, 08:32 AM