1. bobbob1016's Avatar
    I'm pretty sure my issue is my battery, and I can swap it, but I want to make sure that's the issue before I so that. Seems to have happened all of the sudden, and am rooted so I'm not sure if something I may have installed that requires root and isn't showing up there.

    The only thing I've installed recently that I know of that way is Greenify though.

    Sent from my SPH-L720 using AC Forums mobile app
    Attached Thumbnails Can someone confirm if this is an issue with my battery?-1399477962909.jpg   Can someone confirm if this is an issue with my battery?-1399477989726.jpg  
    05-07-2014 11:56 AM
  2. androidcentral8450's Avatar
    Have you tried a different sync/charging cable? Additionally, have you tried this cable on another device?
    05-07-2014 12:49 PM
  3. bobbob1016's Avatar
    Happens with different cables. Using one from an Anker charger. It does get everything else I plug in to up to 100%. The phone also charges up from other chargers, just seems to drop. Even with JuiceDefender Ultimate on it's second option.
    05-07-2014 04:51 PM

Similar Threads

  1. Replies: 17
    Last Post: 05-30-2014, 11:59 AM
  2. Replies: 1
    Last Post: 05-14-2014, 12:18 AM
  3. My S3 screen is black.
    By Brooke Carlson in forum AT&T Galaxy S III
    Replies: 1
    Last Post: 05-09-2014, 02:19 AM
  4. Charging with 3.0 and 2.0 Cable
    By Omer San Gabriel in forum Samsung Galaxy Note 3
    Replies: 15
    Last Post: 05-08-2014, 02:04 PM
  5. Bigger Battery VS Power bank
    By Omer San Gabriel in forum Samsung Galaxy S4
    Replies: 4
    Last Post: 05-08-2014, 07:44 AM