06-03-2017 12:57 AM
72 123
tools
  1. kw-engineering's Avatar
    Hi everyone,

    Thank you for your efforts, and congratulations to all who have succeeded in eliminating this issue. Unfortunately for me, it is still a big problem. There's a lot to read here, but I'm trying to be thorough. Maybe some saint of a geek will take the time to read it all and we can help the world somehow, lol.

    The history on this goes back just a little too far for me to provide great detail, and I honestly can't remember when/why it first started to happen. But it started on my old phone, a Galaxy S Blaze from T-Mobile. I can't remember if I was having this problem before I bought my 2013 Ford Focus or not. I'm beginning to suspect that this may be heavily involved. For whatever reason, the phone would intermittently have no sound (both ways) during calls. Once the phone got in that state, it didn't matter if I tried bluetooth, speakerphone, wired headset, nothing worked!

    Whatever the case, it must have started quite a while after I first got the S Blaze, because I remember deciding to root it and go custom firmware (Cyanogenmod 10.1) to see if the problem would stop. I was considering doing the CM switch anyway, so this pushed me into it, rather than doing a bunch of other troubleshooting to find the root (pun intended!) of the issue. This makes me strain my brain to try and remember if there was any correlation between when the problem started and when I got the new car. Can't remember! All I know is, it wasn't ALWAYS a problem on that phone.

    Bummer was after rooting the phone, installing CM10.1, getting my apps back on there and blah blah, problem didn't stop occuring. Again, it was rather intermittent (maybe once a week) and fairly easy to recover from (reset phone repeatedly until a call to voicemail works again). Since I don't do a lot of voice calls and the recovery wasn't too difficult, I decided to live with this little issue until I could afford a new phone... which ended up taking longer than I thought. By the way, I will never buy a non-flagship, carrier-exclusive device again! What a dumb move.

    Finally out of frustration with the Blaze more than anything (battery life was real bad after 2.5 years, and it was starting to freeze OFTEN), I broke down and bought a refurbished Galaxy S4 LTE from the T-Mobile website last week, and it arrived preloaded with the newest 4.4.4 Kitkat firmware. I'm thinking, okay finally I'll have a perfectly working device again, after living with this buggy junker for so long. Don't know what was wrong with it, don't care, never looking back! I took great fun in smashing the worthless Blaze to bits Sunday night once my awesome new S4 was all set up and seemingly working flawlessly.

    I just about cried the first time this same damn problem happened on my newly refurbished S4!

    Now I'm really irritated. What could this problem be? across two devices, completely different firmware, what are the commonalities? I have googled this to the ends of the internet and tried everything under the sun on my new S4 (except haven't done a new firmware/ROM yet because it didn't help on the Blaze so I better try EVERYTHING else first this time). More on that below.

    Sidenote: On the GS4 the problem is much more persistent. It first happened on Monday at work, and Monday night I got it working again by restarting the phone a bunch (maybe 7 or 8 times) with a test call to voicemail after each restart. It happened again at work today, and for the life of me I cannot get the thing working again now. Really bummed.

    Here's what I have done with my brand new device leading up to the problem:

    1) Installed my Sony 32GB SD card from my old phone as well as the new smaller-sized SIM card.

    2) Activated the new SIM card online, and turned on the GS4 for the first time.

    3) Set up my Google account for Gmail/Play Store, and set up the built-in email app with my Hotmail credentials.

    4) Imported my contacts from the SD card.

    5) Installed a bunch of stuff like Nova launcher, PDF reader, QuickPic, CapturePro, Torch, a fairly long list of other apps/utilities, etc (again, I thought this loss of sound was a unique problem with my old phone so I wasn't shy about putting all my favorite apps right back on the new device).

    6) Tweaked the look and feel a bunch and configured the device to my liking, including disabling several of the included apps.

    7) Paired with my 2013 Ford Focus and did some bluetooth calling on Sunday.

    8) Took the phone to work Monday morning (this problem seems to always actually START while I'm at work. the first time it happened on this new device was on Monday, AT WORK. It is more or less just an observation, because I can't think of any sensible reason for this to be a problem. Is it because I just drove my car? Well I drive my car all the time, all over the NW).

    Troubleshooting notes:

    I don't use anything special with my phone at work, no company email or VPN or anything like that. It just rides in my pocket or sits on my desk connected to a charger all day, and doesn't even have data or wifi enabled (I rarely use/enable mobile data). I rarely make/receive a few texts or voice calls with it throughout the day. Could it be getting messed up by something at work because the bluetooth is left on, and then my phone gets somehow stuck in that state? I don't know what it could be, but the correlation is hard to ignore.

    I have never used any kind of voice search, nor did I even have any of those previously mentioned apps (S Voice or Google Now) installed on my hacked Galaxy S Blaze. Further, Google Now was one of the the built-in apps that I disabled on the GS4 when I first set it up on Sunday (I simply don't use voice search/voice commands/speech to text, any of that).

    I do not Bluetooth stream audio nor did I have the phone paired with anything else, just my car.

    After reading a lot of info online I did the following to try and get the GS4 working again tonight so I can call my brother back:

    1) Took out my SD card (and left it out) and rebooted. No fix (To truly eliminate this as a culprit, I left the SD card out through out all other steps below).
    2) Uninstalled every app that I had added to the device, including any app updates, and restarted phone. No fix.
    3) Triple-checked every setting! Touch sounds, noise reduction, extra volume, silent mode, call sound, voice control, voice search, wifi calling, bluetooth settings, network mode/settings, etc. No fix.
    4) Unpaired the device from my car (also deleted the device from my car's memory/menu). No fix.
    5) Did a hard reset (from powered off state, hold up volume + home key + power key for a few seconds to boot into recovery mode. navigate through the menu to factory reset the phone). No fix! Unbelievable! How can it still persist? Hardware problem maybe? No, i doubt it... because I had this problem on my old phone too, even after root and custom ROM install!! Same intermittent hardware issue on both devices? EXTREMELY unlikely!
    6) From fresh factory reset, no SD card installed, no new apps installed, no bluetooth paired, I disabled every single app the device would let me disable (this DID include both S Voice and Google Now). No fix.
    7) Even though Google Now was completely disable, I thought maybe it was a weird bug, so I turned Google Now app back on, turned the Google Now from any screen option off, and restarted phone just to fully test this proposed solution on my device. No fix.

    Now WTF do I do? Here's my plan:

    1) Do factory reset again, no SD card, no account setup, leave phone stock, no app updates, nothing. Just reset and that's it. Again, I tried this already and the problem persisted, but I will do it again to get back to a neutral starting point.
    2) Pair the phone with my Samsung Bluetooth headset, which should hopefully be compatible with my Samsung phone, durp durp.
    3) If the problem is fixed by doing that, I will adjust my approach to investigate why that fixed the problem, but I don't expect this to solve it, so from here I will do another factory reset and repeat this process a few times to see if the phone will start working again. My theory is that there could be some sort of hysteresis in memory regarding the paring of the phone with my car (which it might not be real compatible with?), and I might be able to flush it out by pairing it with a different, more compatible device a few times? I'm no software engineer, but hell it's worth a try.
    4) If the problem still persists, I will make one last ditch effort to work around it by installing custom firmware and setting up the phone very carefully, leaving bluetooth disabled and not pairing it with ANYTHING, to eliminate that as a culprit (that is, IF I can even get the thing to work correctly again after rooting it and installing the custom firmware).
    5) Last and final option if all of that fails is to restore to stock firmware, reset the warranty flag and return the thing to T-Mobile. Maybe it is time to explore options outside of T-Mobile and Samsung, as my last two devices provided by them have been quite problematic. It sucks when one of my customers calls me and I don't know if I should try to answer or not because my phone might be in this stupid state. I certainly never had this problem with my Nokia 5190 back in the day, lol. All the technology in the world and these new smart phones can't even work right as a PHONE.

    I'll send an update if anything good happens. If you don't see an update from me within a week or so, it means nothing above fixed my problem and I have likely abandoned the device, and possibly the carrier as well, depending on their support. If I have this issue crop again in the future with yet another device, I will try to get on here again and provide another update.

    Good luck, and keep fighting the good fight!

    -Kyle
    03-25-2015 12:46 AM
  2. Taras Levytskyy's Avatar
    So you guys know, you can avoid this problem by disabling media audio support on your bluetooth menu. This way, the google now will not work from your headset. It will work from any screen but only if you speak into the phone. This options works a lot better for me than disabling the google now detection since I only use the headset for talking while driving.
    03-25-2015 07:09 PM
  3. dm3ready's Avatar
    I've had the AT&T Lollipop update for about a week. After the update, I enabled "OK Google Detection...from Any Screen" and....I haven't had any problems!! <knock on wood>
    Has anyone else had similar success?
    04-21-2015 11:40 AM
  4. Doug Meade's Avatar
    I'm on AT&T with my S4 and I've yet to get lollipop :/
    04-21-2015 01:03 PM
  5. jamaica168's Avatar
    What seemed to work for me on kit kat is disabling the option to record audio through Bluetooth headset in the Google now voice settings. I was able to still have OK google from any screen.
    04-21-2015 05:17 PM
  6. bward11's Avatar
    Have you upgraded to Lollipop and tried this. I just upgraded (Verizon) but don't want to go through the hassle if you gurus out there have already done it and determine it doesn't work. Sure would like to have OK Google on all the time...
    05-08-2015 01:45 PM
  7. dm3ready's Avatar
    bward11 - My AT&T Lollipop upgrade fixed the problem!
    05-08-2015 03:37 PM
  8. Sharmarie's Avatar
    I'm having a similar issue with my Samsung Galaxy S5 & my 2015 nissan altima s......everything works great, except incoming & outgoing calls...i know it works because i made 1 voicecall out while practicing & i heard the phone dialing through my speakers. I can tell it to call, then name of contact, then dial..BUT after i say dial, my screen on car says dialing but i hear nothing and no response on phone...also when someone calls me, i hear and see nothing on either car or phone....when phone & car are paired of course. I would appreciate any advice or suggestions, thank you.
    07-22-2015 08:37 PM
  9. Rockler's Avatar
    My problem was solved when I deactivated the "OK Google" option from any screen.
    No problem since then.

    Posted via the Android Central App
    07-23-2015 05:13 AM
  10. bward11's Avatar
    The Lollipop upgrade did fix the problem. Though I only have OK Google after I select Google. Am very happy with the S4 now.
    07-24-2015 05:07 AM
  11. Sharmarie's Avatar
    My issue is now resolved because I followed advice in this forum about deactivation of "OK Google" option from any screen. Thank you all.
    07-24-2015 02:41 PM
  12. Rockler's Avatar
    You are welcome

    Posted via the Android Central App
    07-24-2015 02:43 PM
  13. Sharmarie's Avatar
    Well, looks like i'm back at square one, lol...same issue is back....i believe it is an android connectivity problem but not positive....hopefully i can solve soon, it's really a neat feature to have!!
    07-29-2015 01:10 PM
  14. Thisannoyingissue's Avatar
    This is driving me INSANE... I just spent $230 recently to make repairs to my S4. Got a car that has bluetooth and now my phone wont work which is a critical part of my business. The problem is I have tried disabling Ok Google, I have rebooted the phone today at the shop, and just feel if I go buy even an S5, I could have the same issue. Any other suggestions as it has not worked so far...

    Much appreciated!
    12-14-2015 03:43 AM
  15. bward11's Avatar
    I disabled Samsung Voice. The only place I have "OK Google" set to work is after I launch Google. I haven't had the issue since I disabled Samsung Voice.

    Posted via the Android Central App
    12-14-2015 05:27 AM
  16. nebrsunshine's Avatar
    Rirruto,

    You were right on ! We did what you suggested and have had no issues for two weeks . We blue tooth our Samsung 4 to our Panasonic wireless home phones and it is working great again. We still have "OK Google" but as you found out it has to be removed "for every application". THANK YOU.
    01-29-2016 07:25 PM
  17. richard tangitau's Avatar
    My issue has not returned since disabling the settings I noted above. I will have to live without the OK Google from any screen feature which is fine by me as long as my Bluetooth always works.
    I did all of this and still can't figure out why I still can't gear anyone on the other line...I have the same situation....I can hear a call on Bluetooth(in my truck)but can't hear anyone when I just talk regularly on the phone...so frustrated
    04-13-2016 02:07 AM
  18. ChipMuck304's Avatar
    I have the same problem. My 'OK Google' from any screen was already disabled, so I enabled it. Phone worked for 1 call. Now back to being a POS. Time to break down and get a new one.
    05-10-2016 09:17 AM
  19. sharenep's Avatar
    I hav the same issue with th NO sound from caller and by me. I checked my phone did a search and I do not have the OK Google/Google Now app installed. I cannot find anything about "from any screen" or anything. I turned my S Voice to off on all switches. It usually works, if not a reboot of phone will work. Very frustrating. Thank you.
    10-17-2016 10:34 PM
  20. Tmf33uk's Avatar
    I have a similar issue, but instead of the cars parrot, on my bluetooth headphones wth microphone.

    The difference is that the call sound, both my voice and the other person´s come out of the same device, so in the car it works fine.

    However, I have two phones on which I´m trying this. I have my Samsung Galaxy S5 connected to Mpow bluetooth magneto headphones, and through this, I call my tab2 tablet, which has no bluetooth device connected.

    When my voice from S5 is heard on tab2, I cannot hear anything from tab2 on my S5 phone.

    When bluetooth is activated on my call from S5, I can hear my own voice from S5 on the headphones connected to the S5, but it doesn´t get to the destination tab2. I can speak from tab 2 and hear it on the bluetooth headphones connected to S5. So, in this configuration, I can speak but not hear.

    When I unset the Bluetooth on the call (the phone stil has the bluetooth setting in overall mode), I speak into te S5´s bluetooth headphones and soud comes out of the S5 earpiece and the tab2 earpiece.

    This imakes it pretty awkard to attend meetings where I have to listen but also speak sometimes.

    I´ve unset OK Google altogether, but something is not quite right still, and I´m not sure what else to test. I start to think it´s not my headset that is faulty but my configuration somehow....

    Teresa.
    10-19-2016 10:21 AM
  21. DoneWithDroid's Avatar
    In the December 2016 timeframe, I started experiencing this issue with my bluetooth headset with no sound during phone calls. At first, a simple restart of my phone solved the issue. Then that stopped working. I thought my bluetooth headset was broken, so I bought a new pair. My new bluetooth headset didn't have audio either so I started exploring online forums. I tried disabling "Okay Google" from any screen and disabled S Voice, and it worked for about a week, then the problem came back again. The most frustrating part of this is that the audio will connect every once in a while and I can use my bluetooth headset for a few calls, but then the issue comes back. I know it's not my headset because I experience the same issue when I connect my phone to my bluetooth speakers through my car.

    When I make a call, I hear a beep as the call is initiated, but then there is no sound. If I turn the bluetooth off during the call, I can hear the other person and they can hear me. When I turn the bluetooth back on, I can't hear the other person and they can't hear me. I can listen to music and use "OK Google" with no problem, but the moment I go to make a phone call, the audio does not connect.

    Like I said, sometimes it works, but mostly it doesn't and it seems to be random when it does start working. I have not seen any other satisfactory answer on how to solve this issue on any forum other than disable OK Google from any screen. Is there anyone out there who is experience this same frustration and more importantly, does anyone have a solution on how to fix this issue once and for all? I have been patiently searching for a solution, but my patience is running out and I will be purchasing an iPhone soon if I can't find a solution.

    Thanks, ~M
    05-17-2017 10:07 AM
  22. Lee Credland's Avatar
    I had the same problem. Downloaded on android... "Bluetooth auto connect" with that you have full control of the Bluetooth. Solved my problem. Connected all audio first time.
    06-03-2017 12:57 AM
72 123

Similar Threads

  1. No Sound on Phone Calls after using Bluetooth
    By Rirruto in forum T-Mobile Samsung Galaxy S4
    Replies: 2
    Last Post: 07-28-2014, 02:07 PM
  2. Why won't my my Asus tablet read files/docs on my USB 2.0?
    By charlie98403 in forum General Help and How To
    Replies: 5
    Last Post: 07-16-2014, 01:40 PM
  3. Replies: 6
    Last Post: 07-15-2014, 03:25 PM
  4. DownloadHelper add-on for Firefox NOT available
    By Glas Ot Zalata in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 07-15-2014, 11:32 AM
  5. no connection optimizer on verizon ?
    By Jeff Harris in forum HTC One M8
    Replies: 2
    Last Post: 07-15-2014, 11:32 AM
LINK TO POST COPIED TO CLIPBOARD