1. gussie5555's Avatar
    Hi,

    I'm suddenly getting an entry in Notifications every day from the Messaging App. What is creating this notification and why when I click on the notification entry is it asking for my number to register?

    "Texting just got better" in Notifications every day !-2014-09-08-18.31.39.jpg

    "Texting just got better" in Notifications every day !-2014-09-08-18.33.53.jpg

    It's not an SMS just an app notification - why is this happening and how do I stop it.
    09-08-2014 03:18 PM
  2. bonpurple's Avatar
    I upgraded my firmware last night and have the exact same problem. The app info says its coming from IMS Framework but you cant turn off the notifications. This must be a bug

    Posted via the Android Central App
    09-08-2014 05:34 PM
  3. gussie5555's Avatar
    Yes - this is very annoying - for the past week, every afternoon I get this notification not once but several times!

    I thought it might be my carrier - Sainsburys Mobile here in the UK doing this but then I would see the SMS from them - but there is no SMS entry at all - just a mysterious notification with a mysterious request for my number for registration ??

    Before I posted, googling for this produced nothing!

    At least now anyone searching will find this thread and hopefully we'll get an answer soon.
    09-09-2014 03:54 AM
  4. Coopsdm's Avatar
    I got this message after a firmware update as well.
    I entered my number as requested and got a message telling me that I could now instant message with people who had done the same. I also got a warning to say that if I sent a picture or text to people who hadn't also enabled this option I would get charged at my normal carrier rate. As it doesn't tell you which of your contacts has enabled the option and which haven't it makes it redundant for me and ill keep using hangouts

    Posted via Android Central App
    09-09-2014 02:59 PM
  5. gussie5555's Avatar
    This is now p*****g me off!

    EVERY time my phone connects to a Wi-Fi network - I get this notification popping up!
    09-10-2014 03:06 PM
  6. nj101's Avatar
    I think this is related to the RCS service. You can disable it from the settings menu for text messaging -> Open the inbuilt messaging app (the usual place you receive text messages) -> Find the settings menu -> scroll down and disable the RCS Service.

    I used to get these annoying messages every time I connected to a wireless network but so far so good.

    NJ

    P.S. I'm sure this is just a bug that will be fixed in a later release.
    hubrad likes this.
    09-11-2014 03:50 AM
  7. gussie5555's Avatar
    Many thanks- that setting got rid of these annoying notifications.
    09-12-2014 03:26 PM
  8. hubrad's Avatar
    Nice answer, thanks nj101! I disabled RCS, so hopefully that's it.
    As an experiment, I re-ticked the box to switch RCS back on.. straight away that notification came up, which suggests RCS really is the problem. Now disabled it again. :-) Fingers crossed!
    12-04-2014 07:04 AM
  9. steve_ben2004's Avatar
    When i go to the SMS app and bring up the settings menu I get the following options

    Notifications
    Text Messages (SMS)
    Multimedia Message (MMS)
    General

    I have checked all of them and cannot see anything relating to RCS - any ideas ?

    My phone is an HTC One
    12-25-2014 07:18 AM
  10. dreasovic's Avatar
    On my S5 its different, maybe yours its similar:

    Messages
    Settings
    Default Messaging App
    Rich Communications
    Disable Rich Communications (RCS)

    Hope it helps!
    01-09-2015 03:50 AM
  11. Papi Hasanllari's Avatar
    On my S5 its different, maybe yours its similar:

    Messages
    Settings
    Default Messaging App
    Rich Communications
    Disable Rich Communications (RCS)

    Hope it helps!
    04-06-2015 02:34 AM
  12. markcam01's Avatar
    On Samsung S4 mini RCS can be disabled by going to:

    Settings
    Connections
    More networks
    Rich communications
    Tick off Rich communications
    07-23-2015 01:30 AM
  13. WPOTTER1950's Avatar
    On my S5 its different, maybe yours its similar:

    Messages
    Settings
    Default Messaging App
    Rich Communications
    Disable Rich Communications (RCS)

    Hope it helps!
    This worked for me and so many thanks for the tip. It started for when I changed the SIM from Vodafone UK to ALDI TALK Germany. Very annoyivng for a couple of dsys till I found your posting.
    11-12-2015 04:32 AM
  14. Costache Razvan's Avatar
    FOR HTC USERS !!!!
    SMS just got better issue ??
    htc one m9 .... this **** is killing me..... ;(((
    03-25-2016 01:29 PM
  15. Leest316's Avatar
    FOR HTC USERS !!!!
    SMS just got better issue ??
    htc one m9 .... this **** is killing me..... ;(((
    Had the same problem on my one m9. Got messages>settings>chat service then click yes to confirm rcs is to be disabled. Job done
    04-10-2016 09:43 AM
  16. cr355's Avatar
    okay buddy, this was driving me infknsane and nothing worked, so here's what I did:

    1. Settings
    2. Apps
    3. Small bar at the top >>> swipe till you see 'ALL'
    4. Scroll down to the little god damn app called 'Chat Service'
    5. Tap it and uncheck box at side of 'Show Notifications' better still then disable the SOaB


    Then, settings, Call, and ensure Cell Broadcast is unchecked too.

    Job Done
    anon(10156242) likes this.
    05-18-2016 02:57 PM
  17. anon(10156242)'s Avatar
    This happened to me this morning and was driving me mad too until I found this post, so thank you! The only slight difference on my phone (HTC) was that after selecting All Apps, 'Chat Service' wasn't appearing on my list of Apps. So after 'All Apps' I clicked the 3 dot menu icon on the top right of the screen, and then select 'Show System'. This prompted 'Chat Service' to appear in the list and I was then able to change the notification settings. Hopefully they stay that way...
    01-31-2017 07:10 AM

Similar Threads

  1. how do i create multiple text boxs snote
    By chionk in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 3
    Last Post: 12-10-2014, 08:09 PM
  2. Is the Moto G 16 GB version being sold in USA ?
    By gzzzz in forum Moto G (2014)
    Replies: 3
    Last Post: 09-19-2014, 08:00 PM
  3. DU Speed Booster or 360 sec better?
    By Slash GeaR in forum Ask a Question
    Replies: 1
    Last Post: 09-09-2014, 05:52 AM
  4. Moto 360 In Stock @ Google Play NOW!
    By LocationDudeNYC in forum Moto 360
    Replies: 4
    Last Post: 09-08-2014, 04:56 PM
LINK TO POST COPIED TO CLIPBOARD