1. mwventura's Avatar
    OK, so recently AT&T rolled out 4.4.4. I upgraded, everything worked fine. Then I decided to remove Facebook from my phone, and wrote did a couple of things break big-time.

    One was easy enough to fix - my contacts became corrupted, but since I store everything on Google I just deleted all contact info in application manager and everything pretty much synced back up.

    My calendars, though, have never recovered. I've uninstalled the Google calendar app and reinstalled, I've tried using the stock calendar, but I can not get any calendar info on my phone. In Google calendar, when I hit the settings drawer it says No calendars selected to sync.

    I've gone into Google account settings and manually done a sync. I've cleared calendar cache(s) (both Google and stock) in application manager. Uninstall, reinstall. Nada.

    Calendars are syncing fine on my Nexus 7 so this is just an S4 issue. I mention Facebook earlier because I am convinced that deleting their app is related.

    If anyone has had a similar calendar issue and managed to solve it, I'll buy you a beer if you can throw some advice my way. (Restrictions apply, limited time, etc.)

    Thanks!

    Posted via the Android Central App
    11-19-2014 02:53 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you tried removing your Google account completely in Settings>Accountsā€‹, then adding it back again?
    11-20-2014 12:59 AM
  3. mwventura's Avatar
    OK, just tried that but no dice. Weirdly (and somewhat related), I can find nowhere on the phone to add a calendar account. In attaching a screenshot of what Google calendar tells me; stock calendar has even less to say.

    Posted via the Android Central App
    Attached Thumbnails Google Calendar no longer syncing on S4-screenshot_2014-11-19-22-30-57.jpg  
    11-20-2014 01:37 AM
  4. B. Diddy's Avatar
    From that screen, tap Settings. Do you see your Google account listed there, with the calendars below?
    11-20-2014 11:23 AM
  5. mwventura's Avatar
    Just General and Events from Gmail. No Google Accounts, no options to add anything.
    11-20-2014 12:54 PM
  6. B. Diddy's Avatar
    Hmm. I think you did this already, but just to make sure--go to Settings>Accounts-Google>[your Google account]ā€‹, and make sure Calendar is checked.

    Also, in Settings>Apps>All, select Calendar, and Clear Data along with Cache. Then open it again and see if it resyncs.
    11-20-2014 02:04 PM
  7. mwventura's Avatar
    So there are notices about sync issues (that again arrived after deleting Facebook app). And interestingly: in the Google accounts, no option to sync calendars at all.

    Posted via the Android Central App
    Attached Thumbnails Google Calendar no longer syncing on S4-screenshot_2014-11-20-22-12-16-01.jpg   Google Calendar no longer syncing on S4-screenshot_2014-11-20-11-32-41-01.jpg  
    11-21-2014 04:01 AM
  8. B. Diddy's Avatar
    That's really odd. Have you disabled any apps? Like Calendar Storage? Go to the App Manager, tap the Menu button, then tap Reset All App Preferences (which re-enables all disabled apps). Then reboot, and see if you get the Sync Calendar option back.
    11-21-2014 11:27 AM
  9. mwventura's Avatar
    WINNER! I didn't even restart the phone.

    You know, I was probably trying to find a way to get the annoying stock calendar to leave me alone and must have disabled something at that time. (It has a habit of turning its notifications back on no matter what i do.) Guess I can stop blaming Facebook for this one.

    Thank you for sticking with it - I guess in hindsight it's better to get 2 calendar notifications rather than none!

    Posted via the Android Central App
    B. Diddy likes this.
    11-21-2014 12:09 PM
  10. B. Diddy's Avatar
    Awesome! If you don't want the stock Calendar to give you notifications, you should be able to turn them off in the Calendar app's menu, or uncheck "Show notifications" in Settings/Apps/All on the Calendar app info page.

    Posted via Android Central App.
    Please excuse any typos or autocorrect derps.
    Joe Lowry1 likes this.
    11-21-2014 03:35 PM
  11. mwventura's Avatar
    Yeah, Samsung is terrible about this stuff. I think that resets every time the phone restarts or the app updates or something. It is so obnoxious.

    Nice Crow avatar, btw!
    B. Diddy and Joe Lowry1 like this.
    11-21-2014 05:49 PM
  12. B. Diddy's Avatar
    Crooooooooow!
    Joe Lowry1 likes this.
    11-21-2014 11:02 PM
  13. melanied's Avatar
    I tried what you suggested. Didn't work for me. Unfortunately I didn't come across this thread until just now. Got frustrated a few days ago and thought maybe deleting the stock calendar would help, and now I can't get it back. Do I need S planner for any calendar to work or is there a way around it?
    11-24-2014 03:38 PM
  14. Joe Lowry1's Avatar
    I made a loggin just to thank you for this. I use my calendar for business during the warm weather so didnt notice it wasnt updating till today. unsure how long it has been not working but it was aggravating because all of the things I was trying that people said wern't working and as the previous poster mentioned the options weren't even there to select.lol. thank you and best wishes.
    12-30-2014 12:07 PM
  15. John Boyle2's Avatar
    My wife discovered that her calendar was not syncing with Google. She uses the default calendar (not the Google calendar). I went into Applications and cleared the cache and data for that calendar. It cleared everything off that calendar. Shortly it synced everything back. She then made a new events at the Google Calendar on internet and on her phone calendar. Syncing in both directions works. Thanks for the help tips!
    02-12-2015 11:09 AM

Similar Threads

  1. Replies: 30
    Last Post: 12-19-2018, 09:58 PM
  2. Replies: 22
    Last Post: 11-27-2014, 08:10 PM
  3. Replies: 1
    Last Post: 11-20-2014, 01:04 AM
  4. Replies: 2
    Last Post: 11-19-2014, 12:05 PM
  5. Why is my Galaxy S4 Active disabling data while idle?
    By mxlv85 in forum Ask a Question
    Replies: 0
    Last Post: 11-18-2014, 11:10 PM
LINK TO POST COPIED TO CLIPBOARD