1. Chris Wathen's Avatar
    I've had a problem with my S4 GT-I9505 for a few months now in that the main camera doesn't work, either through the camera app or through *#0*#. In the camera app I'll get the 'Camera Failed' error, in *#0*# I get 'Data Line Failed' before 'Camera Failed'.

    The front camera is still working, and apart from the camera problem the phone is not exhibiting any other problems and is still completely stable. The last time it worked was 31st October, the day before an OTA update came through. Although nothing was reported about this update messing up the camera, to me it still seems a big co-incidence that it was fine until then.

    I tried the usual fixes of clearing the cache, wiping the cache partition and factory resetting the phone. I've also replaced the camera with a new one in case it was a hardware fault.

    When that didn't work, I went back to the theory that the firmware update broke the camera, and so installed cyanogenmod, this did nothing. I've since re-flashed a freshly downloaded copy of the carrier-specific stock rom and disabled all options to auto-restore the device so the phone is now back to a completely out-the-box state with nothing else installed which could possibly conflict. Still no camera. Unless the motherboard itself is faulty, I don't know what else to try.

    Would be grateful for any ideas!
    01-24-2015 06:49 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! You're probably right--I'd bet it's a motherboard issue, perhaps with the circuitry connecting the camera to the CPU.
    01-26-2015 06:49 PM
  3. Chris Wathen's Avatar
    Was afraid of that, decent motherboards which aren't silly money/and or from outside the UK with insane postage charges don't seem to come up on eBay very often either, looks like the trusty old Atrix 4G will have to be pressed back into service until the contract expires later in the year then.

    A shame that, loved the S4 to pieces until this happened.
    01-27-2015 01:59 PM

Similar Threads

  1. Replies: 2
    Last Post: 10-22-2015, 10:29 AM
  2. Replies: 1
    Last Post: 02-05-2015, 08:21 AM
  3. How do I open the place on the phone I plug on the charger?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-26-2015, 06:59 PM
  4. Not all contacts are appearing during sync
    By maxo2 in forum Android 5.0 Lollipop
    Replies: 1
    Last Post: 01-26-2015, 06:53 PM
  5. Replies: 0
    Last Post: 01-24-2015, 04:50 AM
LINK TO POST COPIED TO CLIPBOARD