1. AC Question's Avatar
    I got this sprint galaxy S4 from my family and it is not registered so I have it connected to my home wifi which I can get to the internet, chrome, galaxy apps, etc. but when I try to connect to the Google play store it says No Connection retry. why?
    03-30-2015 12:50 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Are your date and time exactly correct?
    03-31-2015 12:34 AM
  3. weddlini's Avatar
    yes the date and time is correct, it might also help to tell you that the problem persist even after doing a factory reset.
    04-01-2015 11:56 AM
  4. B. Diddy's Avatar
    I was just responding to someone else with this problem. Never quite sure what causes it. You've tried it on other wi-fi networks, or on mobile data?

    If you're totally stuck, you could consider going to the App Manager, selecting Google Play Services, and Clearing Cache/Data. But I'll be honest, I'm not sure what other consequence that might have.
    04-01-2015 04:56 PM
  5. weddlini's Avatar
    I have finally figured it out after all this time, I went to an app just messing around (I think it was the google maps) and it said something like I needed to update google store play apps or something like that. After that I tried to go the google play store and it worked!!!
    04-30-2015 09:39 PM

Similar Threads

  1. throttle?! why?
    By angelisawesome in forum T-Mobile
    Replies: 98
    Last Post: 07-07-2015, 11:07 AM
  2. Anybody get the email from Ed?
    By PhyscoAssassinX in forum HTC One M9
    Replies: 17
    Last Post: 03-31-2015, 10:39 PM
  3. Why does my car answer my S3 MINI even when it's off?
    By joelfish1 in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 03-30-2015, 09:20 AM
  4. Replies: 1
    Last Post: 03-30-2015, 09:18 AM
  5. How do I bypass lock screen on a I CRAIG tablet?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-30-2015, 12:48 AM
LINK TO POST COPIED TO CLIPBOARD