1. solquiff's Avatar
    Hi

    Been having trouble lately with my s4 mini and yesterday I saw an app called SuperSU, which I am unable to download. I googled this and started reading all about rooting a phone, i had no idea about any of this until yesterday. I got the phone in january as a present and I believe it may have been refurbished and/or unlocked so I could use a different network provider. I had never really noticed the app before.

    I downloaded an app to give me details about all my apps (when they were downloaded etc) and it says it was installed on 1st jan 2013 (2 years before I got the phone). I also downloaded an app to confirm root and the pop up for the permissions came up and i clicked accept-it said phone was rooted.

    Today however i tried the same rootchecker again and i didnt get the pop up asking for superuser permission and it says it isnt rooted. What I know for certain is that the SuperSU app is on my phone and cant be deleted.

    How could it have gotten there? Was the phone rooted in order to unlock it?

    Could the phone have been rooted without my knowledge? (unlikely due to the super su install date). Also from what ive read to root it needs to be connected to a computer and my phone has never been out of my sight for long enough for someone to do that, besides noone I know has ever heard of rooting.

    Should I have any thing to worry about. I wanted to get into recovery mode yesterday and it wont work - I think it may have something to do with the phone being rooted. Thanks in advance
    07-29-2015 04:05 PM
  2. Almeuit's Avatar
    It sounds like the phone was rooted which could have been done to unlock it.
    07-29-2015 04:22 PM
  3. solquiff's Avatar
    Hi thanks. Have you heard of that being done before? My phone hasnt been tapped or anything? Just a bit freaked out as weird things have happened yo the phone like restarting itself..settings opening randomly..time changing..apps opening themselves. Thankd
    07-29-2015 05:02 PM
  4. solquiff's Avatar
    I must add that the phone has never been in developer mode. it is just the super su app on the phone. Yesterday when I tried to check if it was rooted or not using rootchecker - a pop up appeared asking for permission, i clicked accept and it said it was rooted. i did it again but this time clicking deny and it said the phone wasnt rooted. today when i tried this again I get no pop up asking for permission. Why is that? because I tried to delete the super su app? Should the permission pop up not happen every time I check if the phone is rooted or not on rootchecker.

    thanks again in advance, im a bit freaked out about this. Could someone be tracking my phone through the super su app even though the phone is not in developer mode? I dont really understand what is going on. thanks
    07-29-2015 06:33 PM

Similar Threads

  1. Replies: 5
    Last Post: 07-31-2015, 11:53 PM
  2. Replies: 1
    Last Post: 07-29-2015, 04:03 PM
  3. How do I display the date on a picture on my Galaxy 4 Tab?
    By grantswartz in forum Ask a Question
    Replies: 0
    Last Post: 07-29-2015, 03:57 PM
  4. Why did my Samsung Galaxy S4 mini activate the emergency safety feature?
    By AC Question in forum Samsung Galaxy S4 Mini
    Replies: 0
    Last Post: 07-29-2015, 03:48 PM
  5. Replies: 0
    Last Post: 07-29-2015, 03:41 PM
LINK TO POST COPIED TO CLIPBOARD