1. Misbah Gulamnabi's Avatar
    I have downloaded files and stuff from the internet for so long and 2 weeks ago it just randomly started saying download failed every time I tried to download something. I have tried all sorts to fix this problem. I have reset the internet settings. I have cleared the cache on the internet and the download manager and all the apps on my phone. I tried to download with google chrome and it also said download failed. when updating apps or downloading apps from the play store it works just fine. I have also read that it might be a corrupt SD card so I formatted it and it still wont let me download. my SD card isn't corrupt either as it works fine and I've been using it for awhile without any problems. I just cant figure out what could be causing this.
    09-03-2015 06:04 PM
  2. B. Diddy's Avatar
    Welcome back! Does it download to Internal Storage without difficulty?

    Try wiping the cache partition: http://support.t-mobile.com/docs/DOC-5744.

    Also, when you cleared the cache from the Download Manager, did you also Clear Data?
    09-03-2015 07:28 PM
  3. Petr Tanker's Avatar
    I've got same problem. Just set your download folder (whatever internet browser you use) to your internal storage!
    09-05-2015 05:35 PM
  4. Misbah Gulamnabi's Avatar
    I tried that as well. Still says download failed.
    09-08-2015 06:41 PM
  5. Misbah Gulamnabi's Avatar
    Yes I cleared the data as well as the cache from the download manager. And I also did the same to the internet browser and Downloads as well. l wiped the cache partition too. doesn't seem to have made a difference. /
    09-08-2015 07:02 PM
  6. B. Diddy's Avatar
    Sorry, just to clarify--do the downloads fail even when you're downloading to Internal Storage?
    09-08-2015 08:22 PM
  7. Misbah Gulamnabi's Avatar
    09-10-2015 04:01 PM
  8. B. Diddy's Avatar
    Try booting into Safe Mode: https://support.t-mobile.com/docs/DOC-11724. If you still can't download in Safe Mode, then you may have to do a factory reset.
    09-10-2015 08:23 PM
  9. Misbah Gulamnabi's Avatar
    I tried safe mode but it didn't work. Guess I'll have to factory reset, thank you though!
    09-11-2015 06:29 PM
  10. heart_crafter's Avatar
    I had same issue on a cm13 ROM...
    Force closing chrome from settings then disabling n enabling fixed it for now.
    darkNiGHTS likes this.
    12-20-2016 11:43 PM
  11. arnearnearne's Avatar
    yes, force closing and disable/enable fixed it for me too.
    02-23-2017 07:49 PM
  12. ROBYN987's Avatar
    Here is the real answer....go to settings...open WiFi connections...open mobile data....then choose your correct phone type...example LEG 4 or 2G or 3G then it fixes the problem...you can always go to Google play apps and download smart tutor...open it and agree to let Samsung take over your screen..dial the 880 number on app and from there Samsung will be able to see your screen in real time and can fix any problem you have w your phone..
    01-23-2018 12:20 PM

Similar Threads

  1. Why won't my videos from my gallery upload on instagram? S5
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 12-02-2017, 01:48 PM
  2. Why won't my samsung galaxy s5 update to lollipop?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-12-2015, 04:00 PM
  3. Is it possible to UNROOT a galaxy note 4 model SM-N910C UD SL
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 09-04-2015, 10:48 AM
  4. Replies: 0
    Last Post: 09-03-2015, 05:56 PM
  5. Replies: 0
    Last Post: 09-03-2015, 05:51 PM
LINK TO POST COPIED TO CLIPBOARD