12-31-2016 12:15 AM
35 12
tools
  1. Arianne Unice Eusebio's Avatar
    Please help.I can't save the text I added...it says "can't write file" and "read only file system" ...how can I fix it?
    04-16-2016 08:00 AM
  2. Mustang5point0lx's Avatar
    I'm sure glad I found this. I had been thinking about unrooting my S4 so I could get the Lollipop update. I've been hesitant about updating for the last couple of years. In fact, I rooted so I could delete the system updater and prevent KitKat 4.4.2 from wrecking my phone. I've been seeing some pretty bad updates the last few years, but this... this is ridiculous! Actually burning out parts of the front screen area. Unheard of.. til this. In NO way should the owner be responsible for this. Samsung is always trying to avoid any kind of responsibility for damages not caused by the buyer. .....
    04-22-2016 04:16 AM
  3. Mustang5point0lx's Avatar
    Please help.I can't save the text I added...it says "can't write file" and "read only file system" ...how can I fix it?
    Arianne, please make sure your file management app is given Superuser Permissions. Otherwise it will not be allowed to write in a system folder. You could also try this... copy the build.prop file to a folder on your SD card. Download the app "Simple Text Editor". Run the app, open the copy of "build.prop" file on the SD card. Add the specific line mentioned. Save the file . Niw open your file manager app. Make sure to give Superuser permissions. Go to the /system folder and delete the build.prop there... now go to your SD card and (Copy) that version of build.prop . Go back to /system folder and paste that file. Or.. if it wont let you delete, just copy the version on the SD card and then paste in the /system folder (overwriting the other version)
    04-22-2016 04:32 AM
  4. s0lara's Avatar
    Folks,

    I just want to say thanks for all of your input so far. I have been following this thread for a while as I have had the same issue as you all. Bl**dy soft keys have gone walkabout!

    Unfortunately for me I have no Samsung support as I'm using a pre-loved S4 after my device decided to retire itself. And although I am more than technically capable to replace the digitiser and screen I decided to look for a low/zero cost option. I have found a suitable sidestep that i think is worth considering as it gives near normal function. Please find following the steps to enable the onscreen soft keys. These can be used if you don't have to worry about invalidating warranties.

    1: Root the device - I used free app called Kingo ROOT. It was a relatively pain free procedure. (You can research the steps to use this yourself.)
    2: Install a decent File Explorer App that can be given Super User permissions to the devive - I used ES File Manager from the Play Store
    3: Start the File Explorer app and in the settings you should be able to give the app Super User permissions. Also change the settings to show hidden files/folders
    4: Browse to the ROOT of the device storage
    5: Open the './system/' folder and locate the 'build.prop' file for editing
    6: Add the following line to the end: qemu.hw.mainkeys=0
    7: Close, saving changes
    8: Reboot the device

    Its not a perfect solution but at least you'll have interactive soft keys without spending any cash on new hardware.

    I hope this helps guys

    Credit must go to User "steevaavoo" - (http://forums.androidcentral.com/mem...aavoo-2313210/) as i used some of the steps that he provided in the following post: http://forums.androidcentral.com/sam...soft-keys.html
    Thank you, thank you, thank you!!!
    05-04-2016 01:49 PM
  5. Hfs Sta's Avatar
    Cant edit or replace build.prop: "Read-only file system"
    Have SuperSu to grant permission. But EsFileExplorer does not request permission. Nothing under Es..Settings. Other apps request and granted OK.
    Rooted ok, Android 5.0.1
    Properties of build.prop and System show:
    readable: yes
    writable: yes
    Hidden : no
    How do I modify build.prop?
    thanks for any help to get my I9505 to give me soft buttons?
    05-19-2016 09:41 PM
  6. la morenita's Avatar
    have they fixed you phone in the store for free??? I have the same issue and I took it to the support centre just to be told that I have to pay for it to be fixed as it is out of warranty. It s just unrealistic
    06-06-2016 11:41 AM
  7. la morenita's Avatar
    For those who encounter this issue I have found a temporary solution posted on youtube, is working but is a bit of a hassle , but then you can have acces to back and menu options. SETTINGS>>MY DEVICE>>ACCESSIBILITY>>DEXTERITY AND INTERACTION>>ASSISTANT MENU turn it on. Hope it helps. Is helping me while I await for a reply from Samsung as I am not going to pay(they asked me to pay for repair as the phone is 3 years old) for them to repair it when it is not my fault an not a waranty issue.
    06-06-2016 01:00 PM
  8. damson rhee's Avatar
    any updates on your run in with samsung customer service on your issue?
    06-16-2016 02:05 PM
  9. Rick Schweitzer's Avatar
    Well it would apear that as warthog55 has already posted that it is in fact the Display Assembly that has been damaged. I have never come across anything like this before. I have well over 28 years as a Firmware Engineer and this is a first.
    As most of you on here have posted I did the automatic firmware upgrade after which the soft keys stopped working. It was not dropped or exposed to any fluids during or after the upgrade. So that only leaves the actual firmware or the upgrade process. I obviously don't have the schematics to work out what could have happened. At a wild guess I would look for something voltage related to these keys. If the voltage to these keys is programmable from the firmware. I have the Snapdragon 600 version as most European S4s will do. As the problem for me was just the soft keys it would be the most likely place to start. As I posted above my phone is now working perfectly after Samsung replaced the Display Assembly. I did read somewhere that someone had gone back in versions of firmware and that they got the keys to work again. How reliable that post was I don't know.
    I hope this help in some way for those of you still trying to fix the problem.

    Posted via the Android Central App
    New to this forum, but not the problem.

    I had not one but two S4s with the exact same issue. The OTA software update killed the menu and return keys. The version was 5.0.1, software date of November 2015. A previous update of August 2015 worked fine.

    These phones were only 30 days old. Essentially, leftover new stock. One phone the vendor I purchased from took it back for full credit! The second one they couldn't as it was greater than 60 days since purchased. This was my fault as I spent 30 days trying to fix it.

    I contacted Samsung support and any phone out of warranty was $$$ to fix. I argued that this was not a warranty issue, it is a problem Samsung caused with two phones and I have proof. In any case, I manged to get a reasonable repair cost and took it. So, sending the phone in for repair.

    And yes, I tried every conceivable method to fix the issue and nothing worked. Also, this phone had a case and a glass screen protector and is in mint condition. I treat my electronics with kids gloves.

    How many S4 owners have experienced this problem and trashed a perfectly good phone for a new one?
    06-23-2016 08:18 PM
  10. marauder1776's Avatar
    I give up. Nothing works. I will never buy Samsung again.
    12-31-2016 12:15 AM
35 12

Similar Threads

  1. Replies: 2
    Last Post: 01-11-2016, 08:46 PM
  2. How DO I get Regular Keyboard back on Samsung Galaxy 10.1
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-20-2015, 11:00 PM
  3. Nexus 7 (2013) Problems after updating app
    By RickBS in forum Google Nexus 7 Tablet (2013)
    Replies: 1
    Last Post: 09-20-2015, 10:59 PM
  4. Samsung Grand Prime-Message organization
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-20-2015, 09:29 PM
  5. Backup not found
    By mkdll in forum HTC Desire 626
    Replies: 0
    Last Post: 09-20-2015, 09:29 PM
LINK TO POST COPIED TO CLIPBOARD