12-30-2016 11:15 PM
35 12
tools
  1. Wilkinson Pugay's Avatar
    Please help!!!
    My S4 is version 5.0.1 then an update came yesterday. I guess it is just some enhancment update and it took around 30mins to finish. After the said update, my soft keys both back and menu buttons are not working anymore, no lights too. Please help. Thank you very much!!! I already had a factory reset but still the soft keys are not functioning.
    09-20-2015 08:38 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! After the factory reset, did a lot of your apps automatically reinstall? If so, some 3rd party app might be causing the problem. Try booting into Safe Mode, and see if the problem persists: https://support.t-mobile.com/docs/DOC-11724
    Wilkinson Pugay likes this.
    09-20-2015 09:52 PM
  3. jspaih's Avatar
    HI ...
    ive just downloaded that update and faced the same problem ... i tried to enter safe mode but its not working
    any other solution please .
    thanks
    09-21-2015 04:30 AM
  4. B. Diddy's Avatar
    Welcome to Android Central! Try using Kies to reinstall the firmware: How do I Upgrade the Firmware for my device using Kies 2.6?. Or you could bring the phone to your local Best Buy and ask the Samsung rep to reflash the firmware.
    Wilkinson Pugay likes this.
    09-21-2015 11:08 AM
  5. Petr Tanker's Avatar
    Reinstal your firmware or make thru RECOVERY wipe data/cache! (POWER+HOME+VOL UP)
    Wilkinson Pugay likes this.
    09-21-2015 07:32 PM
  6. Wilkinson Pugay's Avatar
    Hi! Have you already tried their suggestion of reflashing the firmware? Did it work to you? I have not tried it yet. Thanks
    09-24-2015 01:14 PM
  7. ss4-7's Avatar
    I have the same problem...no solution so far
    09-25-2015 05:41 AM
  8. Rakesh Kumar Chhatwani's Avatar
    I am also facing the same issue with my Samsung S4; and I have seen several posts in which many s4 users have complained about the same issue with update to Android Lollipop.
    09-27-2015 03:37 PM
  9. elettronicpassion's Avatar
    Hi, I have the same problem after the same update. Has anyone of you fixed the bug? Please help me!
    11-19-2015 08:09 AM
  10. Massha Brancin's Avatar
    Hello, I have the same problem - soft keys not working after auto updating of software from unknown to 5.0.1

    I did firmware downgrade with odin from 5.0.1 to 4.4.2 and soft keys are still not working.
    Are there several types of same version of firmware? or is there any other kind of problem?
    11-19-2015 04:34 PM
  11. elettronicpassion's Avatar
    //forum.xda-developers.com/galaxy-s4/help/problems-official-update-signal-soft-t3250132/post63904021#post63904021

    Have a look at this. I haven't tried yet because I have Internet out of order at the moment. If you try, let us know the result.
    Thanks
    11-20-2015 05:07 AM
  12. Nahim Ahmed's Avatar
    I have created an account on here today especially as my buttons have ceased to work. I have done a factory reset and ran it in safe mode and the buttons are still not responding.

    Would very much appreciate a solution for this.
    11-24-2015 02:25 PM
  13. Martin3107's Avatar
    Hi I have same problem and I've tried everything so I contacted Samsung and apparently the only way to fix is to take it to your nearest Samsung store and they can do it whilst you wait and there is no charge for this to be fixed as it's a firmware/software problem
    12-05-2015 03:53 PM
  14. Suyogya's Avatar
    I have upgraded my samsung s4, after the upgrade menu and back soft key are no more working...
    01-03-2016 10:02 PM
  15. xAgonyofArix's Avatar
    I can't believe this happened after the update. I guess I'm lucky,because my buttons work, but the back button doesn't light up anymore. I just turned the other light off too.

    Posted via the Android Central App
    01-04-2016 06:24 AM
  16. Elmojo's Avatar
    I testing day at the Samsung Experience store Leeds UK yesterday. I have the non function back and menu problem too. The Salesman went off behind the scenes to talk to the engineers and came back and told me that the soft keys would have to be replaced. I asked him why. He said that the update bad blown the keys. I should point out that I am an MSc Computer Science and have been a Firmware Engineer for over 30 years. I have never heard of anything like that happening in that time. As we usually blow the prototypes in a very short period of time long before customers get hold of anything.
    He then said he could replace it for free with a S6. As you can imagine this came as shock. A happy one at that. I then decided this can’t be right. So I asked him why. He said my phone was out of warranty and because of that they would not carry out any work on it. After more questions his idea was to sell me a contract phone. Nice one Samsung infact almost cruel.
    I then pushed him on why the keys had blown. He stumbled came out with a load of rubbish. I told him that the ARM I/O ports would be 3.3v and it was very unlikely that 5v or 12v would be anywhere near them. I asked him if he understood that it was the Samsung Lollipop 5.0.1 update that has caused the problem to your own hardware and that I didn’t consider this a warranty issue. He then gave me the number for customer support they then gave me the warranty not active. After about an hour of going around in circles they then said if I had proof of purchase I could get my warranty active. Who has this after everything works for a period time. I do this must have come as a shock to them.
    I then had to travel all the way home and contact them again to email them the proof of purchase. However, the guy I talked to on that occasion seemed to get the point of what I had been saying all day. The main problem he said was that they were not aware of this issue. So there is no fix in the pipeline for the soft key issue. As the new lollipop 5.1.1 is now being rolled out I can’t see it having a fix.
    So a lack of calls to Samsung to highlight this issue has not helped.
    However, how this and the other issues well known on this site got past testing on S4 and S5 devices is nothing short of an embarrassment for developers at Samsung. As these issues started to come to light 5 months ago l find it difficult to forgive. Then to be treated as I was by support in the Leeds store and then the Sheffield Customer Support people only goes to show a lack of respect.
    I am now waiting to find out what they are going to do about their software not working on their hardware. The automated update doesn’t give you the chance to go back. Yes I could use Kies or root my phone. But that would cause Samsung more room to tell me all about terms, conditions and Company policy. I don’t think I want to lose the will to live again. I don’t consider this a warranty issue. So come on Samsung you have messed up big time now fix it

    Posted via the Android Central App
    02-12-2016 09:14 PM
  17. brettbjc's Avatar
    Please eveyone on who has posted kn here and reading this. This is affecting 1000s of people with s4 and s5. Samsung knew about this problem 5 months ago when the uodate came out and not stopped anyone from updating to this faulty update, nor have they tried to fix the problem. Please just spend 5 mins of your time to go to the watch dog website on bbc to report it. It really doesnt take long to fill out form. Just type the problem we are all having. Samsung wont reacte to forums complaining. So lets get this on tv so we can get this problem sorted out. The more people complaining to watch dog, the more chance they will run the storey
    Jt Justus likes this.
    03-06-2016 11:53 AM
  18. Jt Justus's Avatar
    I'm facing the same issue, after a kies update to lollipop 5.0.1 my soft keys fail to work, any solutions?

    Posted via the Android Central App
    03-14-2016 06:13 PM
  19. Elmojo's Avatar
    I have now sent my phone to Samsung and it is back and working perfectly. After several heated discussions with Samsung support they claim to be in the dark to this problem. I at first thought that it can't be possible. However, if you look on the Samsung site you will find some very poorly explained complaints about this issue. So this might explain to some extent the poor response from Samsung on this issue. As I said in my recent email I am a firmware engineer myself so I backed up everything before and after the Samsung fixed it. Hopefully I will have time to find what they did in the configuration to fix the problem. Of course I will share anything I find that is helpful. Luckily I still had my reciept and went through the lengthy process to my phone fixed. I am still very unhappy with the Salesman in the Leeds store who said I could have an S6 as a replacement. He knows who he is and he should be ashamed of himself.

    Posted via the Android Central App
    03-18-2016 05:17 AM
  20. WartHog55's Avatar
    Got the same issue too, During an update to Lollipop the lower part of the screen was getting quite hot. After update the light buttons didn't lit up anymore and also didn't work. Tried a lot to recover the light buttons but nothing helped. I had to replaced the complete screen LCD+Front digitizer and now all is in perfect working order. Nothing else will help.. If the light buttons are gone after an firmware update to lollipop you're screwed..
    03-19-2016 01:53 PM
  21. Elmojo's Avatar
    Well it would apear that as warthog55 has already posted that it is in fact the Display Assembly that has been damaged. I have never come across anything like this before. I have well over 28 years as a Firmware Engineer and this is a first.
    As most of you on here have posted I did the automatic firmware upgrade after which the soft keys stopped working. It was not dropped or exposed to any fluids during or after the upgrade. So that only leaves the actual firmware or the upgrade process. I obviously don't have the schematics to work out what could have happened. At a wild guess I would look for something voltage related to these keys. If the voltage to these keys is programmable from the firmware. I have the Snapdragon 600 version as most European S4s will do. As the problem for me was just the soft keys it would be the most likely place to start. As I posted above my phone is now working perfectly after Samsung replaced the Display Assembly. I did read somewhere that someone had gone back in versions of firmware and that they got the keys to work again. How reliable that post was I don't know.
    I hope this help in some way for those of you still trying to fix the problem.

    Posted via the Android Central App
    03-23-2016 01:54 PM
  22. MightyPeanut's Avatar
    Folks,

    I just want to say thanks for all of your input so far. I have been following this thread for a while as I have had the same issue as you all. Bl**dy soft keys have gone walkabout!

    Unfortunately for me I have no Samsung support as I'm using a pre-loved S4 after my device decided to retire itself. And although I am more than technically capable to replace the digitiser and screen I decided to look for a low/zero cost option. I have found a suitable sidestep that i think is worth considering as it gives near normal function. Please find following the steps to enable the onscreen soft keys. These can be used if you don't have to worry about invalidating warranties.

    1: Root the device - I used free app called Kingo ROOT. It was a relatively pain free procedure. (You can research the steps to use this yourself.)
    2: Install a decent File Explorer App that can be given Super User permissions to the devive - I used ES File Manager from the Play Store
    3: Start the File Explorer app and in the settings you should be able to give the app Super User permissions. Also change the settings to show hidden files/folders
    4: Browse to the ROOT of the device storage
    5: Open the './system/' folder and locate the 'build.prop' file for editing
    6: Add the following line to the end: qemu.hw.mainkeys=0
    7: Close, saving changes
    8: Reboot the device

    Its not a perfect solution but at least you'll have interactive soft keys without spending any cash on new hardware.

    I hope this helps guys

    Credit must go to User "steevaavoo" - (http://forums.androidcentral.com/mem...aavoo-2313210/) as i used some of the steps that he provided in the following post: http://forums.androidcentral.com/sam...soft-keys.html
    03-25-2016 10:40 AM
  23. Elmojo's Avatar
    That has added to the mystery MightyPeanut. I too saw this method of a fix. So I checked it when I got my phone back from Samsung. Guess what, I don't have that line in the props file. As my phone is working perfectly without it opens a whole new set of questions.

    Posted via the Android Central App
    03-29-2016 02:49 AM
  24. MightyPeanut's Avatar
    That has added to the mystery MightyPeanut. I too saw this method of a fix. So I checked it when I got my phone back from Samsung. Guess what, I don't have that line in the props file. As my phone is working perfectly without it opens a whole new set of questions.

    Posted via the Android Central App
    ElmoJo,

    I'm not sure what point you're trying to make. If your phone has been fixed then you won't need my suggestion or the extra line in the props file.

    My instructions are for those people who can't have their phones fixed by Samsung under warranty, or can't pay to have the buttons fixed by anyone else.

    The line in the props file adds replacement buttons on the bottom of the DISPLAY, hence sidestepping the ones burned out by the Lollipop upgrade. You lose about 7mm off the bottom of the screen. It's not 100%, but the solution is an acceptable workaround.
    03-30-2016 03:32 AM
  25. Elmojo's Avatar
    Apologies for the confusion. I should have made my point clearer. I do not accept that this issue is an out of warranty problem. If the official update damages your phone then this is much more than a warranty issue. In fact it would open the door for manufactures to do this deliberately as a means of forcing us to buy later versions of their phones.
    Samsung were a little shocked that I still had my proof of purchase.
    It is not reasonable for Samsung or any other manufacturer to claim that this issue requires an active warranty. When the firmware/software seems to be the cause of this problem. Unless this problem is somehow related to a previously damaged component caused by misuse.
    So my point is that this issue has a cause that has still to be fully explained. The fact that the phone is out of active warranty is not a valid position for them to use in this particular situation.

    Posted via the Android Central App
    04-05-2016 03:37 PM
35 12

Similar Threads

  1. Replies: 2
    Last Post: 01-11-2016, 07:46 PM
  2. How DO I get Regular Keyboard back on Samsung Galaxy 10.1
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-20-2015, 10:00 PM
  3. Nexus 7 (2013) Problems after updating app
    By RickBS in forum Google Nexus 7 Tablet (2013)
    Replies: 1
    Last Post: 09-20-2015, 09:59 PM
  4. Samsung Grand Prime-Message organization
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-20-2015, 08:29 PM
  5. Backup not found
    By mkdll in forum HTC Desire 626
    Replies: 0
    Last Post: 09-20-2015, 08:29 PM
LINK TO POST COPIED TO CLIPBOARD