1. ELandau's Avatar
    Hi! I created a profile here because I have been having a strange problem with using WiFi on my Galaxy S4 that I have not been able to answer with Google searches. I would really appreciate if someone could help me identify the issue. I'm not entirely sure if it is even a problem with my phone, or my WiFi. Details below:

    Phone: Samsung Galaxy S4 (SCH-1545) running Android 5.0.1

    Issue: My phone has oddly selective issues loading data over WiFi. While connected to my home WiFi (through Apple Airport Extreme), the phone has no problems loading a select few webpages, but can't seem to load many others. The same goes for related apps. For example: on Chrome I can load Google, Yahoo, Wikipedia, and Facebook (just a few sites I have tried that work, not necessarily the only ones). I can even conduct searches on Google, or load new Wiki pages. However, most other websites do not work. If I conduct a Google search, the search will load but pretty much any of the results when clicked will not. The Facebook app works perfectly, but my Reddit app will not load at all (nor will reddit.com on chrome).

    The issue is specific to my home WiFi network. Over 4G or WiFi elsewhere, I have no issues on my phone. However, the problem also seems to be specific to my phone. My laptop and family members' phones have none of the same connection issues over the home WiFi.

    I'm stumped. Is it my WiFi, phone, or both? Thanks for your help!
    10-01-2015 02:27 PM
  2. anon(5600632)'s Avatar
    I wonder if it's your browser. Does it happen on both the Samsung browser and Chrome? Have you tried uninstalling then reinstalling Chrome?
    10-01-2015 03:35 PM
  3. extraclass's Avatar
    FORGET the WIFI connection in the settings, wifi, area click on the wifi connection you are using and at the bottom right corner click on FORGET! Re install the connection. I have had this solve a couple problems for me!
    10-01-2015 03:48 PM
  4. ELandau's Avatar
    It doesn't seem to be just with Chrome. Although I don't use the Samsung browser, I also have issues connecting with third party apps like Snapchat or my Reddit app.
    10-10-2015 02:41 PM
  5. ELandau's Avatar
    I think I have tried "forgetting" the wifi network before. But i'll try that again and see if that changes anything.
    10-10-2015 02:43 PM
  6. David Rounds's Avatar
    Is it possible that you may have parental controls enabled on your wireless router?
    10-28-2015 02:18 AM

Similar Threads

  1. Need Advice @ Samsung Galaxy Tab Pro Vs Asus Chromebook Flip
    By Ciik in forum Samsung Galaxy Tab Pro 10.1
    Replies: 1
    Last Post: 10-17-2015, 12:29 AM
  2. Replies: 2
    Last Post: 10-06-2015, 01:35 AM
  3. Replies: 1
    Last Post: 10-06-2015, 01:34 AM
  4. Why is there a problem with Google Play Srevices
    By TheSykO in forum Ask a Question
    Replies: 0
    Last Post: 10-01-2015, 02:09 PM
  5. Replies: 0
    Last Post: 10-01-2015, 02:05 PM
LINK TO POST COPIED TO CLIPBOARD