1. hiimappy's Avatar
    my phone is a samsung galaxy s4 sph-l720t sprint spark that ran on lollipop 5.0.1, i tried looking for a firmware to restore back but i cant find one, i tried re-installing the rom but dont work, yes i did the wiping part, and yes it was rooted with supersu, i tried installing rom with twrp but it didnt work, can someone please help me.
    10-21-2015 02:49 PM
  2. VDub2174's Avatar
    You didn't mention a backup.

    Did you not make a backup of the stock ROM before flashing?
    Laura Knotek likes this.
    10-21-2015 02:54 PM
  3. wtherrell's Avatar
    Better get a Nexus.
    10-21-2015 04:37 PM
  4. hiimappy's Avatar
    no i didnt
    im looking on sammobile, but apparantly my phone was on 5.0.1, and my model for 5.0.1 is not there, only 4.4.2, can i still download a 5.0.1 without being the same model ?
    10-21-2015 07:40 PM
  5. VDub2174's Avatar
    I wouldn't download something else for a different model. It could cause more issues.

    Check XDA for a Tool kit that can restore your phone.

    Sent from my Cataclysmic Nexus 6 on M
    10-21-2015 09:19 PM

Similar Threads

  1. How can I reboot my Samsung Alpha A3?
    By AC Question in forum Samsung Galaxy Alpha
    Replies: 4
    Last Post: 11-06-2015, 09:27 PM
  2. Why aren't games running on my Phone?
    By AC Question in forum Android Games
    Replies: 1
    Last Post: 10-21-2015, 07:30 PM
  3. Moto X on Verizon will not boot past Motorola logo
    By jhardy93 in forum General Help and How To
    Replies: 0
    Last Post: 10-21-2015, 02:45 PM
  4. Replies: 0
    Last Post: 10-21-2015, 02:28 PM
  5. How can I store Quickmemo+ memos on a PC ?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 10-21-2015, 02:28 PM
LINK TO POST COPIED TO CLIPBOARD