1. Weapon54x's Avatar
    Hello all,

    Every time I open my camera and toggle front face camera all it shows is a white screen. The options are all there and the rear facing camera works fine. I have googled the issue and cant seem to find anyone with the same issue just people who have black screens or errors saying "camera fail". Here is what I have tried so far:
    Clear camera cache and data then reboot- Didnt Work
    Rebooted into safe mode -Didnt Work
    Wiped the Cache Partition -Didnt Work
    Factory reset- Didnt Work
    Bought a new camera module and installed it. I then repeated the steps above -Didnt Work

    Any ideas why its not working? or suggestions on what to do next?

    I do remeber the last app I installed before the camera when bad was snapchat. When I uninstalled it and reinstalled it it did nothing for the camera. I also did the factory reset and the camera didnt work before I added snapchat again.
    I took the phone apart and removed the front camera and reassembled it without it and the phone shows a black screen. When I added the camera back it went back to the white screen. Software issue?

    Samsung Galaxy s4 SPH-L720 rooted to AT&T network
    02-08-2016 10:07 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! My guess would be an issue somewhere on the motherboard--perhaps with a connector or circuit related to the camera?
    02-08-2016 10:31 PM
  3. Weapon54x's Avatar
    Thats what im afraid it will end up being...

    Can I replace the motherboard with no issues or is changing the motherboard going to cause issues withe phone?
    02-09-2016 12:00 AM
  4. B. Diddy's Avatar
    Sorry, I don't know the answer to that.
    Weapon54x likes this.
    02-09-2016 12:40 AM
  5. dirtybird1's Avatar
    Hello all,

    Every time I open my camera and toggle front face camera all it shows is a white screen. The options are all there and the rear facing camera works fine. I have googled the issue and cant seem to find anyone with the same issue just people who have black screens or errors saying "camera fail". Here is what I have tried so far:
    Clear camera cache and data then reboot- Didnt Work
    Rebooted into safe mode -Didnt Work
    Wiped the Cache Partition -Didnt Work
    Factory reset- Didnt Work
    Bought a new camera module and installed it. I then repeated the steps above -Didnt Work

    Any ideas why its not working? or suggestions on what to do next?

    I do remeber the last app I installed before the camera when bad was snapchat. When I uninstalled it and reinstalled it it did nothing for the camera. I also did the factory reset and the camera didnt work before I added snapchat again.
    I took the phone apart and removed the front camera and reassembled it without it and the phone shows a black screen. When I added the camera back it went back to the white screen. Software issue?

    Samsung Galaxy s4 SPH-L720 rooted to AT&T network
    06-16-2016 05:36 AM
  6. dirtybird1's Avatar
    Same here. I replaced my glass screen. I used heating on glass to soften glue. This procedure failed as I damaged the digitizer. Ultimately replaced front assembly ,lcd, digitizer. Everything works well but front camera which shows blank white screen. I thought heat might have damaged camera. Hope not motherboard problem.
    06-16-2016 05:43 AM
  7. Krispaolo's Avatar
    I have the same problem too. what i did is i disassemble my s4 and solder the missing capacitor located on the camera socket at the mainboard and that fixed my frontcam white screen problem.
    07-03-2016 11:17 PM
  8. Chris_N's Avatar
    I saw exactly the same problem when I took a friends Samsung Galaxy S3 Neo to a repair shop. At first the front camera worked and the rear camera had an error "device not found". The technician replaced the rear camera and now it works fine. Sadly though from that time on the front camera stopped working with a white screen and no error. The technician informed me that there is a mainboard fault that prevents the front camera working. I tried a factory reset and also tried using another camera app but that did not solve the problem. Its not worth replacing the motherboard. It could be a bad capacitor but there is always a risk in attempting a repair on the mainboard. I suppose my friend will just have to live with the problem.

    Kind regards
    Chris
    12-10-2016 12:02 PM

Similar Threads

  1. No correct notifications on lock screen. on P8
    By mhs_m0nk3y in forum Huawei P8
    Replies: 5
    Last Post: 03-02-2016, 05:21 PM
  2. Replies: 3
    Last Post: 02-20-2016, 10:41 PM
  3. White note 5
    By koves in forum Samsung Galaxy Note 5
    Replies: 2
    Last Post: 02-11-2016, 03:13 PM
  4. Pop up that disable touch screen?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-08-2016, 10:40 PM
  5. Can I retrieve info from Galaxy S3 with dead screen?
    By AC Question in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 02-08-2016, 10:38 PM
LINK TO POST COPIED TO CLIPBOARD