1. whatswronghere's Avatar
    Some details- Was a galaxy s4 with ATT, and then switched service to T-mobile. I believe it worked at first. Recently I couldn't download any apps from google play store, and then i googled the problem and tried removing and adding google account than deleting google/dl manager data/cache. now it can't even connect to google play store.

    Thanks!
    02-18-2016 07:46 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did you clear the Google Play Store cache and data, or some other Google app (like Google Play Services or Google Services Framework)? Hopefully not the latter, because that might cause problems with your connection to Google.
    02-18-2016 12:45 PM
  3. whatswronghere's Avatar
    At first i could at least go on google play and browse apps but couldn't download any apps due to some server error code. When I looked it up that problem there were instructions to clear cache or data of the google app after deleting and adding google account....

    Now that i did that, I cant even connect to google play let alone browse/dl apps.

    Thanks!
    02-19-2016 02:45 AM
  4. Crashdamage's Avatar
    Very likely your original problem actually was that you were out of space. Try deleting/re-addiƱg the account again but this time clear data and cache before re-adding the account not after.
    02-19-2016 06:37 AM
  5. B. Diddy's Avatar
    Merged your threads. You PM'd me that you also cleared the cache/data for Google Play Services and Google Services Framework--this might be why you're having problems. It's generally inadvisable to mess around with the Framework data for sure, and probably also with the Play Services data. Did you try removing your Google account from the phone before or after clearing the Services and Framework data?
    02-19-2016 04:43 PM
  6. whatswronghere's Avatar
    Finally able to reply to my thread, sorry. I believe it was before clearing the services and framework, as the youtube tutorial had taught. So should I try clearing google services, framework, and everthing else after adding google account?
    02-22-2016 02:36 AM
  7. B. Diddy's Avatar
    No--I would recommend against ever clearing data from Google Services Framework. I suggest removing your Google account from the phone, then adding it back again, and then trying again without clearing cache or data from any of those.
    02-22-2016 11:33 AM
  8. whatswronghere's Avatar
    Still not working. Says "error retrieving information from server [rh-01] "
    02-25-2016 02:32 PM
  9. whatswronghere's Avatar
    I have 2 factor authentication for my gmail, if that matters....
    02-25-2016 02:33 PM
  10. B. Diddy's Avatar
    Turn off 2 step authentication temporarily, and then try accessing Google Play again. If it doesn't work, remove the Google account again (while 2-step is still off), then add the account back again.
    02-25-2016 04:59 PM
  11. whatswronghere's Avatar
    Tried that and it still doesn't work.
    02-26-2016 06:00 PM
  12. B. Diddy's Avatar
    Does everything else that's web-based work on the phone? Does this also happen on wi-fi?
    02-26-2016 09:47 PM
  13. whatswronghere's Avatar
    Yeah, everthing else web based seems to work. Yeah google play doesn't work on wi fi either.
    02-27-2016 04:34 PM
  14. B. Diddy's Avatar
    Check the APN settings again, and try turning off IPv6 (i.e., set it to prefer IPv4).
    02-28-2016 04:00 PM

Similar Threads

  1. Replies: 1
    Last Post: 02-18-2016, 08:01 AM
LINK TO POST COPIED TO CLIPBOARD