1. entrees's Avatar
    Hello,

    I bought a refurbished S4 from Amazon UK about a month ago. Two days ago while I was taking a picture with it outside, it did not recognise my SIM card anymore and it wanted to restart itself. After restarting, the problem was still there. When I tried to put on mobile data, it just said 'Insert SIM card'. I have tried to make calls on it as well but it says: 'Not registered on network'. To make things more confusing, it still shows signal bars. For example, at the moment it shows that I have full bars but I can't make calls.

    I have a UK SIM from Three. I have tried my other SIM on it (it's a foreign SIM) and that works fine. I have not tried mobile data as I cannot use its mobile data in the UK but I can still choose mobile data on which you cannot do with the Three SIM. I can also make calls with the foreign SIM. Furthermore, on the same day the problem emerged, I tried the other SIM and after that switched it to the Three SIM. Then, it worked maybe for an hour or two after which the same problem emerged. I had quite a small amount of memory left when the SIM card problem emerged two days ago (S4 was complaining that memory was almost full) so next day I removed some files, so it was not complaining about it anymore, and restarted the S4. After that it worked again about one or two hours but did not work after that anymore.

    I have not been able to get it to work again. I have cleared all app cache in the settings, restarted multiple times, removed and re-inserted the SIM, blown air to the SIM card slot and wiped the SIM card with a finger and have started S4 in Safe Mode. None of those have helped. Furthermore, I went to a Three store today and got myself a replacement SIM. However, when I inserted the replacement SIM to my phone, it did not recognise the SIM and again asks to insert it.

    It is very confusing that the phone worked fine for a month and then it suddenly does not work with Three SIMS but works with my foreign SIM. What could be the problem? What things should I try to fix it? I appreciate very much any help. Thank you!

    There is also a second problem with my phone: it does not recognise my SanDisk Ultra Android 64 GB. Multiple times it has said that the SD card was unexpectedly removed and similar things. Last week it worked for three days but after that it has not worked again. My PC can read the card with no problem. How could I fix it?
    04-21-2016 11:00 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did both the SIM and SD card issues arise at the same time, more or less? Has the phone received any recent system updates?
    04-21-2016 12:41 PM
  3. entrees's Avatar
    Thank you! No, the SD card issue has existed since the beginning. Yes, I have the latest updates installed.
    04-21-2016 12:46 PM
  4. B. Diddy's Avatar
    You could try using Samsung Kies to reinstall the firmware.

    Regarding the SD card, it could be corrupt, defective, or counterfeit. Install SD Insight to see if the card is genuine or counterfeit. Counterfeit cards are programmed to report more storage than they actually have, and if you try saving more than the card can actually hold, then files can start getting corrupt.

    If it's a valid card, then go to Settings>Storage, Unmount the card, remove it, and insert it into your computer. Can the computer read these files? Backup as much as you can right now, then run chkdsk to look for bad sectors: http://forums.androidcentral.com/amb...d-sd-card.html.
    entrees likes this.
    04-21-2016 03:44 PM
  5. entrees's Avatar
    Kies won't let my S4 connect to it because it says that I should use Smart Switch instead. How can I force it to connect? I will check the SD card issue out.
    04-21-2016 03:53 PM
  6. Rukbat's Avatar
    Try using Smart Switch.
    B. Diddy and entrees like this.
    04-22-2016 01:00 PM
  7. B. Diddy's Avatar
    Yes, Smart Switch should also have an option to reinstall or update your firmware. If you can't, then you could try manually reinstalling the firmware using Odin: http://forums.androidcentral.com/amb...interface.html
    entrees likes this.
    04-22-2016 02:46 PM
  8. entrees's Avatar
    Hello,

    I did a factory reset as I could not figure out how to reinstall my firmware in Smart Switch. The problem was not fixed, therefore it probably is a hardware problem. So, I contacted Amazon UK and they will give me a replacement phone. Thank you for your help both of you!
    B. Diddy likes this.
    04-28-2016 01:49 PM

Similar Threads

  1. How can I get my Asus Zenpad to turn on?
    By AC Question in forum ASUS ZenPad 7.0
    Replies: 2
    Last Post: 03-15-2017, 01:17 PM
  2. Replies: 2
    Last Post: 04-23-2016, 12:30 AM
  3. Replies: 2
    Last Post: 04-21-2016, 12:55 PM
  4. Replies: 1
    Last Post: 04-21-2016, 12:42 PM
  5. Where is the menue button on my I mac
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-21-2016, 12:14 PM
LINK TO POST COPIED TO CLIPBOARD