1. NightHawkGuy's Avatar
    My Samsung Galaxy S4 has been working great for 2 years until about two days ago the wifi data transfer speeds suddenly got slow.
    Its not my home wifi router since I tested it with other devices and they are still getting full data transfer speeds, with 802.11.ac 5Ghz I can get internet speedtests at my full rated 50Mb/s download internet speed and data transfer tests via wifi to a PC are up near 200Mb/s with a link speed of 433Mb/s.

    Up until a couple days ago the S4 also got those speeds, but now it gets below 10Mb/s with data transfer tests via wifi to a PC and internet speedtests are slower than that. Yet the linkspeed and wifi signal level are still good as before (up to 433Mb/s near the router). Its only the data transfer speeds and internet speedtests with the S4 that have slowed. It connects to wifi fine and doesn't lose connection, data transfer speed is just now too slow.

    At first I could reboot the phone and I would get full data speed again for a little while, but now even that doesn't help.
    Using non-wifi (T-mobile LTE) data I can still achieve up to 50Mb/s download in speedtests, so it just the wifi thats the problem.
    Has anyone else seen such a problem with a Samsung Galaxy S4? Is it a hardware problem after a few years of use?

    Anyone hear of any simple solutions to his problem?
    I've tried all the common wifi tips, but none of them helped since they are for wifi connection issues which I don't have.
    05-15-2016 06:02 PM
  2. Rukbat's Avatar
    Check the router. Make sure 5MHz is off, the wifi encryption is AES (not TKIP or TKIP+AES). Read [GUIDE] Troubleshooting Wi-Fi Connection Problems.
    05-15-2016 07:29 PM
  3. NightHawkGuy's Avatar
    Its not a router issue, its definitely the phone.
    The router has always been set for AES wifi encryption only.

    The phone has worked with the router with my settings for 2 years and just started this slow data transfer problem a couple days ago.
    The router still works fine full speed with other wifi devices.

    The phone sometimes will work at full wifi data speed again for a short time after being totally powered off, but quickly slows down again after a few minutes.
    I'm asking if anyone else has had this particular problem on the phone itself before. Its not a wifi connection issue, since it connects fine and at good signal level and link speed. Its just the data transfer speed that slows down...
    05-15-2016 10:45 PM

Similar Threads

  1. Note 4 battery sudden death while taking pictures
    By rhetoriccamel in forum Samsung Galaxy Note 4
    Replies: 14
    Last Post: 05-16-2016, 04:42 PM
  2. Having Problems with Xposed on my S6
    By taga in forum Samsung Galaxy S6
    Replies: 1
    Last Post: 05-16-2016, 12:55 AM
  3. Replies: 1
    Last Post: 05-15-2016, 07:39 PM
  4. Transfer Photos from Android to Mac Laptop's iPhoto?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-15-2016, 04:54 PM
  5. Replies: 0
    Last Post: 05-15-2016, 04:31 PM
LINK TO POST COPIED TO CLIPBOARD