1. Georgemuscle's Avatar
    I have used my Samsung Galaxy S4 as a wifi device for the past 3 months with android 4.2.2 and it worked perfectly fine as a wifi device with no sim card in until one day I decided to update it. So now the phone is running android 4.4.4 without a sim card and it wont let me switch the wifi on. What do I do, downgrade the phone back to 4.4.2?
    08-27-2016 12:49 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Moved to the S4 forum (it was originally in the forum for the Galaxy S, which is reeeeally old).

    What happens when you try to switch on the wi-fi? Does the switch turn on, then back off after a few seconds? Or does the switch not move at all?

    Try wiping the cache partition: http://support.t-mobile.com/docs/DOC-5744
    08-27-2016 10:41 PM
  3. Georgemuscle's Avatar
    When I try to switch the wifi on it switches back automatically because i do not have a sim card inserted. Oh yeah now that I only use it as a wifi device like an iPod touch, if theres a way to download apps from the computer and transfer it to the phone that will be great also being that I only use it to listen to music or play games when my primary phone dies.
    08-28-2016 08:13 PM
  4. B. Diddy's Avatar
    The presence or absence of a SIM card shouldn't matter when it comes to the wi-fi radio. If you never use a SIM card, then try turning on Airplane Mode, and then turn wi-fi back on. Does it stay on then?

    The only way to download an app to your computer and then transfer it to the phone would be download an apk installer file from a filesharing site, which I strongly discourage. These sites are not vetted for malware, so your risk of getting a virus is high (and the apps may also be pirated, which we strongly disapprove).
    08-29-2016 06:01 PM
  5. Georgemuscle's Avatar
    Ok already to transfer an app to my phone is not a good idea. Plus when I turn airplane mode on it still won't work. Is there any other way?
    08-30-2016 06:59 PM
  6. B. Diddy's Avatar
    Did you already try wiping the cache partition?
    08-30-2016 10:48 PM
  7. Georgemuscle's Avatar
    It did not work either when I tried wiping the cache portion
    09-02-2016 04:33 PM
  8. B. Diddy's Avatar
    Ok, next step would be to reinstall the firmware using Kies: http://forums.androidcentral.com/amb...sung-kies.html. Backup or sync your data beforehand, since I think this will wipe your phone.
    09-02-2016 10:09 PM
  9. Georgemuscle's Avatar
    Is that part of wiping the cache portion? But I did force do the Samsung Emergency Recovering with Samsung Kies anyway.
    09-03-2016 04:13 PM
  10. B. Diddy's Avatar
    Wiping the cache partition only clears out temporary system data from the system cache. Reinstalling the firmware basically wipes the phone and completely restores the system with a clean version (as opposed to a factory reset, which wipes the phone and then restores the copy of the system that's already onboard--which might not fix things if that copy is corrupt).

    Any luck after reinstalling the firmware using Kies?
    09-04-2016 02:35 AM
  11. Georgemuscle's Avatar
    nope even using without sim card I can't use the wifi, now i'm using 4.4.4
    09-04-2016 03:45 PM
  12. B. Diddy's Avatar
    Sorry, but I'm running out of ideas. What happens if you insert a SIM card, even if it isn't activated?
    09-04-2016 06:05 PM
  13. Georgemuscle's Avatar
    Remember I only use it for listening to music and playing games, so instead of using an active sim card I used a sim card that was un active. So when I inserted the sim card that was un active, first I did not have any service as soon I inserted it and I don't have wifi. Also the option to smart network switch did not say that I needed a sim card to use wifi in the description, plus before I inserted the sim card it said that I needed to have a sim card in order to have wifiHow can I connect to the wifi without a sim card on my galaxy s4?-img_4541-1-.jpg
    09-05-2016 05:24 PM
  14. Georgemuscle's Avatar
    by the way it says this feature was turned off because no sim card been inserted, because the light might be blocking it
    09-05-2016 05:25 PM
  15. B. Diddy's Avatar
    Man, this issue is frustrating (for you and me both ). So let me just recap:

    1. Wi-fi won't turn on regardless of SIM being inserted or not.
    2. Already tried inserting unactivated SIM, turning on Airplane Mode, then turning on wi-fi.
    3. Smart Network Switch already turned off.
    4. System cache partition wiped.

    One other usual thing I forgot to suggest is Safe Mode: https://support.t-mobile.com/docs/DOC-27781
    09-06-2016 03:45 PM
  16. Georgemuscle's Avatar
    Using safe mode has no effect either. Maybe I have to abandon this problem. But if anything post it.
    09-06-2016 05:30 PM
  17. B. Diddy's Avatar
    Grrr. Well, the thing you suggested in your first post might be the way to go--try flashing the old 4.4.2 stock ROM using Odin: http://forums.androidcentral.com/amb...interface.html
    09-07-2016 01:28 AM
  18. Georgemuscle's Avatar
    Yes, it did work for me now using 4.2.2. But my only concern is that this android version is outdated, so if you can find another android firmware that can take wifi without a sim card that would be great
    09-15-2016 09:23 PM
  19. B. Diddy's Avatar
    What's the exact model number? Did you check SamMobile.com to see if they have something in between 4.2.2 and 4.4.4? Firmwares - SamMobile
    09-16-2016 01:22 AM

Similar Threads

  1. Always-On Display
    By isaiah32 in forum Samsung Galaxy Note 7
    Replies: 2
    Last Post: 08-27-2016, 03:25 PM
  2. Replies: 1
    Last Post: 08-27-2016, 02:12 PM
  3. Replies: 1
    Last Post: 08-27-2016, 02:11 PM
  4. how to decompile an apk and disable check for updates
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-27-2016, 12:48 PM
  5. Replies: 0
    Last Post: 08-27-2016, 12:39 PM
LINK TO POST COPIED TO CLIPBOARD