1. angelgabbby's Avatar
    My daughter is desperately in need of new phone due to hers got shattered & she lives alone. A friend gave her her att s5 active. I got someone that is unlocking it but I just saw somewhere someone saying the active wont work for web or messages on tmobile. She does live in a city & does travel out of the city. Does Anyone know if itll still work??? Our only other choice are "like new" phones from craigslist that are at least 4-6 yrs old (like the zinger, mytouch, behold II, Samsung gravity Smart, or G-1) - she prefers this 1.
    Thank you for any help
    11-20-2015 10:28 PM
  2. B. Diddy's Avatar
    The S5 Active should work. Its compatible bands overlap fine with T-Mobile's:

    Samsung Galaxy S5 Active - Full phone specifications
    https://support.t-mobile.com/thread/92908
    angelgabbby and Josiah23 like this.
    11-21-2015 01:53 AM
  3. Josiah23's Avatar
    The S5 Active should work. Its compatible bands overlap fine with T-Mobile's:

    Samsung Galaxy S5 Active - Full phone specifications
    https://support.t-mobile.com/thread/92908
    Bump!!

    I got a Galaxy S5 Active (AT&T G870A) from a trusted user on eBay, it didn't come with a SIM card, as I knew it wouldn't. The device is GSM Unlocked, would I need a AT&T SIM card to switch to T-Mobile? Whenever I enter the devices IMEI on T-Mobile's website, they won't recognize the IMEI, but AT&T IMEI checker works fine.
    09-17-2016 03:36 PM
  4. mmednick1's Avatar
    That's probably because it's still locked to AT&T.
    10-13-2016 02:43 PM
  5. Josiah23's Avatar
    I got mine on AT&T since it was the closest store to my house and job. The prices online arent even the same when you go instore, I was thinking I was going to be paying $60-$70/month, but im paying $40/month with autopay.
    10-13-2016 03:07 PM

Similar Threads

  1. Verizon Moto E 2nd gen on Straight Talk
    By Boston02116 in forum Moto E (2015)
    Replies: 15
    Last Post: 03-19-2016, 04:05 PM
  2. Replies: 1
    Last Post: 11-21-2015, 02:11 AM
  3. Please help, failed to mount /efs error on Galaxy S3 GT-I9300
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 11-20-2015, 09:12 PM
  4. Replies: 0
    Last Post: 11-20-2015, 09:11 PM
  5. i have virus on my lenovo a850.
    By joshua martin in forum Ask a Question
    Replies: 0
    Last Post: 11-20-2015, 09:04 PM
LINK TO POST COPIED TO CLIPBOARD