1. CruzDiva's Avatar
    I have had this phone for about 1 month and I have the settings correct, (Smart Network Switch is checked) however, it stays on WiFi. By the way, if I take it off WiFi, even tho I am 500 feet from AT&T's tower, it still does not pick up GSM, 3G or 4G, therefore, when I am traveling, I have no signal. Cannot make or receive calls or texts. No carrier info in the phone, it just says "My Network", no list of carriers at all. I will take any suggestions on what I need to do. Thanks!
    07-25-2015 10:39 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try turning off Smart Network Switch--it seems to be more trouble than it's worth for some people.

    Does the loss of cell signal only happen after turning off wi-fi? If it happens regardless of your wi-fi radio, I'd contact your carrier and see if you need a new SIM card.
    CruzDiva likes this.
    07-26-2015 03:18 AM

Similar Threads

  1. Replies: 1
    Last Post: 07-26-2015, 03:20 AM
  2. Replies: 1
    Last Post: 07-25-2015, 06:48 PM
  3. AT&T S5 update but not all options available
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-25-2015, 12:39 PM
  4. New S5, Wigits?
    By missouriexile in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 07-25-2015, 11:28 AM
  5. Replies: 1
    Last Post: 07-25-2015, 10:21 AM
LINK TO POST COPIED TO CLIPBOARD