1. nijaboym's Avatar
    Device: Galaxy S6 G900H
    ROM: First Lollipop 5.0 then KitKat 4.4.2
    Problem: Unable to root phone and install custom recovery
    Rooting methods tried: 1.Odin 3.09 (and 3.07 after 3.09 failed). It got this message:

    <ID:0/007> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> CF-Auto-Root-k3g-k3gxx-smg900h.tar.md5 is valid.
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/007> Odin v.3 engine (ID:7)..
    <ID:0/007> File analysis..
    <ID:0/007> SetupConnection..
    <ID:0/007> Initialzation..
    <ID:0/007> Get PIT for mapping..
    <ID:0/007> Firmware update start..
    <ID:0/007> SingleDownload.
    <ID:0/007> recovery.img
    <ID:0/007> NAND Write Start!!
    <ID:0/007> FAIL!
    <ID:0/007>
    <ID:0/007> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)

    2.ADB method in Ubuntu Linus as delineated in this thread: http androidforums.com/threads/how-to-root-any-android-device-manually.586982) Sorry, forum rules forbid newbies from posting links. I followed the instructions up to the point when the phone was put in recovery, thereafter the phone did not show up in the Nautillus file browser.
    3.Heimdall
    4.KINGO Root. This always reported success, but Root checker says there is no root. Titanium backup failed to work because there was no root
    5.OneClick Root also failed
    6.SRSRoot for Android also failed
    7.Skipsoft Android Toolkit (Which I paid for) also failed . I contacted the developer through G+ and Twitter and E-mail, but he has not replied
    After trying all these methods in LOLLIPOP (and knowing I had enjoyed ROOT in Kitkat before moving on to Lollipop) , I flashed back to KITKAT 4.4.2, and rooting with Odin and all the other methods failed also. Please, note that I had enjoyed rooting on the phone for more than a year, before upgrading to Lollipop 5.0 (BOAD).
    Finally, Rooting through Stock Recovery using Phil_Touch also failed at "E-whole file verification failed".
    I don't know what to do again. Can someone help please?
    04-10-2015 11:24 AM
  2. itguyjax8430's Avatar
    Have you tried using Chainfire root? That worked for my Galaxy S6 on Lollipop. Also you will need to use the newest ODIN Latest ODIN - 3.10.6 to push the root files with ChinFire.

    CF-Root Download

    ODIN - http://forum.xda-developers.com/atta...9&d=1420980613
    04-13-2015 06:56 AM
  3. SladeWilson's Avatar
    I have most of those issues also. I cant use Odin as I have a Linux machine. So I tried Heimdall, and I get an error "Cant download pit" or something like that. Can someone please shed us some light?
    05-01-2015 07:21 PM
  4. nijaboym's Avatar
    Not working.
    07-02-2015 10:48 PM
  5. Man Fat's Avatar
    I had some trouble rooting my S5 with Odin. Turned out I needed to clear credentials then it rooted fine.
    07-03-2015 08:59 AM

Similar Threads

  1. Is there any way to restore backup to Galaxy S6?
    By Jabrom in forum Samsung Galaxy S6
    Replies: 31
    Last Post: 02-06-2016, 05:26 AM
  2. Root failed can I unbrick my phone?
    By n00b2 in forum Samsung Galaxy Note 4
    Replies: 6
    Last Post: 11-16-2015, 06:56 AM
  3. Cant find wiget to restore google search back on my android !
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 04-14-2015, 07:02 AM
  4. Is there any way to restore backup to Galaxy S6?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 04-13-2015, 07:35 AM
LINK TO POST COPIED TO CLIPBOARD