1. wecanfly's Avatar
    My phone specs:
    SM-G900R7
    Marshmellow 6.1
    Carrier: Ntelos (VA and WV carrier)
    After so long I finally found a way to root my phone using this guide (https://www.skyneel.com/root-samsung...y-s5-sm-g900r7). So I have Odin v3.10 and followed the guide exactly except I could not turn OEM unlocking on as the option does not show up on my phone. I knew others with my phone and carrier had rooted before so I went on anyway. I flashed the file (using CF-Auto-Root-klteacg-klteacg-smg900r7.tar.md5) and my phone rebooted. It went to recovery boot, but gave the message "Recovery is not Seandroid enfocing". I could not get my phone to do anything but go to download mode. I flashed twrp-klte.tar for Samsung Galaxy S5 and it got my phone to turn on properly, but recovery boot still showed the message. When trying to go to recovery mode again I got into twrp recovery. When rebooting it asked if I wanted to download superSU and that it will root my phone. I clicked yes and when it rebooted SuperSU was on my phone and Samsung + gave a notification my device was rooted, but it was not. I tried going through the process with the SuperSU app, but it told me I needed to install a binary that will root my phone. After many issues and twrp getting stuck in a loop, I flashed stock firmware (it did not reset my phone? but let me get into recovery boot) and have now reset my phone.
    Tl;dr What happened that caused the root to fail? My phone specs match the requirements for the root. Is there any way to get OEM unlocked for my phone without the option on my phone?
    12-03-2016 09:45 AM
  2. anon(632115)'s Avatar
    Recovery is not Seandroid enfocing suggest the files are wrong for the version of Android you are using. OEM unlocking refers to bootloaders. If yours was locked you would have bricked your device. OEM unlock is not to be found in Samsungs so I think the article is wrong.

    I found this https://techchomps.com/how-to-root-s...-cf-auto-root/ but cannot vouch for it.
    12-03-2016 10:03 AM
  3. wecanfly's Avatar
    Used the guide and went through it. One thing I noted in Odin Mode right before it reboots it says Set Warranty Bit: cache. My phone rebooted and is again stuck at Recovery is not seandroid enforcing. any other ideas?
    Edit: Also, Odin says Pass so it thinks it worked.
    12-03-2016 10:44 AM
  4. wecanfly's Avatar
    I got it working! I installed Philz Touch Recovery and SuperSu zip file from my cpu and installed using Philz. I've verified and am now rooted! A quick question: Is it okay to go ahead and restore my backup using Samsung Smart Switch on my computer?
    12-03-2016 11:50 AM
  5. anon(632115)'s Avatar
    Sorry for late reply. Had stuff to do and search is down. Yes you can now restore. Glad you got it working
    12-03-2016 04:49 PM
LINK TO POST COPIED TO CLIPBOARD