03-06-2016 12:47 AM
59 123
tools
  1. R93LFC's Avatar
    My settings look like this. After configuring it I've had no problems connecting to 10 different connections in 10 locations.

    Posted via Android Central App
    Attached Thumbnails Wifi is not connecting automatically on S5. I need to manually connect to wifi every time-screenshot_2014-06-06-13-53-16.jpg  
    06-06-2014 07:55 AM
  2. Jenna Lawlor's Avatar
    try "forgetting" the network and reconfigure it

    it solved my issues with my home wifi where it wouldn't automatically connect upon turning on wifi
    Thank you, this worked for me
    06-11-2014 01:21 AM
  3. jstoddard365's Avatar
    This is not a specific router version and there is nothing you can do on the advanced setttings to fix this. Possibly a channel issue thought I think this is a bug with the S5.
    06-29-2014 01:15 PM
  4. kullar's Avatar
    I turned the "scanning always available" option off and it's working perfect now.
    07-06-2014 04:53 AM
  5. Lefteris S5's Avatar
    This worked for me thanks.

    For the record my home wifi would connect automatically but my work one would need to manually connect simply by tapping 'connect' on the router name as per the original post.
    The solution of forgetting the network worked for me also!
    Glad I did not have to change phones....
    07-11-2014 08:58 AM
  6. nlatham's Avatar
    I have a WiFi lock. It automatically starts my WiFi as soon as I'm in range of it. I love it. I used to have to keep resigning into my WiFi it never remembered my password but my WiFi app (advanced wifi) is amazing I never have that problem anymore.

    Posted via Android Central App
    07-12-2014 04:45 PM
  7. Jon Mortensen's Avatar
    I had to manually add the MAC address to my router in order for it to recognize the phone.
    08-07-2014 12:53 AM
  8. Dilip_Mallik's Avatar
    Hi,

    This method solved my problem , I had issue where I have to manually sign in in my office network even though no password was required.

    Thanks buddy for giving this tip.
    08-14-2014 08:20 AM
  9. hattiedu's Avatar
    Wifi is not staying connected
    09-12-2014 09:38 AM
  10. R93LFC's Avatar
    As above...there's a screenshot with settings. See if that works

    Posted via Android Central App
    09-12-2014 09:41 AM
  11. delzoon's Avatar
    Hello - I'm having the same problem with my Galaxy S5. Just got the phone about two weeks ago. None of the recommendations here have worked yet. I wonder if this has something to do with the fact that I turned off network broadcast to increase the security of my network. In other words, the name of my network is not broadcast, so it is not found when a mobile phone scans available networks. You have to type the name of my network in, and then the password.

    Other folks having problems: is the name of your network being broadcast?

    Thanks.
    09-14-2014 07:22 AM
  12. Rmedy21's Avatar
    ...

    Posted via Verizon Samsung Galaxy S5 😎
    09-14-2014 07:35 AM
  13. R93LFC's Avatar
    Hello - I'm having the same problem with my Galaxy S5. Just got the phone about two weeks ago. None of the recommendations here have worked yet. I wonder if this has something to do with the fact that I turned off network broadcast to increase the security of my network. In other words, the name of my network is not broadcast, so it is not found when a mobile phone scans available networks. You have to type the name of my network in, and then the password.

    Other folks having problems: is the name of your network being broadcast?

    Thanks.
    This shouldn't be an issue. I have the same setup

    Posted via Android Central App
    09-14-2014 07:54 AM
  14. Northern.dj's Avatar
    OMG ARRRRRRRRR
    ITS NOT YOUR PHONE THAT IS THE PROBLEM
    The problem is your Router any Netgear bassed router will not work as they don't support it on there basic range
    any Firmware bassed router will work
    Its all about Handshack when you come in range your phone pics up your router and says Hello
    Your router should then say welcome back
    I have a Asus Dark Night and works you will find that ISP Routers suck so get a stand alone router
    09-14-2014 08:11 AM
  15. ryetronics's Avatar
    I am also having this same problem with a 1-day old Samsung Galaxy S5. Any phone settings from this thread have not worked for me.

    One thing to note is when I turn off Mobile Data (Settings-More Networks-Mobile Networks-Mobile Data) the Wifi turns right on. When I re-enable Mobile Data, wifi turns back off.
    09-23-2014 02:59 PM
  16. ryetronics's Avatar
    UPDATE:

    A few hours after posting this my Galaxy pushed a software update. After the update the problem is now fixed on both my home network and work. So yes, for me at least, it was definitely software related. I didn't have to make any adjustments to routers.
    09-24-2014 09:44 AM
  17. cyberkeeper1's Avatar
    Having this problem on my s3? Only did it on 4.3 and up. On 4.2.2 and 4.1.2 in my galaxy s3, it never even asked. On 4.3+ I understand it's some kind of new check to see if it's a hotspot or proxy. Any idea how to disable this extra step if rooted? I don't know how just now. I don't like it. It's a nag to me. When I walk in i expect my wifi to be already connected, so i dont understand the extra step nonsense.
    10-02-2014 09:24 PM
  18. Jesse Millwood's Avatar
    UPDATE:

    A few hours after posting this my Galaxy pushed a software update. After the update the problem is now fixed on both my home network and work. So yes, for me at least, it was definitely software related. I didn't have to make any adjustments to routers.

    I have had my S5 since it was released and I have loved it but the last two weeks my wifi has not been connecting automatically to my home, work, or school networks and it did just fine up until about the time of this update it seems.
    10-07-2014 06:46 AM
  19. KariNich85's Avatar
    This just started happening to me yesterday, my wifi will randomly drop (at home AND work) and I'll have to go in and manually tell it to connect again. I have all the right things checked and it's been working fine for the past 5 months and now all of a sudden doesn't. So it HAS to be a phone issue. It's getting really annoying because it did it last night while I was listening to music and ate up quite a bit of data because of it. This is definitely a bug that Samsung needs to fix
    10-07-2014 05:18 PM
  20. isnoop's Avatar
    I'm having the same issue here. It's happening at home and work. Started about a couple weeks ago on my month-old Verizon GS5. I have a GS4 and another GS5 at home and this problem doesn't happen on either of those phones.

    The problem device is set up as described in the previous post with the screenshot and doesn't exhibit any other problems.

    Possible solution:
    I've uninstalled FireChat in the hopes that will solve the problem. I know the app does special things with the wifi when not connected (it can chat with others nearby when you're not on the internet), so it is possible it interferes with re-connecting to wifi on Samsung devices. After uninstalling the app and rebooting the phone, it reconnected to wifi, so things look promising. I'll do some more testing and follow up.
    10-28-2014 05:38 PM
  21. hondakawi's Avatar
    A little update of my findings on this problem.

    I regularly connect to 2 modems, home and work. They both connect automatically with no problem except after restarting the work one (a fairly new BT modem). It needs a restart for an unrelated printer problem and the restart triggers in the need to manually connect the S5. It's as simple as selecting the router and clicking on connect in settings. Other phones in the office do not have this issue, just the S5.

    I don't yet know if the same issue will apply to the home modem as I've yet to try a restart of it.
    I have a Galaxy S5. All the settings on the phone are correct. But was having same problem as you guys, until I went into my modem/router unit settings and reset the 'Telnet timeout' setting from '30 min' to 'never timeout'. Been a couple days and no problems so far! Before I did this I would always get the 'sign in required' message.
    11-16-2014 11:43 AM
  22. cmzzmoffatt's Avatar
    I have an S5. I finally deleted McAfee and now my wifi connects fine.

    Posted via the Android Central App
    Daryl Stephens likes this.
    11-22-2014 01:30 PM
  23. Daryl Stephens's Avatar
    I was having the same problem and it appears, as with cmzzmoffatt, that uninstalling McAfee fixed things.
    11-24-2014 10:05 PM
  24. Rainmanne's Avatar
    Got a similar problem after changing security settings on my router from WPA-PSK/WPA2-PSK to just WPA2-PSK and TKIP+AES to just AES. I needed it for my laptop. I wonder if this is the reason. The phone not only does not connect automatically but also it does not connect if you try to force connection and asks for the password again. Even if it does connect there is no Internet connection. It is a bit bizarre as all other devices at home (Nexus phones and tablets, laptops etc.) connect and work without any issue.
    01-08-2015 10:06 AM
  25. rodaz's Avatar
    Hi
    I'm a new android user. The problem I'm having is that when my wifi drops out or if I come home the Internet on my phone does not switch back from mobile data to wifi. I'm with bigpond and I have put the password into my phone and I don't need to put the password in each time but when I go to wifi settings it says sign in required and I press connect and the wifi turns on. As soon as I come home or the Internet drops out it switched back to 3G and doesn't connect back to wifi unless I do what I mentioned above.

    The advanced setting on the wifi are
    Proxy-none
    Ip settings DHCP
    Signal strength- very strong
    Security wpa2 psk

    I also have the smart network switch toggled to off. I have reset my telstra router.

    I would love some help with this, I will readily admit to knowing nothing about android but I'm willing to learn. I've wasted a lot of my mobile data this week before I realised that when I left the house or the net dropped out my phone was staying on 3G and not switching back to wifi the way my iPhone and every other phone I've owned did.

    Thanks so much
    02-25-2015 04:33 AM
59 123

Similar Threads

  1. Replies: 20
    Last Post: 05-09-2014, 09:13 PM
  2. Not enough storage available
    By TSLS in forum Samsung Galaxy Tab 2
    Replies: 2
    Last Post: 04-27-2014, 09:00 PM
  3. wallpaper not sizing right.
    By kami8586 in forum Samsung Galaxy Note 3
    Replies: 12
    Last Post: 04-17-2014, 03:26 PM
  4. S5 needs more RAM or less touch wiz
    By Zylograth in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 04-15-2014, 09:58 PM
  5. MHL to HDMI Cable
    By Tarlach in forum HTC One M8
    Replies: 3
    Last Post: 04-15-2014, 03:09 PM
LINK TO POST COPIED TO CLIPBOARD