1. Corey Hill2's Avatar
    It's really starting to irritate me now. I've been messing with this d*** phone for 2 hours now! USB debugging is enabled, tethering is unchecked (even tried with it checked), Media storage is selected (not the camera (tried that also)), and I've installed every driver imaginable for this thing, via itself and from other forums. It comes up when i plug it in to my computer, shows up as "Galaxy S5" and when i choose to "Open device to view files in explorer" the window goes away and NOTHING happens. When I go to my computer, it doesn't even have it down as a "removable storage device"...funny thing is when I go to Windows Media Player, it recognizes it and lets me put music on it (but who really uses that anymore?) It even showed up in Odin when installed philz touch but when i go to put the SuperSU zip on there, my computer wont recognize this damned thing! Even tried booting in recovery and mounting the storage like that, simply says installing and nothing happens...I have the Tmobile model. Anyone else having issues?
    04-20-2014 10:07 AM
  2. Harp1909's Avatar
    Try turning the Power Saving mode off, it may sound silly but my S5 did the same thing this morning and by simply turning the Power saving mode off it showed up in my PC right away.
    07-02-2014 05:57 PM
  3. Jason Eaton's Avatar
    What USB cable are you using? Did you try any others?

    Posted via Android Central App
    07-02-2014 07:14 PM
  4. jackwagon06's Avatar
    DId you install samsung drivers?
    01-27-2015 04:21 PM
  5. eternalwhitemoon's Avatar
    I just wanted to chime in that the Power Saving suggestion is very much still a valid solution. It worked for me today. It had been plaguing me for months that the PC would show the S5 as a media device and then claim there were no files.
    05-01-2015 05:11 PM
  6. Astral_Oath's Avatar
    A bit late replying to this. I found this as I was having this issue just now with my own S5. I found a solution for my own issue. When I plugged in the phone this VZW Software update thing would pop up, followed by the phone being registered as a media device. I went into the control panel, devices and printers, then right clicked on it and the top option allowed me to get into the device storage.
    I have an HP laptop with windows 7.
    06-15-2015 11:06 PM
  7. joyceface2's Avatar
    this is what the problem is. thank you.
    06-16-2015 04:52 PM
  8. highhacker's Avatar
    Hello for future reference if you still cant get the Samsung S5 USA models t detect as a removable drive after you install the drivers here is a little trick .Dial *#0808# and select MTP/ADB then ok and you shold be good to go . this is also the command to set up Diag modes fo the Command ##DMMODE# fo connecting to computer phone programming software for advanced users.

    Hagbard Celine1 and newguy13 like this.
    07-19-2015 02:17 PM
  9. Hagbard Celine1's Avatar
    You are a dead-set legend. Worked like a charm!
    08-22-2015 08:50 PM
  10. Cindy62712's Avatar
    None of the suggestions will work with my S5. Power saving mode is already off. It is already connected as the MTP device setting on the phone. I tried dialing the *#0808# but Verizon says it is unable to connect to this number. No Verizon update popup coming up when I plug in my phone. The computer is recognizing it as being connected when I plug it in via the USB cord because I heard the clunk/clunk sound but it does not show up in Windows Explorer. The last time it did this, just checking the MTP box on the phone let it show up but even though it is still checked nothing is showing up in Windows Explorer. I even changed to the camera setting then back to the MTP setting but still no luck. Anything else to try?
    09-09-2015 08:00 PM
  11. collins Obuogo's Avatar
    Excellent solution! Worked in micro-seconds.
    11-06-2015 01:32 AM
  12. Ricardo Alfaro's Avatar
    thank you it really works
    01-11-2016 07:39 PM
  13. newguy13's Avatar
    this worked! thanks to you now i can move some movies to my PC lol. thanks!
    07-02-2016 08:23 AM
  14. Fonefighter's Avatar
    Thanks, the *#0808# solved the problem I was having. So where are all these "hidden" menus documented? Why wasn't this available somewhere in Settings?
    07-04-2016 03:31 PM
  15. Fishermandan007's Avatar
    Got the same issue and the number won't work for me either.
    08-15-2016 09:36 PM
  16. ironass's Avatar
    Some U.S. carriers, AT&T & Verizon for example, disable a whole range of service codes on their firmware and so, entering *#0808# into the dial pad will not work.

    08-15-2016 11:17 PM
  17. MommaFelts16's Avatar
    This isn't referring to the s5....I have a s6 that shows up on everything as a s5. Not sure why? I bought it brand new 6 months ago...but my pc, and my email accounts all recognize it as a s5!!! Help!
    09-25-2016 01:23 PM
  18. queenxlilith's Avatar
    omg you are a god! thank you
    10-11-2016 08:53 PM
  19. schoen311's Avatar
    I can't even find the usbsettings screen to try this. Would you please tell me where it is.

    Thank you-
    11-01-2016 11:59 AM
  20. ironass's Avatar
    I can't even find the usbsettings screen to try this. Would you please tell me where it is.

    Thank you-
    Which of the 42 models of Samsung Galaxy S5 do you have?

    Have you installed Samsung Smart Switch for phones on Lollipop and Marshmallow?
    11-01-2016 12:24 PM
  21. Rudy NotRuby's Avatar
    Same here its like no one knows how to fix this issue.
    01-27-2017 12:48 PM
  22. lgossin's Avatar
    when you plug the phone into the computer swipe down and you should see USB settings, the default is charge only, you can then adjust for file transfer, you need to do this every time
    01-27-2017 04:41 PM
  23. Lucas Ledesma's Avatar
    when you plug the phone into the computer swipe down and you should see USB settings, the default is charge only, you can then adjust for file transfer, you need to do this every time
    you sir, deserve whatever it is you want in life. THANK YOU.
    03-28-2017 10:18 PM

Similar Threads

  1. Replies: 11
    Last Post: 04-26-2014, 11:53 PM
  2. Best Browser for the M8
    By Zakappel in forum HTC One M8
    Replies: 20
    Last Post: 04-21-2014, 11:49 AM
  3. Help! How do I view videos from iPhone users?
    By alil25 in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-20-2014, 01:21 PM
  4. Replies: 0
    Last Post: 04-20-2014, 09:12 AM