05-14-2018 11:34 AM
108 12345
tools
  1. CpoWinter's Avatar
    This seems to have worked for me
    02-08-2015 02:13 PM
  2. Yahel Johnson's Avatar
    Unchecking "smart network switch" worked for me. The issue started about a month ago. Lost every network connection I was on constantly even though other devices didn't. Very annoying. I've had my phone for months with the option on with no issues. Glad it was an easy workaround but Samsung should definitely fix this as it doesn't seem to be an issue with other devices or a specific provider. I have AT&T and this forum mentions Verizon and Tmobile users too. I guess we can only hope Samsung is paying attention to their forums.
    Robin Wilson2 likes this.
    02-08-2015 04:28 PM
  3. midnight2762's Avatar
    Hi go to settings then wifi and uncheck smart network switch wifi should work perfect then mine did
    Robin Wilson2 likes this.
    02-09-2015 03:10 PM
  4. JFetch's Avatar
    Hi go to settings then wifi and uncheck smart network switch wifi should work perfect then mine did
    My S5 just started doing this a few days ago. It goes off and on every 10 seconds or so. It does it on every wifi network. I just tried this and it seemed to fix it so far.
    YsLadyMN likes this.
    02-09-2015 11:55 PM
  5. achillesheels's Avatar
    I agree this is merely a workaround. I've had the "Smart Network Switch" on since I first got the phone last year and no problems until the last couple of days and I haven't had any Android updates recently (still on kitkat 4.4.4). I'm on Verizon and others reporting this same problem are on different carriers so it doesn't appear to be a Carrier issue. This also happened on my home and work wifi. I'm suspecting a recently updated app is causing the issue. That could be hard to troubleshoot though as I've had lots of recent app updates.
    YsLadyMN likes this.
    02-10-2015 09:23 AM
  6. Stacy Lyons Pizzi's Avatar
    Thank you...I did what you said and it's been great... I unchecked the Smart Network Switch and wha-lah!!
    I was looking for an answer to a different wi-fi question when I saw this.
    I'm on AT&T with my S5.
    Under the Wi-Fi settings I have an option for "Smart Network Switch" which says it Automatically switches between Wi-Fi and mobile networks to maintain a stable internet connection. Anytime a computer says it automatically does something for me; I typically say no thanks. I don't typically like my devices making assumptions of what I like, don't like or want to do. So I have that option unchecked. I never have an issue with the network stability once I've connected to a specific wi-fi connection.

    Not sure if that will help you all or not. But thought I'd share.
    02-10-2015 07:39 PM
  7. Melanie Nash's Avatar
    Started dropping wifi about a week ago, turned off the 'smart switch', and for the first time in a week, I've stayed on wifi for over 5 minutes. Sad that something like this had to be done so I can stay on wifi!!!
    02-10-2015 11:05 PM
  8. Philip Coombs's Avatar
    Absolutely agree...!! My phone always worked with the Smart Networks enabled, then suddenly started reconnecting the Wifi constantly. I don't mean like every half hour... every few seconds. Why should I have to turn off a feature to fix something as a workaround?
    YsLadyMN likes this.
    02-10-2015 11:12 PM
  9. alex9679's Avatar
    That used to happen to my Note, Reset your modem and it should be fine.
    Hi i had the same problem ket dropping every 10 secs. I booted in safemode realised it was ok .
    i uninstalled a few security apps and games i had recently put on and that fixed the problem. These apps did not effect my s5 before the update.
    02-11-2015 03:25 AM
  10. Drunder40's Avatar
    I agree this is merely a workaround. I've had the "Smart Network Switch" on since I first got the phone last year and no problems until the last couple of days and I haven't had any Android updates recently (still on kitkat 4.4.4). I'm on Verizon and others reporting this same problem are on different carriers so it doesn't appear to be a Carrier issue. This also happened on my home and work wifi. I'm suspecting a recently updated app is causing the issue. That could be hard to troubleshoot though as I've had lots of recent app updates.

    This^^^^

    Same here for my S5 and my Wifes S5. Both had this Wifi issue after lollipop. You should NOT have to turn stuff off to fix an issue that started immediately after a major Android update. . I have the network switch off ATM and hoping Verizon comes out with a fix..
    seattle3713 likes this.
    02-11-2015 09:07 AM
  11. Jennielee Armstrong's Avatar
    Getting the same problem using my S5 in Canada using Bell so it's not a network issue.

    Tried every possible settings and still have this issue. It has to be device related... Hope Samsung fixes this bug soon.
    I have a galaxy s3 it keeps kicking me off my home wifi connection . Verizon replaced my phone thinking it was the problem nope its not new one does it I haveconnection through dish so dish is telling me its my phone Verizon says its thecable idk what to do help
    02-11-2015 09:24 AM
  12. Fifi Monkey's Avatar
    Mine started doing this yesterday on both work and home wifi. I did this at home today and so far it's working well. Hope this helps.
    youtube.com/watch?v=v2DFzr66x-0
    THIS WORKS!!

    I just did switch off ...couldn't access my keyboard because of those damned wifi popups. I was beside myself because I do NOT want any old refurb..if I drop my phone, or do something stupid, okay..I'll suffer the consequences. But I make a point and I've spent money to protect this phone - it's wrapped in good things and it's treated right! no stupid useage, no installing questionable, no trying anything illegal.

    so this shouldn't be happening.

    as I wrote to the author of the youtube, I suspect this is a kind of useage "nudge"- where the only way you can use your messaging, is if you shut off wifi and of course, if you're a big user, you'll rack up those extra minutes.

    if this were a unique issue, meaning an occasional problem for some users, then it would be understandable. but it's obviously become a relatively common issue because there's a lot of bb discussion on it in various forums.

    I recently received a system update 12/23 and after a week, it started happening - not frequenly, just occasionally. then these last couple of weeks, it was up to every 10 seconds. and of course, it upped my usage.
    02-11-2015 09:51 AM
  13. seattle3713's Avatar
    A few days ago I realized my battery was draining way faster then usual. I noticed it's b/c of the WiFi switching on and off for no reason. Even if I had full bars fir WiFi it keeps switching back and forth. I too have had the smart network switch on since I got the phone almost a year ago and never had a problem before.

    Just saw this forum and hope disabling the smart network switch helps. I have T-Mobile and by reading reading previous posts it doesn't seem to be network based, it sounds like a lousy update Android did.

    I've had the Galaxy S3, S4, and now S5. This is the first issue I've ever had with their phones.

    Hope they fix it soon.
    02-11-2015 10:49 AM
  14. Robin Wilson2's Avatar
    I've restarted mine each morning and it still does it. I have a good connection when talking on the phone but the constant beeping from my possible drop call warning is very annoying. I'll try contacting Samsung about it.
    02-12-2015 06:27 AM
  15. Robin Wilson2's Avatar
    Turned off the Smart Network switch. It still beeps that I may drop my call but not as frequently. I can deal with that for now.
    YsLadyMN likes this.
    02-12-2015 06:37 AM
  16. shockeymoe's Avatar
    I just turned off "Smart Switch" and set my wifi connection to static rather than through DHCP.
    These changes have stabilized my connection. I am not sure which one it is that fixed it but now it is working better. Thanks to all for the suggestions.
    YsLadyMN likes this.
    02-13-2015 02:28 PM
  17. Jim Mike's Avatar
    I believe this problem came about after loading android 5. Likewise, i disabled smart network switch. I just did it so not sure how much it helped but i think it made some difference. Wifi not connecting and disconnecting so frequently. Thanks for the info.
    02-14-2015 05:11 PM
  18. YsLadyMN's Avatar
    I was looking for an answer to a different wi-fi question when I saw this.
    I'm on AT&T with my S5.
    Under the Wi-Fi settings I have an option for "Smart Network Switch" which says it Automatically switches between Wi-Fi and mobile networks to maintain a stable internet connection. Anytime a computer says it automatically does something for me; I typically say no thanks. I don't typically like my devices making assumptions of what I like, don't like or want to do. So I have that option unchecked. I never have an issue with the network stability once I've connected to a specific wi-fi connection.

    Not sure if that will help you all or not. But thought I'd share.
    I TOO determined this was the problem. With ANY fluctuation in signal on my WIFI network, the phone would switch to 4G and then start WIFI scanning. Turn it off, all seems good with the world.
    02-15-2015 01:49 AM
  19. YsLadyMN's Avatar
    This^^^^

    Same here for my S5 and my Wifes S5. Both had this Wifi issue after lollipop. You should NOT have to turn stuff off to fix an issue that started immediately after a major Android update. . I have the network switch off ATM and hoping Verizon comes out with a fix..
    FWIW, mine was going this before the Lollipop update... turning off the smart network optimizer seems to do the trick short of beating Sansumg over the head for a fix. I talked to them for over a half hour today working through issues... and as usual the answer is the factory data reset. Wish I could send them a bill at my standard hourly rate for almost 5 hours of screwing around to get my phone useful after the update... but like I said, mine was doing this from day one. Which I bought mine on September 1, 2014 when it was loaded with KitKat.
    02-15-2015 01:55 AM
  20. howie0093's Avatar
    i went in and made sure the smart network box was unchecked under my WiFi settings and i haven't had the issue occur since... And I never had any problems with the WiFi until AFTER update.. just FYI
    02-15-2015 03:42 PM
  21. hybucket's Avatar
    FYI - I'm on a new Galaxy 5 with AT&T on 4.4. The wifi dropping issue was driving me nuts (well, nuttier...) til I found this thread. I disabled the SMART NETWORK SWITCH and now all is well. I always had the switch turned on with my Galaxy 3 and still do on another S3 with no problem, so this has to be a Samsung bug. Obviously, it was not fixed even with the Lollipop update. As others have said, you should not have to disable a feature to get the phone to work properly.
    02-16-2015 05:34 PM
  22. t_wysocki's Avatar
    My wife and I have two new Verizon S5's and they both have the same exact problem - dropping the wifi connection even though they say they're "CONNECTED". They're not pingable from my network. The smart network switch does no good on either one. If I "forget" the connection and re-establish it, it works for a short time only. And they wonder why people buy the iPhones.
    02-17-2015 08:40 PM
  23. SaraT81's Avatar
    I have been having this problem for 2 weeks now even replaced my phone. I am beyond pissed but it worked to turn off the smart switch. Samsung needs to fix this now!
    DeBuiser likes this.
    02-18-2015 07:40 PM
  24. SaraT81's Avatar
    I factory reset and warranty replaced mine. A lot of time wasted resetting everything up and on the phone with tech support. I agree they should pay us!
    DeBuiser likes this.
    02-18-2015 07:44 PM
  25. kk1l's Avatar
    Folks,

    I was having the same trouble on my home network. The android devices would disconnect and reconnect several times an hour and as much as once a minute. On my wireless access point I had "WMM" (WiFi Multimedia) turned on with acknowledgements turned off for better throughput. Turning acknowledgments back ON cured my connection problems. Steady now for quite a while!! I had tried lots of things before reaching this conclusion.

    Ron <><
    02-21-2015 02:07 PM
108 12345

Similar Threads

  1. How to Root Galaxy S4 (LTE+) I9506 on Android 4.3 Jelly Bean
    By eriktuz in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 2
    Last Post: 06-18-2014, 08:05 AM
  2. [Guide] How to root Samsung Galaxy S4 I9500 [Jelly Bean]
    By eriktuz in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 05-06-2014, 08:12 AM
  3. Galaxy S4 help
    By carlos9032 in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 1
    Last Post: 05-05-2014, 05:17 PM
  4. New S5 user
    By dgrobe2112 in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 05-03-2014, 01:20 PM
  5. Replies: 0
    Last Post: 05-03-2014, 09:53 AM
LINK TO POST COPIED TO CLIPBOARD