09-04-2017 04:16 PM
106 ... 2345
  1. Colebra Friz's Avatar
    I had this same problem and could get no help. I was told it was working fine. i was so mad. i read all i could find to no avail. After a week of playing with the settings I have found and fixed my problem.
    I hope this help you as much as it did me.
    02-24-2015 09:24 AM
  2. Raza ul mustafa's Avatar
    Wooo. I am still getting same problem. Wifi really make my mind out of freek. I have ready news from a site ...aaah it was i think Mobile phone prices - Specifications - Price in Pakistan which solve my problem, go and search s5 problem. I was looking but right now it's not on home page.
    02-24-2015 09:55 AM
  3. JenJen00au's Avatar
    I think my experience is along the lines of this thread, they have to be connected somehow.
    We have 2 Samsung S5's, an S3 & an S2. The S2 is banned from having mobile data on, so fingers crossed he's not an issue. But the other 3 have been losing 1MB at a time, 3 - 4 times a minute, random minutes through out the day. Upon studying our usage that lists the times of each transaction, it apparently started when we first got the phones - but I didn't look into it enough to see the activity, I just thought they were teens, they needed lots of data. But since December things seem to have ramped up. The phone chipped away at our data so much that my son lost 1.7GB of data in one day, all in 1MB lots. It made 1437 entries on our statement. We are still trying to work out why the phones are behaving like this and what has changed for them to increase their activity. Have switched off the feature that allows the phone to switch between wifi & data, have restricted background app activity, and have to keep turning off our mobile data after each use. Forget, and you pay. It's rampant.
    I have data usage notifications in place, but none of the phones triggered these. It wasn't until our provider sent emails saying we were almost out of data - after 3 days, that we were alerted to it. I rang Samsung, who then told me that their data usage app, that monitors your data usage, actually only monitors data you physically use - ie play a video, go on FB, etc. It DOES NOT record the data consumed by background apps. So in effect, their 'data usage' app, can not be relied upon, because it doesn't mean ALL data usage.
    I was livid. False advertising, putting people into a false sense of security.It's not till you get your massive bill, do you see the problem. So we are still unable to use our phones unless we are in a wifi area, and mobile data is off. We have uninstalled many apps today, and will find out later if that has made a difference. There is no way of knowing which app is doing it. Is it a factory app? I have installed Onavo, but it also seems to be showing less usage than our provider does. HELP???? In Australia.
    02-26-2015 04:06 AM
  4. Glen Zammit's Avatar
    I had this same problem and could get no help. I was told it was working fine. i was so mad. i read all i could find to no avail. After a week of playing with the settings I have found and fixed my problem.
    I hope this help you as much as it did me.
    Ive just had the same problem starting from last night and this one worked for me.
    03-13-2015 05:56 AM
  5. JenJen00au's Avatar
    I did that Glen - a very important little function that they don't advertise. However, I DID discover what the problem was. The provider was the problem, on two counts. In the last few months, they decided to charge for all social media usage which had previously been free. On top of this, it became news to me that no matter what you did in a session on the net, they round up the billable amount to 1MB. So each time my phone connected to the internet (3 times a minute) they deducted 1MB off my data. Even if my phone only used a few kb's(sent an sms or got a weather update), they'd round it up to 1Mb. So basically they are stealing my data. So you think you are connected to home wifi, and for some reason your phone thinks it can get a better signal from mobile data, it will jump back and forth between the two (if you have not turned off Smart Network Switch) and so each one of these 'jumps' counts as a session. You could easily think your download is free, until you get the bill. Needless to say, we are now moving our 4 numbers over to a carrier that bills in kb's, not Mb's.
    03-13-2015 07:18 AM
  6. Rae Johns's Avatar
    Great thank you! That fixed my problem!
    I'm glad because I have been looking for the optimizer connection as mentioned in an earlier post but couldn't find one.
    03-17-2015 01:49 AM
  7. alipan's Avatar
    I think I have a fix for my Galaxy Note 2 - I have also been tearing my hair out for the past 6 months and that is following 18 months of no problems.
    I had tried all the usual tips and advice to no avail but today I happened across an entry in your forum.
    However I lost the kind person's contact item who inserted it - He (or She) is a life saver.
    This problem seemed to arise after receiving my new BT type 4 modem and contract even though I set up the new modem as per the book and I am able to receive a good wifi signal.
    Unfortunately it not only keeps losing a connection but demands that I reconnect even though it has remembered the PW it is still not a workable situation.
    Well, it seems to work for me now even when there are no signal bands at all it still does not disconnect now - HALLILUYA.
    Here's the fix: Go to SETTINGS, WIFI, select bottom left menu button and select "WPS BUTTON".
    A blue bar starts timing and then before it 'times out' press your MODEM WPS BUTTON for a few seconds (to make sure).
    Your phone should start searching and should eventually "LOCK ON" to the signal.
    Seems OK all day so far - hope it works for you as well - good luck.
    03-21-2015 10:35 AM
  8. s milverton's Avatar
    im getting the same happening to me in Australia on the optus networrk. But he wifi unit is literally about 2 ft from the phone most of the day. It is dropping connection hundreds of time s a day. And now the camera stalls the whole phone and i need to reboot it when i activate the camera. The phone is only a month old.
    I thought the S5 was meant to be a good phone. Never had any trouble with my old HTC. Wish i was still using it now
    04-02-2015 12:57 AM
  9. Mars Binika's Avatar
    Samsung galaxy s5, bought about 4 months ago, started to have the same problem, it doesnt stay on wifi, drops as soon as you sign on, tried everything and all suggestions on the net , but it doesnt work, brought to the Samsung rep at the Best Buy, where I bought it from, the rep did something to the settings and claimed that it will work,but it is having the same problem, all other devices working on the wifi are working perfectly, without ever having a problem, it seems like a device problem and Samsung should rectify it
    I found that turning off mobile data and having only WiFi on helps.
    04-18-2015 07:10 PM
  10. iamladydi's Avatar
    I just uninstalled my anti-virus software and now my wifi will stay connected. It was McAfee. I may try to install again or just look for another app, but so far so good. This has been going on for months only with my wifi at work. Had the same issue with a Sony and returned because of it. The Samsung S5 worked fine for the first month or so, then it started happening again. I had also tried EVERYTHING mentioned here, but nothing worked. Fingers crossed it will stay connected.
    04-28-2015 02:17 PM
  11. DarkUltra's Avatar

    I have the same problem. It is especially sad for me because I use tasker to turn off lights and heat when I don't have wifi (when I leave the house).

    It started happening after I upgraded my S5 to lollipop. I have the G900F international version. Smart network switch option is and have always been off.
    05-21-2015 10:59 AM
  12. Toshkibambino's Avatar
    Just go in to Wifi and untick the Smart Network Switch. This solved my issue immediately.
    06-09-2015 01:15 AM
  13. disabati's Avatar
    This is an older post with many ideas for resolving this issue and here's how I resolved mine. I have a Galaxy Note 3 and had the same issue for nearly 6 months until I finally figured out what was going on. I'm sharing here in case others have a similar set of circumstances.

    1. I have a router (Fios) that supports dual band (2.4 & 5gHz) WiFi frequencies. When I set up the router, I thought I would make it easy for everyone wanting to connect to my home network and named the SSID the same for both radios (in my case, "MyWiFi"). This seems to work for most phones because many older phones don't support the 5gHz band. So, when those phones connect, they are connecting to the MyWiFi 2.4gHz frequency and they stay connected because there are no other options their phones support.

    2. My Galaxy Note 3, like many newer phones, supports both band frequencies. Thus, when I set the WiFi setting on my phone to connect to "MyWiFi", it connected to either the MyWiFi 2.4gHz or 5gHz band, depending on how far away I was from my router. Although the 5gHz band provides a more stable connection and is generally preferred, it also has less range than the 2.4gHz band. Thus, depending on whatever interference I was experiencing while walking around the house, my phone would many times drop one band in favor of the other (remember, in my case, both SSIDs were called "MyWiFi"). So, it always appeared that the WiFi connection would drop, connect to 3G/4G, and then later reconnect when in fact one radio frequency was being dropped in favor of a better signal (both of the same SSID).

    3. SOLUTION - I simply changed the SSIDs on the two bands of my wireless router to:
    (1) MyWiFi-2.4gHz and
    (2) MyWiFi-5gHz
    This has resolved my WiFi disconnects and allows older phones to still connect (older phones will only see "MyWiFi-2.4gHz"). Dual band phones will see both WiFi frequencies and should pick "MyWiFi-5gHz" in this example (unless the house is huge, the 2.4gHz connection could actually work better).

    CONCLUSION - If anyone has:
    (1) a dual-band wireless router, and
    (2) happened to setup the SSID on both radios using the same name (like I did), and
    (3) your phone is a dual band phone like many of the newer Galaxy (and iPhone) phones,
    the solution above may resolve your problem. It certainly fixed mine.
    06-18-2015 08:40 AM
  14. Anagoge's Avatar
    I've read the four pages of this thread. The only clear option seems to be turn off Smart Network Switch. However, that option isn't available on an S3.

    I've had my S3 for two years. No problems with wifi until the last few weeks. Unless there was a software update without me realising, I feel like perhaps it might be more of a router issue than a phone issue. What do you think?
    07-01-2015 02:59 PM
  15. hybucket's Avatar
    May depend on your carrier, but I"m on AT&T, I have an S3, and it does have the Smart Network option (under WiFi in the settings). You may have to update to the latest Android version, which I think is 4.4 on the S3 (it has not gotten the 5.0 version to my knowledge). But the Smart Network Switch is indeed the best solution to the problem, assuming you don't have other issues. (My S3 and S5 both had the dropout issue, but only on some WiFi connections, not all of them).
    07-02-2015 10:44 AM
  16. Ashley Welborn's Avatar
    My issue is that I get kicked off of my WiFi connection I have reset the modem , router as well as my phone . This is only happens when in Google maps . I have reported this issue time and time again.
    08-02-2015 12:31 AM
  17. mikebeamer's Avatar
    I have Note 5 on Verizon. I have unchecked smart network switch and that does not help. What's the next step?
    10-13-2015 10:46 AM
  18. bluerap's Avatar
    Using an S5 and an ASUS router here. Started having this problem after tampering with the router settings. Performing a factory reset on my router worked for me.
    10-17-2015 12:38 PM
  19. Darth Wylder's Avatar
    I was having the same issue with WiFi disconnecting quite frequently and as soon as I un-ticked this "Smart Network Switch" option, under WiFi in settings, everything has been great and I am no longer being disconnected.
    This was the answer to my WiFi woes. Thank you so much.
    04-19-2016 12:39 PM
  20. Jeric1963's Avatar
    I was looking for an answer to a different wi-fi question when I saw this.
    I'm on AT&T with my S5.
    Under the Wi-Fi settings I have an option for "Smart Network Switch" which says it Automatically switches between Wi-Fi and mobile networks to maintain a stable internet connection. Anytime a computer says it automatically does something for me; I typically say no thanks. I don't typically like my devices making assumptions of what I like, don't like or want to do. So I have that option unchecked. I never have an issue with the network stability once I've connected to a specific wi-fi connection.

    Not sure if that will help you all or not. But thought I'd share.
    I have been dealing with this for over a year. I have called my cable company several times, bought 3 new routers, and it NEVER dawned on my it was my phone since it had never done that before. It had cost me in date over charges, battery draining fast, and charges for the cable company coming 6 times. Thank you I am going to give this a try. I can't express the level of anger a fricken phone can actually give you.
    05-31-2016 09:37 AM
  21. HandsomeP's Avatar
    I had the same problem, my wife's Samsung S4 was taking down the network. Several other devices connected without issue including my cell phone, but for some reason her phone crashed the network when she turned Wi-Fi on and connected to the network. We tried many things which did not work, and in our case the solution was to create a Guest Zone on the router to which she connected with her Samsung S4.
    06-29-2016 11:10 PM
  22. ssello's Avatar
    Smart Network Switch is the problem. Unchecked that box and now my Wi-Fi works like a charm. Stays connected.
    07-04-2016 08:53 AM
  23. anon(8114070)'s Avatar
    Smart Network Switch is the problem. Unchecked that box and now my Wi-Fi works like a charm. Stays connected.
    Where is the setting?
    03-03-2017 01:52 AM
  24. All Y_all's Avatar
    Where is the setting?
    It's in your wi-fi menu, under "advanced." The only problem with this solution to an obvious problem that Samsung doesn't appear to want fixed, is you're constantly switching between mobile & wifi! Could get quite pricey unless you're lucky enough to have true unlimited service. I've had my Samsung 5 for several years without this issue, just cropped up a few months ago. I'll be going back to a Motorola for my next phone.
    04-16-2017 06:34 PM
  25. Genesis1975's Avatar
    This worked for me in limited sample size. Only annoying thing is the show I'm watching will sort of pause with audio still running, then speed up to catch up.

    Edit, meant to quote that it's the smart network switch that I unclicked.
    04-30-2017 08:26 PM
106 ... 2345

Similar Threads

  1. How to Root Galaxy S4 (LTE+) I9506 on Android 4.3 Jelly Bean
    By eriktuz in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 2
    Last Post: 06-18-2014, 08:05 AM
  2. [Guide] How to root Samsung Galaxy S4 I9500 [Jelly Bean]
    By eriktuz in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 05-06-2014, 08:12 AM
  3. Galaxy S4 help
    By carlos9032 in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 1
    Last Post: 05-05-2014, 05:17 PM
  4. New S5 user
    By dgrobe2112 in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 05-03-2014, 01:20 PM
  5. Replies: 0
    Last Post: 05-03-2014, 09:53 AM