1. Steven Friedmann's Avatar
    Everything was working fine until after I installed the following apps from the Amazon Appstore free apps giveaway on May 16: Perfectly Clear, TouchRetouch, Paper Camera, and PicFrame.

    Since then:
    • The camera no longer saves pictures to the SD card
    • Files can't be written to the SD, either with My Files or via my PC
    • Search results for files are ordered in descending order, regardless of how I set the preferences (ascending), whereas the results followed suit before the problems started

    I uninstalled those apps, but the problem persists.
    I'm thinking that something got messed up in the permissions or the way the Camera and My File apps interact with the SD. Where they had write access before, it's as if they lost it.

    Has anyone else had this problem?

    Does anyone know how to fix it?
    05-22-2014 02:29 PM
  2. ExtremeNerd's Avatar
    First thing first, try a different SD card in your phone.
    Then directly attach the SD card to your computer.

    If both of these work, your SD card is likely fried. That is my first inclination, not that permissions got messed up.
    05-22-2014 02:40 PM
  3. jpr's Avatar
    I don't know what happened to your card but if your file system got corrupted them it would be best to reformat it. Back up your files to your computer. If you have any apps installed on the card, move them over to the phone. Then format the card from the phone settings.

    It's also possible you could be having a hardware failure with the card and your app installs were a coincidence but try the format and see if it is solved.
    05-22-2014 02:41 PM
  4. Netherscourge's Avatar
    What type of SD card is it?

    Brand? Class?

    05-22-2014 02:43 PM
  5. Steven Friedmann's Avatar
    It's a SanDisk 64GB Class 10. Still reads fine. I will try your solutions - thanks!
    05-22-2014 03:09 PM
  6. sirmaru's Avatar
    Before you do anything else, open up the back and press the SD card in harder. The contacts may have loosened.
    05-22-2014 03:15 PM
  7. bembol's Avatar
    It's a SanDisk 64GB Class 10. Still reads fine. I will try your solutions - thanks!
    I had that SanDisk too and was fried after 4 months. I couldn't write anything either.

    When I ran Disk Utility it forced me to format but afterwards it wouldn't read either. Sent it for RMA. Twice actually the new replacement was dead again after a few months.

    Anyways I went back to Kingston just wanted to see how SanDisk was.

    Pro S5
    05-22-2014 04:25 PM

Similar Threads

  1. XLTE...OK TMo what are you going to do now?
    By LuvMusic in forum T-Mobile
    Replies: 49
    Last Post: 01-28-2015, 04:10 AM
  2. Won't Boot Up
    By comptech520 in forum Motorola Droid MAXX
    Replies: 5
    Last Post: 05-27-2014, 07:57 PM
  3. Upset I can't make my own ringtones!!!
    By Elizabeth Margoshes in forum Motorola Droid MAXX
    Replies: 7
    Last Post: 05-25-2014, 11:09 PM
  4. Replies: 2
    Last Post: 05-22-2014, 05:24 PM
  5. Connected to internet message
    By darryjr in forum HTC One M8
    Replies: 0
    Last Post: 05-22-2014, 01:19 PM