1. Ian Ivey's Avatar
    In the Security settings, I've enabled "Unknown sources" but when I run the Amazon App Store installer, the installer shows the permissions and device access page, with Cancel and Install soft buttons at the bottom, but the Install soft button is non-responsive. The Cancel button works.

    Any ideas?
    05-23-2014 12:20 AM
  2. jpr's Avatar
    Are you by chance running the app Screen Filter? That's a known bug if so. If not, maybe another is interfering. If you have the screen filter app just turn it off until the install is over.
    Ian Ivey likes this.
    05-23-2014 12:46 AM
  3. Ian Ivey's Avatar
    How about that. No, I wasn't running Screen Filter, but I was running an app called Twilight, which dims and shifts the color of the screen toward red in the evening. Your comment made me think about anything that might be affecting the screen, so I paused Twilight, and the Install button immediately became responsive.

    Nice tip -- thanks for the help!
    jpr likes this.
    05-23-2014 01:38 AM
  4. AZgl1500's Avatar
    You are better off to NOT install Amazon Suites.

    That single app is the worst battery hog there ever was made. I had to delete it off the phone because it constantly keeps sending data back and forth.

    thank you, but a pc is the only way I will mess with Amazon.
    05-23-2014 04:39 AM
  5. junkmaledr's Avatar
    Brilliant! Similar problem on my LG. Got the Amazon App Store to install, and a few of the apps I have stored there, but then it quit. I had seen the tip about Screen Filter but I had never heard of it and didn't know what it was. I DO run Twilight. Precisely the problem. Pause Twilight and the installer works perfectly. Many thanks!
    04-06-2015 12:10 PM
  6. Wired Kel's Avatar
    Solved for me too. I've been frustrated for about a month over this. I use an app called Darker that lowers the brightness when I'm reading in bed. Stopped it and the Install button worked again. I'm not going back to sleep now, though. ;-)
    04-17-2015 05:25 AM
  7. chrisgianti's Avatar
    POTENTIAL SOLUTION...same issue. I'm on samsung note 3 with 5.0 software. Even when I succeeded in installing, apps were slow or never would install. Some, once installed, wouldn't recognize the appstore as present.

    So I happen to have an old version called "Appstore-642000010.apk" it worked quickly and so did the apps I installed through it. It was flawless. I was surprised.

    The icon for this version has a little hand on it. The icon is orange with a white stripe across the top. If you're unable to find an old version of the appstore on google, let me know and I'll figure out a way to share it.
    07-29-2016 08:15 PM

Similar Threads

  1. How can I save an (APK?) app and reinstall later?
    By paisley99 in forum General Help and How To
    Replies: 6
    Last Post: 06-12-2014, 12:35 PM
  2. Can I replace just one app icon?
    By paisley99 in forum General Help and How To
    Replies: 6
    Last Post: 05-24-2014, 10:31 PM
  3. Not just tied to the Galaxy S5
    By kirkturk in forum Samsung Galaxy S5
    Replies: 18
    Last Post: 05-24-2014, 07:54 PM
  4. Samsung Apps Auto-Update Question
    By ryguy2008 in forum Samsung Galaxy S5
    Replies: 7
    Last Post: 05-23-2014, 01:54 PM
  5. Problem with WiFi and 3rd party apps
    By debslosingit in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 05-22-2014, 11:50 PM