1. jaltman's Avatar
    Lately I have started getting the "security update failed" message repeatedly. I can turn off the automatic updates, but I can't figure out why the message is occurring. I have two s4's in the house and neither of them are having the message. I am not sure whose server it is failing to connect to. Is it samsung or is it my exchange server. The security certificate was updated recently on the office server which has exchange on it. No other changes were made in the security policies on that server.

    I uninstalled and re-installed all the Active Sync stuff. But it still happens. Active sync is actually working fine.

    Any guidance would be appreciated.
    t11rmh and c_urbanek like this.
    05-28-2014 06:32 AM
  2. c_urbanek's Avatar
    i've got the same issue on sprint galaxy s5... rooted... are you rooted? could be knox related?
    05-28-2014 01:48 PM
  3. jaltman's Avatar
    i've got the same issue on sprint galaxy s5... rooted... are you rooted? could be knox related?
    Not rooted here, nor do I suspect it can be Knox. No Knox components running on the server. So I doubt it could be that, but I guess a gross bug in Knox could be generating an error when its not in use, but I think it is unlikely.
    05-28-2014 05:04 PM
  4. jaltman's Avatar
    Well, I have good news and bad news. The good news is I fixed it. The bad news is a did a factory reset. It now updates correctly. All I can suspect is that something caused some corruption and starting over cleared it out. Painful, but successful.
    05-28-2014 07:36 PM
  5. tsanchai's Avatar
    What work for me is to go to Settings - application manager - all then go to security policy updates. Clear cache and stop the service. Then go to Settings - Security and update. It work for me
    07-02-2014 07:47 PM
  6. Navik von Bathory's Avatar
    Tsanchai's advice worked for me.
    07-07-2014 04:20 PM
  7. Coching's Avatar
    I tried tsanchai's method, but it didn't work
    07-14-2014 05:50 PM
  8. Tomcat31b's Avatar
    Tsanchai's method worked for me also but I took an extra step of restarting the phone before trying the update again

    Posted via Android Central App
    07-14-2014 06:29 PM
  9. ellsswhere's Avatar
    For those this did not work for... I went into the policy updates, storage, and manager service and cleared the cache as well as cleared data. Restarted my phone and went to update. This solved the problem
    ebanks89 likes this.
    07-19-2014 06:27 PM
  10. jmagid51's Avatar
    What work for me is to go to Settings - application manager - all then go to security policy updates. Clear cache and stop the service. Then go to Settings - Security and update. It work for me
    Worked for me too.

    Cleared the cache
    Cleared the data
    Forced stop
    Restarted the phone
    Did the update manually.

    Thanks.!!

    Sent from my SAMSUNG-SM-G900A using AC Forums mobile app
    JshBlckbrn likes this.
    07-21-2014 01:23 PM
  11. LarryBauer's Avatar
    Worked for me too.

    Cleared the cache
    Cleared the data
    Forced stop
    Restarted the phone
    Did the update manually.

    Thanks.!!

    Sent from my SAMSUNG-SM-G900A using AC Forums mobile app
    Worked for me too, on my S5 Verizon. Thanks All !
    07-30-2014 11:59 AM
  12. JshBlckbrn's Avatar
    Worked perfectly! Thanks.
    07-30-2014 04:16 PM
  13. Anil Swain's Avatar
    It worked for me as well.. Thanks for the advice.
    08-05-2014 10:47 PM
  14. Dthekilla's Avatar
    Worked ty!!
    08-28-2014 03:18 AM
  15. oldsoldier's Avatar
    Worked!
    08-28-2014 09:29 AM
  16. TimmyTwo2's Avatar
    Worked for me too!
    08-28-2014 12:45 PM
  17. destiple's Avatar
    This did not work for me. Crud!
    12-09-2014 03:42 PM

Similar Threads

  1. Galaxy S5 - Front camera ring piece loose - defective
    By paipuky in forum Samsung Galaxy S5
    Replies: 23
    Last Post: 07-30-2015, 04:30 AM
  2. Replies: 8
    Last Post: 06-14-2014, 10:15 PM
  3. Software update from AT&T interupted
    By TxDaydreamer1 in forum Samsung Galaxy S5
    Replies: 7
    Last Post: 05-28-2014, 09:25 PM
  4. i9500xxufne4 Update?
    By TowersVault in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 05-28-2014, 05:10 PM
  5. The TV remote app is gone missing on my S5...
    By Sterango in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 05-28-2014, 03:06 AM
LINK TO POST COPIED TO CLIPBOARD