1. ElectricSheepDreamer's Avatar
    I have a wireless qi charger from Linocell that I use with my Galaxy S5. It works well, except that the screen keeps lighting up intermittently, even though I'm not getting messages and the battery isn't full. I can't find any information about this anywhere...
    05-28-2014 03:23 PM
  2. dpham00's Avatar
    It has happened to me before. For me, it was because the connection was not very good. Maybe try to reposition the phone

    dpham00, Android Central Moderator
    Sent from my Verizon Samsung Galaxy Note 3
    05-28-2014 03:27 PM
  3. GuyInRockford's Avatar
    It happens because when the battery reaches 100% the charger disconnects and reconnects when the battery drops to 99%. Unfortunately, it will keep doing this the whole time. What I do, since I use it at night, is turn down the screen brightness all the way down and turn down the notification volume as well. Hope this helps.
    05-28-2014 04:40 PM
  4. ElectricSheepDreamer's Avatar
    I'll give it a try, thanks.
    05-30-2014 11:53 AM
  5. ElectricSheepDreamer's Avatar
    It has happened to me before. For me, it was because the connection was not very good. Maybe try to reposition the phone
    Thanks, I'll give it a try.

    - - - Updated - - -

    It happens because when the battery reaches 100% the charger disconnects and reconnects when the battery drops to 99%. Unfortunately, it will keep doing this the whole time. What I do, since I use it at night, is turn down the screen brightness all the way down and turn down the notification volume as well. Hope this helps.
    No, that's not it, because as I said it happens regardless of the battery level.
    05-30-2014 11:55 AM
  6. jharo's Avatar
    Did you ever find the problem for this? I'm having the same issue. It begins to charge then disconnects and reconnects ever few seconds or so. I'm gonna try and reset the qi receiver under the battery cover.
    06-18-2014 04:32 PM
  7. MK Redding's Avatar
    Check your power supply. I noticed that if I use a power supply less than 2mah I would get the connect disconnect problem. once I swapped out the lower power units the problem stopped.
    06-21-2014 10:40 PM

Similar Threads

  1. Is it OK to charge the phone from 30%/50% to 100%?
    By Omer San Gabriel in forum General Android Device Chat
    Replies: 6
    Last Post: 03-09-2017, 02:22 AM
  2. Network problems?
    By Emma Mastad in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 05-31-2014, 09:41 AM
  3. Dont know if this is a problem or a feature....
    By alpinecivic in forum T-Mobile Samsung Galaxy Note 3
    Replies: 3
    Last Post: 05-29-2014, 09:59 PM
  4. Motorola Boot Service problem!
    By Balsalobre in forum Moto G (2013)
    Replies: 2
    Last Post: 05-29-2014, 07:35 AM
  5. Official Wireless Charging Kit Issue!!
    By Warcony in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 05-29-2014, 04:43 AM
LINK TO POST COPIED TO CLIPBOARD