1. tty7's Avatar
    I assume I'm not the only person in the world with a Samsung Galaxy S5 and who uses Mac.

    I have a pretty current MBP 15" and a somewhat dated MBA. The Air runs Mavericks and the MBP runs Mtn. Lion.

    I began using my S5 with the MBA and could never get Android File Transfer to work. But it worked just fine on my MBP. Only difference (I thought) being the OS.

    Well, for this reason, I never upgraded my MBP from Mtn Lion to Mavericks.

    Today, I stupidly ran the Verizon Installer on the iso image that auto-mounts when you first connect the phone. All of a sudden - on my MBP that has worked for the last 2 months - AFT stopped working.

    So, I'm convinced:
    1) I must have run the Verizon Installer on my MBA at some point, which is why AFT never worked.
    2) the drivers that the Verizon Installer install are crap drivers and don't work with the S5 even though they're bundled.

    There's no support for it on the Verizon site, and no uninstaller.

    Ideas? I'd love to be able to put more music on my phone ... without setting up a web server, hosting my music, and manually downloading each song I want on my phone... lol

    06-01-2014 11:27 AM
  2. mhunter6378's Avatar
    Have you tried rebooting the Mac while your phone is connected via USB? Sometimes that works and makes AFT work.
    06-01-2014 11:34 AM
  3. tty7's Avatar
    Hi, I figured it out.

    It's a bad driver from Verizon.

    When you plug in the phone, it first attaches as an "installer" and presents an ISO960 (cdrom) image to the OS.

    f you wait, it will go away and the device will mount under AFT just fine, and present your files.
    If you're in a hurry, you can go to the S5 screen, under the alerts click on the USB thing, and check the "MTP device" box, which puts the phone immediately into media transfer mode.

    Wait.. what? you installed that thing called "Kies?" Or you (like me) accidentally forgot that Verizon porks for drivers, and ran the installer instead of just waiting for MTP with AFT to kick in?

    Here's your fix:
    I found out (after installing Kies on the computer that stopped working) that Kies uses a driver called "ssuddrv.kext" when its installer runs.

    It lives in /System/Library/Extensions/ssuddrv.kext

    launch terminal and execute:
    sudo r m -rf /System/Library/Extensions/ssuddrv.kext

    ** note there is a space on purpose in the "r m" command because Incapsula would not let me post a command that remotes files. brilliant.. so omit the space when you try this. **

    really, just delete it... At first, I just moved it and rebooted to see if anything else would break. It's been about a week, and nothing has broken, and AFT + MTP on the Galaxy S5 is working just fine again.

    On both machines.

    The Verizon installer and Kies both install that dysfunctional ssuddrv.kext driver. Just delete it. Then reboot, then connect your phone and you're back to the point at which you can either wait for the device to go into MTP mode or you can manually check the box. Myself, I'm lazy, so I wait.

    Wish I could find a way to stop the phone from presenting an installer to the OS that doesn't work.

    Way to be awesome, Verizon. Worse than bloatware: bloatware that doesn't work.

    06-12-2014 06:38 AM
  4. JJM1975's Avatar
    Thanks for the tip. I gave up and just installed a ftp client on the phone and connected to that from filezilla on the mac.
    06-12-2014 07:09 AM

Similar Threads

  1. receiving mms issues?
    By kittenmurder in forum HTC One M8
    Replies: 4
    Last Post: 06-01-2014, 06:02 PM
  2. Some games (not all) crash - GoClever Terra 72
    By EsEmDee in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 06-01-2014, 11:14 AM
  3. ok Google widget and nova launcher question
    By Antmf in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 06-01-2014, 10:43 AM
  4. Wi-Fi Issues after Kit Kat update
    By adam13141 in forum AT&T Samsung Galaxy Note 3
    Replies: 0
    Last Post: 06-01-2014, 10:11 AM