1. tty7's Avatar
    I have a fix for the Device Not Found issue but Incapsula keeps preventing me from posting it.
    I'm going to do it line by line and see what the issue is.

    Hi, I figured it out.

    It's a bad driver from Verizon.

    When you plug in the phone, it first attaches as an "installer" and presents an ISO960 (cdrom) image to the OS.

    f you wait, it will go away and the device will mount under AFT just fine, and present your files.
    If you're in a hurry, you can go to the S5 screen, under the alerts click on the USB thing, and check the "MTP device" box, which puts the phone immediately into media transfer mode.

    Wait.. what? you installed that thing called "Kies?" Or you (like me) accidentally forgot that Verizon porks for drivers, and ran the installer instead of just waiting for MTP with AFT to kick in?

    Here's your fix:
    I found out (after installing Kies on the computer that stopped working) that Kies uses a driver called "ssuddrv.kext" when its installer runs.

    It lives in /System/Library/Extensions/ssuddrv.kext

    launch terminal and execute:
    sudo r m -rf /System/Library/Extensions/ssuddrv.kext

    ** note there is a space on purpose in the "r m" command because Incapsula would not let me post a command that removes files. brilliant.. so omit the space when you try this. **

    really, just delete it... At first, I just moved it and rebooted to see if anything else would break. It's been about a week, and nothing has broken, and AFT + MTP on the Galaxy S5 is working just fine again.

    On both machines.

    The Verizon installer and Kies both install that dysfunctional ssuddrv.kext driver. Just delete it. Then reboot, then connect your phone and you're back to the point at which you can either wait for the device to go into MTP mode or you can manually check the box. Myself, I'm lazy, so I wait.

    Wish I could find a way to stop the phone from presenting an installer to the OS that doesn't work.

    Way to be awesome, Verizon. Worse than bloatware: bloatware that doesn't work.

    thecomicbookandme likes this.
    06-12-2014 07:33 AM
  2. _YoKolorMeBadd's Avatar
    ... I don't have this problem.

    Sent from my SCH-I535 using Tapatalk
    06-13-2014 12:40 AM
  3. ajoroev_myskyl's Avatar
    thank you very much was having this problem a weeks after MAC YOSEMITE update, not it works just fine, thank you!!!
    tty7 likes this.
    11-12-2014 05:20 PM
  4. craigwill55's Avatar
    It works! Thanks for posting this. Hours of wasted time solved in minutes with your post!
    tty7 likes this.
    01-07-2015 11:11 PM
  5. csherman1's Avatar
    You are a hero!!!! This worked like a charm on my brand new, freshly rooted, Galaxy S6 Edge! BTW, I needed to reboot before it worked. Thank you!
    tty7 likes this.
    04-13-2015 01:01 PM
  6. harveypotato's Avatar
    This did not work for me (that file does not exist on my computer), so just in case someone else runs into my same issue, I thought I'd just say that all I had to do to fix the situation was get rid of HTC Sync.

    It was running in the background. A quick, temporary fix would be to exit the program via the mac's desktop icon located at the top, near the WiFi & volume indicators, right-click, and exit. A more permanent fix is removing it altogether. What seems to be the case, here, is Android File Transfer just won't even touch the phone if anything else could even potentially be accessing it (even if it's not). So weird and sensitive. But, hey, I got it working!
    11-18-2015 06:45 AM
  7. KT Pierce's Avatar
    There is no "ssuddrv.kext" on my entire system. Any other ideas?
    05-06-2016 10:16 PM
  8. tty7's Avatar
    I'll be honest: my original post was a month shy of two years ago.
    Since that time, I've had four OTA updates to my Verizon Samsung Galaxy 5S. Two were major release upgrades.
    My macs are now on 10.11.4, more than a major release and a half from where I started with this thread in 2014.

    I do clean installs on my Macs and have avoided Samsung Kies like the plague, and have also avoided letting the phone's automatic driver repo install to my Mac.

    I've continued to just go grab a copy of the Android File Transfer app and while I could say much about the poor quality of that app, at least it works.

    More honesty: my 2 year contract expired and my qualifications for a new phone were "Something that is NOT samsung that takes an SD card" so I ended up with an LG G5.

    Perfectly happy. Glad to have a phone that the manufacturer will actually continue to support; Samsung stopped development and support on the G5 after it was 5 weeks old. I watched LG and HTC support my friends' phones well into new android releases while I was ignored. Lesson learned. Avoid samsung.

    05-07-2016 06:24 AM

Similar Threads

  1. Android 4.1.2 internal storage issue
    By 007avenger007 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 06-15-2014, 04:33 AM
  2. Tracking app for S5
    By prodiger in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 06-12-2014, 11:23 AM