1. AZgl1500's Avatar
    This is the second time that I can recall that Google Services popped up a notification that it could not load. This was when I was trying to use Google Maps to locate an unknown address in an unknown city...

    Very aggravating, the phone became useless as a navigation device.

    GPS was working like a champ, my two different address locators zeroed right in and reported the Lat/Long but when they tried to download a map.... nada, just a blank screen with a blue dot "there you are clod" and the coordinates.

    When I got home, I fired up Kies 3 and restored "Location Services" back to day one. Lucky I made a full image copy back then when it all worked.

    Every thing is hokey dokey now, but it is a PITA when it happens.

    I thoughts are, that Google tried to do an update and something happened to interrupt that update.

    Your thoughts?

    07-25-2014 10:22 PM

Similar Threads

  1. Replies: 6
    Last Post: 03-02-2016, 04:20 AM
  2. S5 & Gear2 Conflict with in Car Bluetooth Use
    By kramali in forum Ask a Question
    Replies: 1
    Last Post: 09-07-2014, 04:00 PM
  3. How to take the best phone in the world and turn it into crap
    By Babbah Shanaba in forum Verizon Galaxy Note 2
    Replies: 4
    Last Post: 07-29-2014, 09:51 PM
  4. mic won't work in calls, works for voice commands
    By laurenlobo67 in forum Motorola Droid MAXX
    Replies: 1
    Last Post: 07-25-2014, 09:25 PM
  5. Google Camera on S3 - No HDR Mode?
    By bml203 in forum Samsung Galaxy SIII I9300
    Replies: 0
    Last Post: 07-25-2014, 08:11 PM