06-09-2015 02:13 AM
37 12
tools
  1. Dre-Sean's Avatar
    My galaxy s5 is disconnecting from my wife though I have all the settings for that type of thing off.. It disconnects and reconnects the moment it disconnects... What could be the issue?
    07-31-2014 09:19 AM
  2. FreddieF's Avatar
    What does the status below the Network name say?
    07-31-2014 10:14 AM
  3. whtciv2k's Avatar
    My galaxy s5 is disconnecting from my wife though I have all the settings for that type of thing off.. It disconnects and reconnects the moment it disconnects... What could be the issue?
    Does it happen with every wifi network you attempt to connecT to?
    07-31-2014 10:24 AM
  4. Dre-Sean's Avatar
    that im not sure about, im gonna test it today but what could be the reason it's happening to one router and not another one, if thats the issue?
    07-31-2014 10:39 AM
  5. whtciv2k's Avatar
    that means you are connecting to a faulty access point. Most home routers (from my experience) go bad after a few years of use. That is a sign that you need to replace it. As a test, you can powercycle the router you are connecting to. If it'll let you connect w/o drops then you'll be good for a day or two before you need to reset it again. If it continues to disconnect, i'd test connecting to a public connection to see if you experience the same issue, if you do then the wifi radio in your handset is probably the culprit.
    07-31-2014 10:45 AM
  6. Dre-Sean's Avatar
    It only does it to my phone though, not my laptop or anything
    oberstare likes this.
    07-31-2014 01:15 PM
  7. whtciv2k's Avatar
    yeah, sounds like the radio on your phone might be bad. Otherwise, I've seen it when certain devices don't like certain routers. Rare, but I've seen it.
    07-31-2014 01:16 PM
  8. Dre-Sean's Avatar
    I'd hope not or this will be my second time returning a phone. Wish I knew that store I bought it from wasn't corporate cause it seems like all his phones are ****ed up... Big *** sprint sign and it isn't even truly sprint..is there a way to attempt to fix this issue?
    07-31-2014 03:01 PM
  9. whtciv2k's Avatar
    That, I can't answer for you. Don't give up yet though, test it on another wifi access point and see if you still get the disconnects.
    07-31-2014 03:14 PM
  10. s_banks's Avatar
    In your settings there's a setting to change it. It disconnects when the wifi is unstable and uses the mobile network for faster speeds.
    08-01-2014 02:39 AM
  11. whtciv2k's Avatar
    Or what s_banks said lol
    08-01-2014 07:44 AM
  12. pharmdroid's Avatar
    I had the same issue. I had foxfi installed and it was sucking up battery as well. I uninstalled foxfi and restarted the phone. It works fine now.
    08-01-2014 10:40 AM
  13. Kc7's Avatar
    mine was doing the same thing. In Settings>wifi>advanced, I turned off Smart network switch. It seems to be working so far.
    SLCZurdo, LVREA, kaicho and 2 others like this.
    02-02-2015 10:56 PM
  14. kasra_baby's Avatar
    aaah THANK YOU SOOOO MUCH MAAAAN!!!! Auto switch was the problem!
    xzr1tv likes this.
    02-03-2015 05:13 AM
  15. rialinn's Avatar
    aaah THANK YOU SOOOO MUCH MAAAAN!!!! Auto switch was the problem!
    This is the exact problem I'm having, it's driving me crazy! I just got a new router thinking that was the problem but same thing is happening. I went to settings->wifi which brings up a list of wifi connections available, is this the right place? I selected my wifi connection bit dont see the smart/advanced setting you're talking about. Can you help??
    02-05-2015 10:37 PM
  16. rialinn's Avatar
    I'm not seeing the Smart network switch, can you help me with that before I drop this phone down a well?
    02-05-2015 10:44 PM
  17. rialinn's Avatar
    mine was doing the same thing. In Settings>wifi>advanced, I turned off Smart network switch. It seems to be working so far.
    I can't seem to find the Smart network switch, can you help? I went to settings and wifi which shows the list of available wifi connections, then?
    02-05-2015 10:47 PM
  18. sweetypie31's Avatar
    I can't seem to find the Smart network switch, can you help? I went to settings and wifi which shows the list of available wifi connections, then?
    Once you go to wifi, smart switch will be at the top.

    Posted via the Android Central App
    Attached Thumbnails Galaxy s5 keeps disconnecting from WiFi?-screenshot_2015-02-05-22-02-48.jpg  
    02-05-2015 11:03 PM
  19. SLCZurdo's Avatar
    mine was doing the same thing. In Settings>wifi>advanced, I turned off Smart network switch. It seems to be working so far.
    We have 3 S5's in my house which were all doing this. I turned off the Smart network switch and they have all stayed on the network solid.

    Thanks for the tip!
    02-05-2015 11:40 PM
  20. sweetypie31's Avatar
    I think that particular description is all wonky.

    Switching between networks does not make for a stable connection, makes it worse as we have all seen.

    Mine has been unchecked since day one.
    It's never actually worked for me. Unless I was doing it wrong.

    Posted via the Android Central App
    02-06-2015 01:34 AM
  21. Nate Hull's Avatar
    You need to tap the 3 dots icon in the top right exposing a menu, tap advanced. Then the smart network checkbox is on the top of the list.
    02-06-2015 12:53 PM
  22. KCP6030's Avatar
    I've had my S5 since last July with no problems cropping up.

    Just this week my S5 started acting funky. It kept dropping my wifi connection & immediately reconnected - over & over. A few times the S5 rebooted itself. Yesterday it got hot & ran the battery down quickly probably due to all the wifi dropping & reconnecting. I tried a number of different things before I realized it might be the repeated dropping & reconnecting. That's when I unchecked the Smart Network Switching. It seems to be OK now. Time will tell I suppose.

    Does anyone know the best way to notify Samsung about this?
    02-06-2015 07:05 PM
  23. Figaro14's Avatar
    If you have the Galaxy S5, go to Settings, then tap Wi-Fi under Quick Settings. It should be the first setting listed on the Galaxy S5. In the upper right hand corner tap on the three vertical dots. This will bring up "Advanced" as a choice. Tap on advanced and scroll down. You will see a choice that says "Smart Network Switch." UNCHECK IT. This will prevent the phone from going back and forth between a Wi-Fi connection and a 3G or 4G connection. I had the exact same problem and I knew the signal from my router was just fine because I had a strong signal throughout the house with my notebook computer and my other wireless devices.
    02-06-2015 10:14 PM
  24. Google Google2's Avatar
    mine was doing the same thing. In Settings>wifi>advanced, I turned off Smart network switch. It seems to be working so far.
    02-09-2015 09:26 AM
  25. majpaine's Avatar
    My Galaxy 5 Active has been stable until this latest update this past week and then my wifi went wonky.
    It would connect and then disconnect after a minute this causing other issues while surfing.
    I turned off the smart Network Switch and so far it is staying connected.
    I guess the only question is once I go out of range of the wifi will it switch back to cellular data, and vise versa when I arrive back in wifi range, or will I have to manually change from wifi to phone?

    I also noticed from this update that my phone has slowed down, and the battery is only lasting 7 hours instead of 15 hours.
    02-09-2015 09:48 AM
37 12

Similar Threads

  1. Google maps different on Galaxy 5 and Droid Maxx
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-31-2015, 05:05 PM
  2. Samsung galaxy s4 using too much data
    By Xegano in forum Ask a Question
    Replies: 6
    Last Post: 08-04-2014, 08:18 AM
  3. my galaxy note 2 security
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-31-2014, 02:06 PM
  4. Galaxy Note 3 on Verizon Issues
    By andyw80684 in forum Android 4.4 KitKat
    Replies: 9
    Last Post: 07-31-2014, 09:19 AM
  5. Sumsung S5 GPS in Europe
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-31-2014, 07:16 AM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.