1. montanaxvi's Avatar
    I've searched and read many posts about people having wifi issues saying it disconnects, or they have to change the settings to a static ip addy and so on.

    Mine is a weird one and not at all like most others I am seeing. The wifi works fine on the phone.....as long as I am actively using it. I've had my S5 on Verizon for about a month now and it just started acting weird this weekend. Mostly at home simply because I haven't been anywhere else with wifi to test it out. I do not believe it is doing this on 4G LTE but again, I haven't went anywhere this weekend to know for sure.

    The phone operates as normal as does the wifi, as long as I am doing something requiring it to be in use. Facebook app, browsing web etc. Once I am done with whatever I am doing and lay the phone down, the screen timeout kicks in like it normally does and I assume all is well. Give it 30-40 minutes and when I pick the phone back up and as soon as I use the data again, I will get a flood of ESPN app alerts all of them with the exact same, and current, time stamp, they are also old events such as scoring play in a game or end of game final score which happened already in real time, sometimes quite a while ago. Gmail notifications pop up saying I have new mail, Facebook app notifications show up as well as the Facebook app icon on home screen updating to show alerts pending.

    It is almost like something is turning off ALL the data when the screen times out, like it used to do on my older phones when I used Juice Defender (I have NOT installed it on the S5 at all, or any other battery saving apps) I do use the built in Samsung power saving function but have not had any issues like this until just this weekend, it started around Friday night that I know of.

    The wifi never disconnects that I know of, I get no error messages stating that my connection is unstable, I've tried to wipe the phone cache from the recovery menu, I've tried to "forget" and re-connect to my network for the last 2 days and it still does it. As long as I am actively using the data connection I will get things coming through on a push like basis. As soon as I allow the phone to go idle it seems like it just goes to sleep.
    08-18-2014 01:09 AM
  2. B. Diddy's Avatar
    Not sure if this will help, but go to Settings>Wi-Fi, tap Menu and then Advanced, and see if there is a "Wi-Fi optimization" setting. If you see one, turn it off. Wi-fi optimization is usually more about saving battery than improving reception, and it might be temporarily turning off your wi-fi if it doesn't sense any need for it.
    montanaxvi likes this.
    08-18-2014 02:51 AM
  3. montanaxvi's Avatar
    Thanks for the suggestion. I don't see optimization as an option. I did see keep wifi on during sleep and that was set to always (like it should have been) guess I'll see how things go tomorrow while at work.
    08-18-2014 03:01 AM
  4. montanaxvi's Avatar
    Plugged phone in and laid down. Check it 2 hours later and zero notifications. Open Gmail app and 8 emails show up that never came through until I was actively using data
    08-18-2014 06:57 AM
  5. B. Diddy's Avatar
    It wouldn't hurt to try wiping the cache partition: Reset: Samsung Galaxy S 5 | T-Mobile Support
    08-18-2014 11:14 AM
  6. montanaxvi's Avatar
    It wouldn't hurt to try wiping the cache partition: Reset: Samsung Galaxy S 5 | T-Mobile Support
    Did that yesterday afternoon and still having issue.

    I'm at a loss on this one.
    08-18-2014 12:05 PM
  7. montanaxvi's Avatar
    Just because I am really curious about this and didn't even see anything like this on an search over at XDA. I just did a full wipe and restore. Unfortunately it auto downloaded all of my old apps so I am unable to test if there was a certain app causing issues....but I am still having the issue. Really not sure where to go from here.

    Phone works fine, except when screen is off it is as if my data is shut down until I start actively using the phone again. No background data limits enforced in any settings that I could find, no data limits period enforced that I could find. I also don't recall installing any new apps around the time this started happening (this past Thursday night) I cannot rule out the possibility that my router isn't playing nice with the phone, but it hasn't been an issue in the past month I have had the phone, also every single other wireless device in the house works totally fine with the router. Wife has an LG G3 with no issues, Kindle Fire no issues, laptop no issues, PS4 no issues, 2x wifi enabled Blu-ray players no issues, Samsung smart TV no issues.
    08-19-2014 12:05 AM
  8. B. Diddy's Avatar
    Go to Settings>Backup & Reset, and uncheck Automatically Restore. Then try another factory reset (if you're willing to go through the hassle), and see if the apps automatically reinstall again.
    montanaxvi likes this.
    08-19-2014 01:09 AM
  9. montanaxvi's Avatar
    Not sure if I'm that much of a glutton for punishment.
    08-19-2014 04:00 PM
  10. montanaxvi's Avatar
    Bet you couldn't guess that I fell asleep and woke up to check my phone at 1:13am.
    Attached Thumbnails Unusual wifi issue-1408512765313.jpg  
    08-20-2014 01:32 AM
  11. B. Diddy's Avatar
    You're not on some kind of Night Mode, are you?
    08-20-2014 02:18 AM
  12. nikkisharif's Avatar
    I had this same issue a few days ago but I just assumed it was my hotel wifi. It has since worked itself out though. I wish I could help more.
    08-20-2014 02:33 AM
  13. montanaxvi's Avatar
    You're not on some kind of Night Mode, are you?
    I have went over any and all settings I can find and nothing seems out of the ordinary. Like I said, this all started this past Thursday or Friday night. It seems like something is disabling data when the phone isn't in use but for the life of me I cannot figure out what triggered it and why it's still happening after cache wipes and full wipe/reset. I may go buy a new router this weekend just to see if that solves it. That will be my excuse to justify buying that new Linksys WRT1900AC.
    08-20-2014 04:23 AM
  14. sbhatia1981's Avatar
    You mentioned that you use Power saving mode, have you check if you have ticked the Block background data by mistake?
    That might be issue.
    08-20-2014 08:25 AM
  15. montanaxvi's Avatar
    You mentioned that you use Power saving mode, have you check if you have ticked the Block background data by mistake?
    That might be issue.
    This is not the issue. Background data isn't limited or disabled in any settings I have found.
    08-20-2014 09:59 AM
  16. Pianoman2013's Avatar
    Are you still having this issue? Did you find a solution? My S5 is doing the same thing; push notifications and syncing is no problem whatsoever as long as I am on my data plan (or any other WiFi network). My home wifi is a different story. I think it might have something to do with ipv6. I had found a post about an issue the S3s were having, although my S3 gave me over 2 years of dependable service. I am too new on this site to post a link, but if you google "Bug: Samsung Galaxy S3 (+other Samsungs) broken in IPv6 WLAN networks (wifi driver ignores icmpv6)" you'll find it. It is a much older post, but the user seems to have a pretty good handle on the problem. . . just not the solution.

    If you've found one for this, please let me know. It is a real nuisance.
    01-29-2015 08:38 AM
  17. montanaxvi's Avatar
    Really old bump, but a year later and I am still having this issue. I have upgraded to that above mentioned 1900AC Linksys as well as replacing my cable modem with an owned, brand new Motorola SB.

    The thing that ticks me off the most is being upstairs in my room on the PC and trying to use MightyText to send text messages, or respond and my phone is downstairs on the charger......but since the screen is off and I am not actively using the phone, the data connection doesn't work and MightyText is unable to send or get any of the messages since it uses data..

    As soon as I go downstairs and actively start using my phone all is well again.
    07-31-2015 11:04 PM
  18. Angel Pulido's Avatar
    I am having the same issue. My phone needs to be active in order for messages to go through. Has anyone figured this out? I have Galaxy note 5 and I noticed this after I activated power savings mode and deactivated it a short time later.
    09-26-2015 10:12 PM

Similar Threads

  1. Wifi turning on automatically - Help!
    By roccom33 in forum Android Security Talk
    Replies: 2
    Last Post: 02-10-2015, 10:35 AM
  2. MOAR ROM Battery Issue
    By Anglingaddict in forum Sprint Galaxy S III Rooting, ROM's, and Hack's
    Replies: 5
    Last Post: 08-20-2014, 12:04 AM
  3. Having trouble connecting to wifi at home with s5
    By Unregistered in forum Ask a Question
    Replies: 2
    Last Post: 08-17-2014, 05:16 PM
  4. Problem with wifi on my android
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-17-2014, 04:39 PM
  5. Razr black screen issue
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-17-2014, 04:32 PM