1. dkperez's Avatar
    We need to turn OFF the display of the phone's number on outgoing calls.

    I've found several things on the Internet that show how to do this........
    They ALL (so far) send me into phone/settings/calls then tell me to select "MORE SETTINGS" I DO NOT have a "more settings". I have an "additional settings" where that would be, but all that's in there is TTY mode and Hearing aids.

    How do I turn on and off the display of the phone number when making calls?
    08-29-2014 12:17 PM
  2. SpookDroid's Avatar
    I know this is not what you want to hear, but if it's not there, it's not possible. I'm guessing your phone is carrier-branded, in which case either the carrier removed this feature from the ROM or it just doesn't support it. These Additional Options are tied to the carrier's capabilities.

    Under Additional Settings you should see the Caller ID option IF it wasn't removed by your carrier or if its supported by it (in case you're using a factory-unlocked version).
    08-29-2014 12:22 PM
  3. thecomicbookandme's Avatar
    We need to turn OFF the display of the phone's number on outgoing calls.

    I've found several things on the Internet that show how to do this........
    They ALL (so far) send me into phone/settings/calls then tell me to select "MORE SETTINGS" I DO NOT have a "more settings". I have an "additional settings" where that would be, but all that's in there is TTY mode and Hearing aids.

    How do I turn on and off the display of the phone number when making calls?
    This is how I do it. (AT&T)
    Find "Accessibility" in the settings menu. Select sub category "More settings" - "answering and ending calls"
    Select "answering and ending calls" at the very top.
    Select "additional settings"
    At this point you may get an error message, but if you continue to try it will take you to another screen.
    Select "caller ID"
    Select "hide number"
    Good luck 👍

    Posted via Android Central App
    08-29-2014 01:40 PM
  4. SpookDroid's Avatar
    This is how I do it. (AT&T)
    Select "additional settings"
    At this point you may get an error message, but if you continue to try it will take you to another screen.
    Select "caller ID"
    This is what I mean. It's a CARRIER DEPENDENT feature. It actually loads this from the network info, which is why, if the network has a glitch or it can't communicate with it, it shows that error. But if the info is loaded and the network allows Caller ID control, then it will show there. If not, the carrier is not allowing the use of that feature, not the phone.
    08-29-2014 02:29 PM
  5. dkperez's Avatar
    Wow, my Accessibility menu is TOTALLY different than yours......

    Please, PLEASE tell me Verizon DIDN'T do something as UTTERLY STUPID as to make it impossible for my wife NOT to broadcast her number to anyone she calls? 'Cause in her job, there is absolutely no way she can have her number get out to some of the people she has to call...
    08-29-2014 11:31 PM
  6. crabbz's Avatar
    Caller ID really isn't a function of the phone, it's done in the network. I haven't tried but the bottom of this page tells how to turn on caller id blocking for verizon.
    Calling Features: Caller ID & Caller ID Blocking | Verizon Wireless
    08-30-2014 12:14 AM
  7. Eclipse2K's Avatar
    Caller ID really isn't a function of the phone, it's done in the network. I haven't tried but the bottom of this page tells how to turn on caller id blocking for verizon.
    Calling Features: Caller ID & Caller ID Blocking | Verizon Wireless
    I remember seeing the option in the past but no where in My Verizon do I see an option to hide the number.

    If all else fails I guess she has to dial *67 prior to each call.

    Samsung Galaxy S5 (Verizon)
    08-30-2014 01:51 AM
  8. jmagid51's Avatar
    On the current S5 after the update from yesterday.

    Settings
    Call
    More settings
    Caller ID

    you have 3 choices.

    Show number
    Hide number
    Use network default

    Hope it works. AT&T
    08-30-2014 08:22 AM
  9. dkperez's Avatar
    Believe it or not, this feature doesn't exist on the phone with Verizon.... It's in the network. The pointer to "My Verizon" was right.......

    EXCEPT, it doesn't exist anywhere in the "Change Features". You actually have to CALL them, wade through all the crap, get someone on the phone, and have THEM turn it on... And then, there's no "display" "hide" or such. Just a line in the "Change Features" that says "Caller ID Block".......

    SO, in THEORY, it's resolved. We'll find out Tuesday. What a massive pain in the *** it is to get something that SHOULD be this trivial done.
    Eclipse2K likes this.
    08-30-2014 08:20 PM
  10. Eclipse2K's Avatar
    Believe it or not, this feature doesn't exist on the phone with Verizon.... It's in the network. The pointer to "My Verizon" was right.......

    EXCEPT, it doesn't exist anywhere in the "Change Features". You actually have to CALL them, wade through all the crap, get someone on the phone, and have THEM turn it on... And then, there's no "display" "hide" or such. Just a line in the "Change Features" that says "Caller ID Block".......

    SO, in THEORY, it's resolved. We'll find out Tuesday. What a massive pain in the *** it is to get something that SHOULD be this trivial done.
    They do understand you wanted to block her number, right? I'm sure you made it clear but I just want to throw it out there to make sure they didn't just disable Caller ID from working on her end.

    Samsung Galaxy S5 (Verizon)
    08-30-2014 08:50 PM
  11. JudH's Avatar
    Does your wife have a 2nd phone for "normal" contacts that don't require blocked callerid? If not turning callerid off globally may result in a lot of no answers. I bet 2/3s of the people I call, including me, don't answer blocked calls.

    As shown in crabbz's link above you can block the callerid on a per-call basis on Verizon by prefixing it with *67.
    08-31-2014 12:49 PM
  12. Cordieb's Avatar
    This is how I do it. (AT&T)
    Find "Accessibility" in the settings menu. Select sub category "More settings" - "answering and ending calls"
    Select "answering and ending calls" at the very top.
    Select "additional settings"
    At this point you may get an error message, but if you continue to try it will take you to another screen.
    Select "caller ID"
    Select "hide number"
    Good luck 👍

    Posted via Android Central App
    Just enter *67 before making your call.
    05-02-2015 02:52 PM
  13. Cordieb's Avatar
    Just enter *67 before the number you dial.
    05-02-2015 02:56 PM
  14. Robin Byers's Avatar
    Thank you....that worked for me....T-Mobile.
    06-08-2015 07:45 PM
  15. Moto-Edge's Avatar
    at least on 5.0 lollipop, this can be done by FIRST launching the phone app . . . (I couldn't find it in the main settings menu) WITHIN the phone app, go into those settings, then » CALL » More settings » (wait for it as it displays, "Reading Settings") » Caller ID » then choose Hide number.
    06-12-2015 08:21 AM
  16. draystar's Avatar
    We need to turn OFF the display of the phone's number on outgoing calls.

    I've found several things on the Internet that show how to do this........
    They ALL (so far) send me into phone/settings/calls then tell me to select "MORE SETTINGS" I DO NOT have a "more settings". I have an "additional settings" where that would be, but all that's in there is TTY mode and Hearing aids.

    How do I turn on and off the display of the phone number when making calls?
    09-08-2015 10:13 AM
  17. draystar's Avatar
    So, here is the answer from a non-techno-boob in plain English. On my Note 5, which is a Verizon phone, go to SETTINGS. Scroll down to the heading PERSONAL. Then select the subheadings HELP. On the HELP screen, select the heading MY VERIZON MOBILE. On the MY VERIZON page, scroll down to and select MANAGE SAFEGUARDS. At this point you may be asked to sign in to your Verizon account. From the MANAGE SAFEGUARDS page, select SERVICE BLOCK and there you can block or unblock your phone number from view. Again this is only for Verizon phones, but a quick call to the tech support people tells me that similar options exist for all brands. DO NOT ALLOW TECHNO-BOOBS to tell you nothing can be done.
    09-08-2015 10:28 AM

Similar Threads

  1. Kyocera Hydro stuck on Boost Mobile screen
    By Max Pascua in forum Ask a Question
    Replies: 2
    Last Post: 12-21-2014, 12:16 PM
  2. Stuck On Loading Screen (Keeping it specific!)
    By Rackstraw in forum Ask a Question
    Replies: 3
    Last Post: 08-31-2014, 02:03 AM
  3. apps lingering on download and will not install to device
    By badger2727 in forum Ask a Question
    Replies: 1
    Last Post: 08-29-2014, 04:00 PM
  4. How do you add pass code to conference call so it auto dials?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-29-2014, 12:57 PM
LINK TO POST COPIED TO CLIPBOARD