1. kq702's Avatar
    About a week ago my phone asked me what kind of language I want to use (not sure why it asked but it randomly showed up in notification center) and I meant to click on the ENGLISH option but I accidentally clicked the one underneath english. Now this is a screen shot of what my text messages looks like (you can see where I put the red arrows)

    part of my phone shows up in a different language-1.jpg

    When I hold my finger on one of the messages, I get the following options:
    part of my phone shows up in a different language-2.jpg

    I tried reinstalling my keyboard and it did not fix it. any ideas how to fix?
    09-07-2014 08:43 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! So I assume everything is in Chinese, right? Go back to the homescreen, then go to Settings, and scroll all the way down to the category at the bottom, which should be System. Expand that category, and tap the selection with the "A" icon, which should be the Language menu. Then tap the topmost option, which is for Default Language, and reset it to English (or whichever language you prefer).

    Here's an article with some helpful images: How To and Computer Tips Trick Blog: How to Set Language in Samsung Galaxy S5

    EDIT: Sorry, that article suggests you should open the Sound & Display menu to get to Language, but I thought I saw it elsewhere in System. Try both.
    09-07-2014 10:24 PM
  3. kq702's Avatar
    well thanks for the info but it did not work I went to settings then language and input and it is set to english. I scrolled to the samsung keyboard option (only option that is selected) and hit settings and reset the default settings and it still is in chinese any other ideas?

    edit- this only occurs in the "messages" page (so for my text messages only) all other options are english
    09-08-2014 04:14 PM
  4. B. Diddy's Avatar
    Have you looked through all of the Messaging settings? I don't have a Samsung device, so I can't check myself.

    Are you certain your S5 is a US version? Did you get it through a wireless store? Could it possibly be a Chinese version, or a clone?
    09-08-2014 04:35 PM
  5. kq702's Avatar
    I went through literally every setting I can find! I know its not a clone or a "fake" 5S because I never had this problem untill I hit that button by accident (the button that I talked about in my orig post). I had it for a few months and it was working fine. I got it from an authorized retailer (amazon.com)

    I notice sometimes my ringer does not sound too (on rare occasions) so I think I am gonna try a factory reset
    09-18-2014 12:36 PM
  6. Student-Christian Mccallister's Avatar
    Welcome to Android Central! So I assume everything is in Chinese, right? Go back to the homescreen, then go to Settings, and scroll all the way down to the category at the bottom, which should be System. Expand that category, and tap the selection with the "A" icon, which should be the Language menu. Then tap the topmost option, which is for Default Language, and reset it to English (or whichever language you prefer).

    Here's an article with some helpful images: How To and Computer Tips Trick Blog: How to Set Language in Samsung Galaxy S5

    EDIT: Sorry, that article suggests you should open the Sound & Display menu to get to Language, but I thought I saw it elsewhere in System. Try both.
    Thanks so much for the help this happen to me last week and I found this and it help me outo I click the A icon in the screen on settinga and I got to changed the language to english
    B. Diddy likes this.
    01-16-2018 03:58 PM

Similar Threads

  1. Note 4 a good two year phone?
    By Yogi217 in forum Samsung Galaxy Note 4
    Replies: 42
    Last Post: 10-05-2014, 08:30 PM
  2. Replies: 1
    Last Post: 09-08-2014, 02:28 AM
  3. Replies: 2
    Last Post: 09-07-2014, 10:02 PM
  4. Vodafone S5 phones get a update or do they ??
    By Northern.dj in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 09-07-2014, 08:01 PM
LINK TO POST COPIED TO CLIPBOARD