1. knicks1130's Avatar
    I have a S5 running 4.4.4

    About a week ago... my SD card stopped working... I could not access any files on it, or even see it under Storage menu (said Mount SD Card) I take the card out and pop into my laptop... works fine, I can see all the files, etc. I check online for solutions. I order a new 32GB Class 10 Samsung Mico SD Card. I copy the files from old card to new card... still does not work. I then wipe and factory reset my phone (big pain in the a$$) It finally recodnizes the card! Then as soon as I restarted my phone BAM, it doesnt work again... any suggestions?

    Is this because of KitKat changes to SD cards? PLEASE HELP!!!
    10-24-2014 06:52 AM
  2. knicks1130's Avatar
    Anyone?
    10-24-2014 08:21 AM
  3. colyn1353's Avatar
    I doubt Kitkat is the problem. Sounds more like your phone is loosing it's connection to the card.

    Sent from my Galaxy S5 using Tapatalk
    knicks1130 likes this.
    10-24-2014 08:21 AM
  4. knicks1130's Avatar
    How do I check that... or fix it?
    10-24-2014 08:46 AM
  5. knicks1130's Avatar
    why would that happen all of a sudden... phone is only 3 months old
    10-24-2014 08:46 AM
  6. P_Devil's Avatar
    Make sure the card is properly ejected from Android and then physically remove it from your phone. Examine the memory card and make sure the physical connections aren't damaged. Look at your phone's memory card adapter and make sure it is clear of debris. If you can, you should test your memory card with another device to see if the card is to blame or not. Then, if the card works in another device, put it in your S5 and see what happens. You should try rebooting your phone while the card has been ejected.

    What brand is your SD card and where did you buy it?

    On a side note, you don't have to incessantly bump your thread. Most of the people here on the forums are volunteering their time and it may take longer than 90 minutes for them to reply back. Let your thread sit for a while and someone will eventually get around to answering your question (for free).
    10-24-2014 10:00 AM
  7. knicks1130's Avatar
    Samsung EVO class 10 32GB,..from Amazon..thanks
    10-24-2014 10:14 AM
  8. P_Devil's Avatar
    Was it shipped and sold by Amazon or through someone in the Amazon Marketplace? It is possible that you purchased a fraudulent card if it's from the Marketplace. Like I said, the best thing you can do is check the validity of the memory card by using it with a different device. You can buy a USB microSD card reader if you don't have another device that can read microSD cards.
    10-24-2014 10:30 AM
  9. knicks1130's Avatar
    no thought Amazon directly... I had an older card in the phone when it started not to work... I got a new one even though the older card worked in the PC as well
    10-24-2014 11:30 AM
  10. JSQ's Avatar
    I am also having this issue and it started right after the last update on Verizon.

    I removed the card and checked it on my desktop and it worked flawlessly. However, when I returned it to the phone it would not mount and I got a notification message that said the card was damaged.

    I also ordered the card through Amazon(direct). It is the class 10 32gb EVO micro SD.
    10-28-2014 07:55 AM
  11. P_Devil's Avatar
    Hmn... Well, if the SD card reader is free of debris, I suggest restarting the phone. If that doesn't work, I suggest clearing out the phone's cache entirely. Turn the phone completely off and then turn it back on holding the power, volume up, and home buttons at the same time. Release the buttons once the screen flashes. From the on-screen menu, you can use the volume buttons (up and down) to select the Clear Cache option. Clear your phone's cash and then restart it using the on-screen menu. I suggest turning the phone off again, inserting the memory card, and then turning it on.

    You may want to double-check the memory card using a disk scanning program with your PC even if it's just the OS X or Windows disk utilities.
    10-28-2014 08:16 AM
  12. JSQ's Avatar
    P_Devil. I tried wiping the cache and it did not work. I also bought a new card, SanDisk 32gb. I received the same error.
    10-31-2014 12:34 PM
  13. colyn1353's Avatar
    When updating it is a good idea to remove the card and backup to your computer then put the card back in. Once the update is done, format it. Most updates will download the update file to the SD card which can cause issues. After the update is done format the card again and put your files back on it..
    10-31-2014 06:24 PM
  14. WillPM360's Avatar
    Since updated to Marshmallow I cant see any sign of my SD card. Works fine on my computer. I was able to backup my SD card but now my phone shows no data so I cant back it up.
    Help?
    11-01-2016 12:13 AM

Similar Threads

  1. How can I avoid auto call record files adding to playlist?
    By Babasaheb Jagtap in forum Ask a Question
    Replies: 4
    Last Post: 02-20-2017, 07:19 AM
  2. Wish I can win a note 4 extended battery
    By molybear in forum Samsung Galaxy Note 4 Accessories
    Replies: 10
    Last Post: 03-02-2015, 12:17 AM
  3. Is the Note 4 better than the Galaxy S5?
    By Pollyanna Henricks in forum Ask a Question
    Replies: 2
    Last Post: 10-24-2014, 03:44 PM
  4. Replies: 2
    Last Post: 10-24-2014, 08:21 AM
  5. Replies: 0
    Last Post: 10-24-2014, 02:11 AM
LINK TO POST COPIED TO CLIPBOARD