01-18-2017 06:24 PM
26 12
  1. trickylikeaninja's Avatar
    I have a Samsung Galaxy S5 on T-Mobile, and I keep running into this issue:

    I just moved to a new city and have no clue where anything is yet, so when I go out I'll pull up a route via Google Maps on my phone. While at home, my phone is connected to my wi-fi network, and I have zero issues.

    As has been the case multiple times now, once it's time to pull up my home address in Google Maps to navigate home, I'm out of luck. I'll have full bars, 4G LTE, and will open Google Maps and enter my address, but nothing will pre-fill on the search screen (it normally pre-fills with your most recent searches etc) and the little arrows next to 4G LTE won't light up at all.

    I'll manually type in my home address and hit search, again no arrows lighting up to indicate data, and then my phone just spins that circle indicating a search is pending. Nothing will ever pull up.

    I've spoken to T-Mobile about this and was told I needed to update my phone via Settings and the problem will go away. It hasn't.

    I've been going all over the city for job interviews lately, and this is getting extremely inconvenient. What should I do?
    10-28-2014 10:37 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try going to the App Manager, select Google Maps, and Clear Cache/Clear Data, then Force Stop. Now try again.

    When this happens, does everything else work fine on mobile data? For example, you're still able to browse the web or send email or do a Google search? What happens if you use the phone's browser to go to maps.google.com?
    10-28-2014 11:12 AM
  3. trickylikeaninja's Avatar
    All other forms of the internet work fine. I tried your steps, no change.

    The really weird thing I noticed is this - when it happened on Friday, I went to the Play Store and downloaded Waze and tried Waze... SAME problem.

    In both cases even the map of my surrounding areas loaded, but it was like no data was DL or UL whenever I would try to send a specific request for a location.

    In the past, enabling and disabling location settings a bunch of times would eventually get it working, as would changing my location settings to GPS only, but lately even that hasn't been working.
    10-28-2014 01:39 PM
  4. B. Diddy's Avatar
    Did you also try the Google Maps mobile site? Maybe we can narrow it down to an issue with the actual Google Maps app, vs some problem with the Maps server.
    10-28-2014 02:59 PM
  5. trickylikeaninja's Avatar
    It's not an issue with the Google Maps app if it's affecting Waze (which it is) as well. The mobile site loads fine, but doesn't actually update my location or anything, so all I can do is pull up a "turn here, go 2 miles, turn right" list like in the old days of printing out directions off Map Quest.
    10-28-2014 03:13 PM
  6. B. Diddy's Avatar
    What I was trying to figure out was if it's an issue with accessing the information via app, be it Google Map or Waze (so presumably an API issue? I'm not a coder, so forgive me if I'm off base) or if there's a problem with the Google Maps server (in which case you'd have problems on the mobile site as well). So with what you're describing, it makes me think there might be some API issue, but again, since I'm not a coder, I'm not sure what to do next. Also, I'm not sure why the problem would only be on mobile data. Let me ask some other folks.
    10-28-2014 03:57 PM
  7. trickylikeaninja's Avatar
    Awesome, thanks for the help. It's such a weird issue, and so far T-Mobile has been absolutely no help.
    10-28-2014 04:17 PM
  8. trickylikeaninja's Avatar
    Any updates?
    10-29-2014 01:37 PM
  9. B. Diddy's Avatar
    Sorry, no, none of my colleagues have any suggestions at this time.

    I wonder if reflashing the firmware might help, in case the maps API has somehow gone weird (again, apologies to any real software engineers out there if I'm way off base). Either that or a factory reset (but I think reflashing the firmware will preserve your data).

    First, see if wiping the cache partition does anything: Reset: Samsung Galaxy S 5 | T-Mobile Support

    If that doesn't help, see if this process works: http://forums.androidcentral.com/amb...ia-odin-8.html
    10-29-2014 05:48 PM
  10. JanlleZ's Avatar
    I have the same problem. Have you found any solution that works?
    12-03-2014 02:36 PM
  11. jcf007's Avatar
    I have tried force stops, clearing the cache and uninstalling updates on google maps. I have also tried wiping the device's cache partition. Nothing works excepting getting on WiFi. Has anyone seen this issue on non-S5 devices? non-Samsung devices? My tablet doesn't have this problem running the same version of google maps (9.1.2)...
    I am wondering if this isn't some sort of handshaking issue with google servers as accessing maps on my tablet appeared to clear the issue on my phone...
    12-14-2014 08:25 AM
  12. fyrso's Avatar
    I had the same problem with my Maps App. It would not work. I found an youtube video and it told me that this issue was due to the updates on it. The guy said to clear the Cache and the data then click uninstall updates. it will remove the update and give you back the factory version. I did and it worked. once I found an address and click start navigation it popped and even the voice was there. I have not tried it out driving yet but if I got all this which I didnt before Im sure it will work.
    12-14-2014 09:18 PM
  13. Michael Brown25's Avatar
    I have a similar issue going on with my S5.

    I type, or put a pin in a location I am trying to get directions for, and as soon as I hit the "route" button, the maps app turns off completely.

    Won't even load the directions at all. And this has nothing to do with internet connection because it happens no matter what the situation. EVERY time.

    I have tried everything suggested on this forum and nothing helps. I'm starting to realize that the best way to fix your Samsung Phone, is to throw it away and buy an Iphone. At least that way you can get some help when something goes wrong.

    I am on my 4th replacement phone, and I haven't gotten a decent one yet. I only heard good things about these phones, but since me, my mom, and my sister bought them, we have been thoroughly disappointed in everyway.
    03-05-2015 08:30 AM
  14. tpaul66's Avatar
    I had the same problem. What corrected the issue for me was going to the application manager where I cleared the data (which automatically cleared the cache). Next, I force stopped; turned app off and back on. The app was removed from the folder I had it set it. I had to go back to apps and move it back to the folder. When I opened it again, it had been restored to its original state. Knock on wood 24 hrs later ...still working (Knocking on wood again)
    03-13-2015 10:20 PM
  15. Buggs Bunny's Avatar
    I had the same exact problem as the OP and tried every suggestion. I talked to Verizon tech support, and they suggested booting into safe mode, in addition to all the other fixes suggested here. They even suggested taking the damn cover off in case it was somehow blocking the GPS. A manager reviewed the call log and called me later to do a follow up. He said he would delve into it more and he actually called me the next day to see if I had resolved the problem. I told him no and he said he would continue to try to find a solution. I then went to my local Verizon store, and they were scratching their heads as well. It would appear that there simply is no solution to this problem. They finally called it a location services "issue", and are shipping a new phone since mine is still under warranty. If someone comes up with a solution or explanation please post it.
    03-20-2015 10:18 PM
  16. Riicky Aandrade's Avatar
    I have a similar issue on my Samsung S5. Everything works fine except for the localisation system. When I'm using the google maps app, It's not working properly.
    When I turn on my localisation, the icon keeps blinking and never stops. Sometimes it does but the gps loses the signal and starts blinking again. The gps isn't accurate at all and is not following my movements when I'm driving! I asked help from Samsung, they sent me to a repair center which was supposed to repair/fix the issue. Went there, they said that they fixed it, went home and halfway to my destination it wouldn't stop blinking at started doing the same thing. My phone was factory reset too... I don't know what to do anymore. I seriously tried everything stated in this thread but still nothing. If someone could help me that would be great!
    04-14-2015 09:53 PM
  17. Dagon123's Avatar
    I tried all the suggestions for this problem other than restore without success. I then went to the Playstore, searched on Google Maps, and selected Update. All seems to be working fine now including Pedestrian mode!
    05-12-2015 07:48 PM
  18. Axe6164's Avatar
    Google map error message pops up "Unfortunately Google Maps has stopped working" when I am on 4G and when I tap the navigation button and select the car mode prior to entering the address.
    No issues when I am home on wifi. All the time. Every time.
    Have not been able to find a solution yet.
    05-15-2015 04:01 AM
  19. anon(1017475)'s Avatar
    Are you still on 4.4 or did you take the 5.0 update?
    05-15-2015 07:31 AM
  20. Metendo's Avatar
    It's not an issue with the Google Maps app if it's affecting Waze (which it is) as well. The mobile site loads fine, but doesn't actually update my location or anything, so all I can do is pull up a "turn here, go 2 miles, turn right" list like in the old days of printing out directions off Map Quest.
    Google owns waze. Uninstall all updates of maps from your application settings. Itll work. I have the same problem. Its due to the most recent version maps
    03-15-2016 09:10 AM
  21. Nirmal Venkatesan's Avatar
    Remove the proxy server from the APN and all apps should work now in mobile data.
    Path to remove proxy in android phones: Settings > mobile data > access point names > APNs > Proxy
    05-05-2016 06:58 PM
  22. Dani Syed's Avatar
    Dear All,
    I have solved this issue at my Galaxy Tab 6, as follows:
    1. Uninstall Google maps.
    2. Thanks try to search a location, it will ask to choose chrome or map,
    Choose maps. Thanks it will ask to use Google, than select Google.
    3. Now it will Navigate without any issue, as I am utilising this easily to navigate my destination.

    Enjoy & comments.

    Syed Danish
    10-04-2016 06:21 AM
  23. Dani Syed's Avatar
    Next time just uninstall maps updates, it will be working fine.

    Enjoy the Navigation towards your final destination.

    10-12-2016 03:53 AM
  24. eyekymo's Avatar
    My problem is a bit different. My GPS will not work with the phone network, only with WiFi. Not one hundred percent of the time, but at least ninety percent. When I try to use google for voice activated calling, I get an "offline" screen. I've already disabled Google maps, but Waze won't do anything anyway.
    10-21-2016 09:59 PM
  25. scottcruss's Avatar
    Another issue can be caused by things like a mounted video camera blocking the GPS. Usually it is the power cable or the ac adapter causing interference.
    10-22-2016 09:35 PM
26 12

Similar Threads

  1. Samsung Galaxy Note 4 Camera not centered
    By Dhanaa Alaas in forum Samsung Galaxy Note 4
    Replies: 9
    Last Post: 09-08-2015, 08:49 PM
  2. Motorola Hint not activating Moto Voice
    By booboolala2000 in forum Moto X (2014)
    Replies: 2
    Last Post: 10-29-2014, 10:47 PM
  3. Replies: 2
    Last Post: 10-29-2014, 06:31 AM
  4. Home button cycling colours, no power on.
    By Russell Abbott in forum LG Optimus Series
    Replies: 1
    Last Post: 10-28-2014, 11:15 AM
  5. how can I go to straight Talk with my Verizon s5 world phone on ST byop?
    By Travis Chilafoux in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 10-28-2014, 10:21 AM