1. crazyamor's Avatar
    So I will be browsing through facebook or linkedin or anything like that and click on a link which is supposed to open in Chrome. Most of the time, they open fine. But sometimes when I try to open those links, they open the blank browser with either the Google search up or just a blank browser with the plus sign button to open a new tab. No matter if I restart the phone, free up processing power by clearing the task manager, whatever link doesn't work just won't work. I know it's not the website's servers being down or anything like that because they will open fine on my desktop computer, my samsung tab 3 tablet, someone's else phone. Not sure what to do to fix this?
    10-29-2014 12:05 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! When the blank browser page comes up, is it still Chrome, or the stock Samsung browser? Try going to the App Manager, tap Menu, and tap Reset All App Preferences, which will clear app defaults. (Be aware that it will also re-enable any disabled apps.)
    10-29-2014 06:48 PM
  3. redsoxfan26's Avatar
    Facebook now has a new built-in browser. I don't like it either.
    10-29-2014 07:26 PM

Similar Threads

  1. Contacts are not showing up in iPhone Hangouts App after SMS integration
    By shanezam203 in forum The Android Central Lounge
    Replies: 6
    Last Post: 02-01-2015, 08:27 PM
  2. Replies: 4
    Last Post: 11-04-2014, 06:58 PM
  3. Replies: 3
    Last Post: 10-29-2014, 10:53 PM
  4. motorola alert not compatible?
    By Loc Huynh in forum Moto X (2014)
    Replies: 2
    Last Post: 10-29-2014, 07:10 PM
  5. Vibration on Keyboard not available?
    By Sammuel1973 in forum Samsung Galaxy Note 4
    Replies: 6
    Last Post: 10-29-2014, 05:46 PM
LINK TO POST COPIED TO CLIPBOARD