05-09-2018 07:26 AM
85 1234
tools
  1. awaisjaffery's Avatar
    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.
    Thanks.. this worked for me
    11-13-2016 07:58 AM
  2. Jadesword1's Avatar
    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.
    You are amazing. Fixed it. Thanks so much!!
    11-13-2016 04:48 PM
  3. Kay Drayton's Avatar
    Try clearing the cache on any apps that send files or photos, I have this problem I'm using textra & it seems to be an issue after I've sent a photo. I think there is some kind of network hangup going on because all of the solutions people are suggesting tend to reset or clear the mobile network settings. So try clearing you cache for apps like text, FB, Twitter, Snapchat or anything else you might use to send files over your mobile network. see if that works. I would suggest clearing the cache of each app one at a time then try turning on your wifi after each one so you can locate which one is causing the hangup.

    Goodluck!
    11-13-2016 10:30 PM
  4. a generic person's Avatar
    S6 user (Verizon) checking in, I've got the random wifi on and off too. Disabling wifi scanning did help, but uninstalling Google home didn't help at all. I'm just hoping we get a fix for this. Maybe if enough people end up in this thread....
    11-13-2016 11:46 PM
  5. Stank0's Avatar
    Note 5 here. For me it was Bitmoji app I installed a few days ago. First force stopped it and wifi immediately turned on and stayed on. Promptly uninstalled, problem solved.
    11-14-2016 04:48 AM
  6. Yiannisc's Avatar
    OK people, attempt number 2:

    Go to Location | Improve accuracy.

    If Wi-Fi scanning is on, turn it off. Apparently in the small text below it it says: "Improve location accuracy by allowing apps and services to scan for Wi-Fi networks automatically, even while Wi-Fi is turned off"!

    It seems to me that some app or service has gone mad and scans every 5 secs or so.

    Hope ti solves it.
    11-14-2016 05:50 AM
  7. Daoud333's Avatar
    Hello,

    Same issue since some days with my Note 4 ( EU model N910F)

    Disabled "Wi-Fi scanning" in location / improve accuracy and the issue gone but it's not a solution.
    11-15-2016 02:26 AM
  8. Chris 78's Avatar
    That really isn't a problem because high accuracy still scans for WiFi networks when WiFi is turned on, this option just disables it when WiFi is turned off.
    11-15-2016 09:08 AM
  9. snorth87's Avatar
    Had the same issue this morning. After looking at this thread I turned off the wifi location accuracy to temporarily stop the wifi on/off insanity. Then I went into settings/storage/internal storage/cached data and deleted all app cache. After that I was able to go back into the location settings and re-enable the wifi location accuracy, and the wifi continued to work and stay on normally.

    Maybe just deleting all the app cache will fix the issue without having to touch the location accuracy settings. If not, the above sequence worked for me. Hope it works for anyone else stuck in this wifi toggling madness.
    11-15-2016 09:24 AM
  10. Daoud333's Avatar
    Even with internal storage cache deleted, the issue is still here for me.

    The issue is not here when wifi is enabled but only if wifi disabled with wifi location accuracy activated.
    11-15-2016 09:48 AM
  11. chipinmyhead's Avatar
    I'm having this same issue on my note 4, VZW. I've tried nearly all of the above, including deleting google home, to no avail. I had the issue over the weekend on my personal S7 Edge, and fixed it by resetting the data settings (not a factory reset). This fix does not seem to solve the issue on the Note 4. Thanks.
    11-15-2016 01:25 PM
  12. Daoud333's Avatar
    What version and build of android have you on your N4 ?
    11-15-2016 03:14 PM
  13. Erns Pen's Avatar
    same problem here. Issue started out of the blue without installing or updating any app whatsoever (I have automatic app update disabled). Galaxy S5 running Android 6.0.1. Only solution to the constant "wifi scanning for high accuracy" thing is to disable it in location ==> improve accuracy ==> turn off "Wi-Fi scanning". I've tried uninstalling Google Home but nothing. Anyone has any idea which app could be causing this crazy bug?
    11-15-2016 04:44 PM
  14. Erns Pen's Avatar
    Well, here's what solved it for me (I have a galaxy s5 by the way).

    1. Go settings ==> connections ==> Location (turn on location if it isn't already, of course) ===> "Improve accuracy" and turn on "Wi-Fi scanning" to initiate the bug process.
    2. Then go back to Location, and, in the list of apps under "Recent location requests", tap one and go to "Permissions" and disable the "Location" permission for each one, one a time (IMPORTANT).
    3. If after disabling the location permission of one of the apps it doesn't fix the problem (check the wifi connection behavior), move on to disable location permission for the next app on the list ("Recent location requests"). Eventually, after disabling the location permission of the glitchy app, the bug will stop



    For me it was the T-Mobile app so I simply left it with permission disabled. I kind of had a feeling that Android would not let any of their apps or other big Play Store apps get away with this kind of huge glitch. I honestly wish I could uninstall T-Mobile app since I never use it and it kind of sucks but ah well, don't wanna root my phone for now.


    Anyways, hope this helps.
    11-15-2016 05:15 PM
  15. nrobins's Avatar
    For me, I couldn't turn WiFi on, it just did a cycle off/on/off... every couple of seconds. I fixed this on my Verizon Note 4 by going to settings:WiFi and dragging the on off switch to the right and keeping my finger there long enough to allow connection to my home wifi network. At least I got off my data plan...
    11-15-2016 11:20 PM
  16. Daoud333's Avatar
    Ok. I found the app responsible of this global issue !

    It's "Google play services" version 10.0.84 !

    I returned to previous version (with titanium backup) 9.8.77 and the issue gone immediately ...
    11-16-2016 02:27 AM
  17. Claytan K's Avatar
    Well, here's what solved it for me (I have a galaxy s5 by the way).

    1. Go settings ==> connections ==> Location (turn on location if it isn't already, of course) ===> "Improve accuracy" and turn on "Wi-Fi scanning" to initiate the bug process.
    2. Then go back to Location, and, in the list of apps under "Recent location requests", tap one and go to "Permissions" and disable the "Location" permission for each one, one a time (IMPORTANT).
    3. If after disabling the location permission of one of the apps it doesn't fix the problem (check the wifi connection behavior), move on to disable location permission for the next app on the list ("Recent location requests"). Eventually, after disabling the location permission of the glitchy app, the bug will stop



    For me it was the T-Mobile app so I simply left it with permission disabled. I kind of had a feeling that Android would not let any of their apps or other big Play Store apps get away with this kind of huge glitch. I honestly wish I could uninstall T-Mobile app since I never use it and it kind of sucks but ah well, don't wanna root my phone for now.


    Anyways, hope this helps.
    This is what worked for me. I was in so much distress over this, it turned out being Google play services that was itself requesting location repeatedly, now there is many apps that go through Google play services to request location but I had used the app greenify to force stop almost all of my applications so I was at a loss by this point. What I did to fix it was I went to uninstall updates to Google play services but it wouldn't let me unless I turned Android device manager off as an administrator as the system. After I did that I just pressed force stop and did not actually uninstall anything and it instantly started up again but without the constant broken loop of turning my WiFi on and off. I turned it back on as a system admin and left it all as it was and it is now fixed. Figured I'd give my two cents and help someone else out.
    11-16-2016 07:52 AM
  18. Daoud333's Avatar
    It's fixed only the first time, but when the phone is rebooted, or else ... the problem came back.
    11-16-2016 08:41 AM
  19. Erns Pen's Avatar
    yep, you are right on the money Claytan! It seems that is either an issue with that version of Google Play services or a glitchy app that it's getting location data through Google Play service. I'm gonna update all of my apps to rule out any glitch coming from an outdated app version. I guess if nothing else solves the issue, the only temporary fix would be to roll Google Play services system app to an earlier version (would probably require root access though) or wait for a fix to that specific, unknown app.
    11-16-2016 08:44 AM
  20. Jeepsk8's Avatar
    I thought it might be Google Play Services. I checked everything else. Now, how do I fix this? It basically won't let me do anything to it.
    11-16-2016 12:32 PM
  21. Jeepsk8's Avatar
    This is what worked for me. I was in so much distress over this, it turned out being Google play services that was itself requesting location repeatedly, now there is many apps that go through Google play services to request location but I had used the app greenify to force stop almost all of my applications so I was at a loss by this point. What I did to fix it was I went to uninstall updates to Google play services but it wouldn't let me unless I turned Android device manager off as an administrator as the system. After I did that I just pressed force stop and did not actually uninstall anything and it instantly started up again but without the constant broken loop of turning my WiFi on and off. I turned it back on as a system admin and left it all as it was and it is now fixed. Figured I'd give my two cents and help someone else out.
    I did the above. It did stop the problem, but, Gmail wouldn't work. I kind of need that. Sooooooo, I'll just keep wi-fi scanning off for now. I can live without that.
    11-16-2016 01:45 PM
  22. Claytan K's Avatar
    I did the above. It did stop the problem, but, Gmail wouldn't work. I kind of need that. Sooooooo, I'll just keep wi-fi scanning off for now. I can live without that.
    Odd, my gmail still works.
    11-17-2016 12:45 PM
  23. PedroPintos198x's Avatar
    Worked for me. Thanks!
    11-17-2016 07:30 PM
  24. Jeepsk8's Avatar
    Odd, my gmail still works.
    I'll try it again. Could be I screwed up.
    11-18-2016 06:42 AM
  25. Jeepsk8's Avatar
    Ok, I tried it again. Everything worked fine this time, until I pulled up google maps. Once I did that, the problem started again.
    11-18-2016 03:54 PM
85 1234

Similar Threads

  1. Spotify and Runtastic?
    By elysm1 in forum Samsung Gear S
    Replies: 10
    Last Post: 11-12-2014, 06:06 PM
  2. Replies: 2
    Last Post: 11-09-2014, 10:52 AM
  3. Replies: 1
    Last Post: 11-08-2014, 10:00 PM
  4. Replies: 1
    Last Post: 11-08-2014, 09:02 PM
LINK TO POST COPIED TO CLIPBOARD