07-21-2018 11:40 PM
85 1234
tools
  1. Justin Carter741's Avatar
    Samsung Note 5 here with the same issue. I saw that the OP switched texting apps. I had recently switched to Facebook messenger SMS and when I went back to the default SMS and restarted my phone it stopped. We'll see how long it lasts
    11-18-2016 10:44 PM
  2. BMWKante's Avatar
    Samsung Note 5 here with the same issue. I saw that the OP switched texting apps. I had recently switched to Facebook messenger SMS and when I went back to the default SMS and restarted my phone it stopped. We'll see how long it lasts
    Me too have this Problem on oneplus 3. If I deactivate WLAN scanning the Problem is gone
    11-19-2016 11:17 AM
  3. GoLfWRC's Avatar
    I have just found my personal temporary fix by these:
    + Go to Setting / WiFi
    + Tap a slider to stop this on/off madness (it will go to completely off or on based on your last state)
    + Tap again to switch from off to on or on to off based on your last state
    At least, this is just a fix for now. May need to wait for an update. However, attempting a solution above on WiFi quick setting does NOT solve.
    11-19-2016 09:41 PM
  4. Rekonn's Avatar
    Quote Originally Posted by Erns Pen View Post
    Well, here's what solved it for me (I have a galaxy s5 by the way).

    Go settings ==> connections ==> Location (turn on location if it isn't already, of course) ===> "Improve accuracy" and turn on "Wi-Fi scanning" to initiate the bug process.
    Then go back to Location, and, in the list of apps under "Recent location requests", tap one and go to "Permissions" and disable the "Location" permission for each one, one a time (IMPORTANT).
    If after disabling the location permission of one of the apps it doesn't fix the problem (check the wifi connection behavior), move on to disable location permission for the next app on the list ("Recent location requests"). Eventually, after disabling the location permission of the glitchy app, the bug will stop

    For me it was the Contacts from Outlook. Clicked on Contacts from the Recent Location Requests page, switched off Location and all has been fine.
    11-21-2016 04:30 PM
  5. tmmug's Avatar
    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.
    Perfect. This worked. It had been bugging me since latest NOV 2016 update on Note 4. Thanks man!
    11-22-2016 01:26 PM
  6. Ed Lojko's Avatar
    @ Jeepsk8 worked on my Verizon S5. Thanks,
    11-23-2016 11:38 AM
  7. lokster's Avatar
    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.

    THIS! since the oct-nov update. THIS FIXED IT! THANK YOU SO MUCH DUDE!!

    Fixed my note 4. i scanned through all my apps and nothing was turning the wifi on except for the high accuracy, that you just mentioned

    so awesome for figuring this out thanks

    Im on Marshmallow on the note 4.
    11-23-2016 09:58 PM
  8. japark's Avatar
    Thanks for the solution. I had given up finding a solution to the constant on/off of WiFi. Turning off high accuracy did it.

    Unfortunate that you have to disable part of the GPS system to get the phone to do what you set it to do.
    11-24-2016 06:04 PM
  9. Software Libre Software Libre's Avatar
    This method works.

    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.
    11-24-2016 06:15 PM
  10. Glen G's Avatar
    Well you helped one person. That is for sure. Thanks, this worked for me
    11-25-2016 07:51 PM
  11. Stuntchicken's Avatar
    You're a star! No idea why this suddenly happened overnight but your solution fixed it - thank you for putting it out there.
    11-29-2016 12:05 PM
  12. omcsilva's Avatar
    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.
    Worked for me! Thanks
    11-29-2016 07:17 PM
  13. CSin06's Avatar
    Same situation as mick... it must be a similar messaging App to Textra... (Whatsapp perhaps?) that does this?

    suggestions anyone?
    12-01-2016 12:59 AM
  14. CSin06's Avatar
    This almost worked, and led me to a solution, Thanks!
    After Deny'ing the location permissions on my apps one by one and checking, I still had the fluctuating Wifi...
    but notice that the LOCATION-MODE setting was "High accuracy" which uses GPS, Wifi and mobile netowkrs to estimate your location
    versus POWER SAVING setting which uses wifi and mobile networks
    versus GPS only setting....

    I set it to the last one and problem solved (after undoing each of the Apps).
    I may try to turn the apps permissions back on now to verify.
    Thanks all for the direction.
    12-01-2016 01:24 AM
  15. forubilal's Avatar
    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.
    Awesome man.....made my day...problem solved...
    12-04-2016 12:00 PM
  16. Monkeystuff's Avatar
    Hi,

    Looks like I too have a similar issue on the SM-G900F S5.

    I too found the 'hold the slider over to the right' trick ... but now I cannot turn wireless off and I don't want to have it running constantly.

    Trying to hold it to the left doesnt work; it just toggles left and right about once a second.

    Tried all of the other suggestion re Location - high/low accuracy - permissions, factory reset etc. but nothing works.
    12-05-2016 10:18 AM
  17. swstrick's Avatar
    Thank you. Tried many different ways to stop this before finding your solution that actually worked.
    12-05-2016 10:47 AM
  18. Monkeystuff's Avatar
    Update!

    I checked back through the messages here until I spotted "Claytan K"s notes about Google Play Services.

    I've had problems with this before, just after I bought an Android Wear watch, and had to go through a number of update and uninstalls until I got the mobile and the watch to talk properly.

    Removing all the updates to Google Play Services - currently 10.0.84 (438-137749526) - reverts back to version 8.something; the original factory supplied installation.

    Now I can switch Wi-Fi On or OFF at will!

    The problem is ... Android Wear, Maps, Hangouts etc. won't work unless they see the current version.

    So - for the time being - I have put back all the updates and have to leave Wi-Fi permanently on until Google comes up with a solution/new update.

    12-05-2016 11:01 AM
  19. Metah4's Avatar
    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.
    Oh my gosh! This worked! Been watching my wifi flicker...and not sure why it was doing that. Searched, saw this post, made the change...and voila! FIXED!
    12-09-2016 12:28 PM
  20. Kelvin Tan 75's Avatar
    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.
    This one works for me. Finally found the culprit that drains my phone batt!
    12-12-2016 11:18 AM
  21. trinisuprazee's Avatar
    deleted google home and then reset the phone!! wow this is probably what has been destroying my battery life.

    Saved me from doing another factory reset thanks folks
    12-12-2016 04:56 PM
  22. MrMortal's Avatar
    I have LG G pro 2 F350L... having same issue, Factory reset... Flashing... new firmware, nothing helped... i can switch wifi off but when i turn it on.. it keeps turning itself on and off, constantly
    12-21-2016 10:28 PM
  23. lowgman23's Avatar
    This method works.

    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.
    I had the same issue with my galaxy S5 (att) and now I moved to the Galaxy S6 Active (att) and still the same issue. The issue started on the active after the Nov 2016 security update. I tried your suggestion and now my wifi is working like it should. Thank you very much. Im curious if this issue is just with at&t branded phones
    01-11-2017 12:41 PM
  24. Daoud333's Avatar
    Seems solved for me with December security update on my Samsung Galaxy Note 4
    01-17-2017 11:50 PM
  25. Stan D's Avatar
    Samsung Galaxy S5, 16 GB, 64 GB memory SIMM, T-Mobile, Android version 6.0.1, security patch Nov 1,2016.

    I read many of the recommendations here and elsewhere.
    I rebooted and cleared the cache, with no permanent fix.
    Power saving setting has Power Saving mode "On".
    For Settings/Wi-FI,the Smart network switch is unchecked and WiFi is turned on.
    I was connected to my T-Mobile WiFi CellSpot router (Asus TM-AC1900) with mostly defaults.
    Location was turned off initially while I had the same problem as you.
    My Location method is now "High accuracy".

    As soon as I turned Location "ON", the problem no longer occurs.
    I tried unsuccessfully to reproduce the error at a T-Mobile store.

    Apparently, something in the phone needs the Location feature turned on with wi-fi.
    If I want better security, hiding my location, I'll just turn off wi-fi.
    I have not tried turning off Location in individual applications.
    There were no listed running applications while I was testing.

    I'm able to keep Wi-Fi turned on w/o wi-fi constantly cycling.

    I hope this information helps.
    02-18-2017 05:56 PM
85 1234

Similar Threads

  1. Spotify and Runtastic?
    By elysm1 in forum Samsung Gear S
    Replies: 10
    Last Post: 11-12-2014, 06:06 PM
  2. Replies: 2
    Last Post: 11-09-2014, 10:52 AM
  3. Replies: 1
    Last Post: 11-08-2014, 10:00 PM
  4. Replies: 1
    Last Post: 11-08-2014, 09:02 PM
LINK TO POST COPIED TO CLIPBOARD