02-21-2018 09:42 AM
84 ... 234
  1. Stan D's Avatar
    Samsung Galaxy S5, 16 GB, 64 GB memory SIMM, T-Mobile, Android version 6.0.1, security patch Nov 1,2016.

    I read many of the recommendations here and elsewhere.
    I rebooted and cleared the cache, with no permanent fix.
    Power saving setting has Power Saving mode "On".
    For Settings/Wi-FI,the Smart network switch is unchecked and WiFi is turned on.
    I was connected to my T-Mobile WiFi CellSpot router (Asus TM-AC1900) with mostly defaults.
    Location was turned off initially while I had the same problem as you.
    My Location method is now "High accuracy".

    As soon as I turned Location "ON", the problem no longer occurs.
    I tried unsuccessfully to reproduce the error at a T-Mobile store.

    Apparently, something in the phone needs the Location feature turned on with wi-fi.
    If I want better security, hiding my location, I'll just turn off wi-fi.
    I have not tried turning off Location in individual applications.
    There were no listed running applications while I was testing.

    I'm able to keep Wi-Fi turned on w/o wi-fi constantly cycling.

    I hope this information helps.
    02-18-2017 05:56 PM
  2. jahani's Avatar
    I had the same problem here in my Samsung Galaxy Note 5. Trying to turn on wifi, it was starting to turn on and off again and again every two or three seconds. tried every solution in this topic and none of them worked for me.

    Tried to hard reset (Power+Volume Up+Home) my phone and in first boot setup process found my wireless (no problem till here, wifi turn on with no problem and found wireless devices), then enter my passphrase to connect to my router and the problem starts to happen again. (watch the video)

    Then changed this settings in my TP-Link router:
    - turn off 5GHz band (to use just 2.5GHz band)
    - Mode: 802.11n only (not 802.11bgn mixed)
    - Channel Width: 20MHz (not 40MHz or Auto)
    and hard reset again and connect to wifi with no problem until now. (for a few hours)

    Better to mention last week I activated "Developer Mode" and run a simple app of mine from Android Studio. The problem starts to happen after that (not immediately) and it could be related to it.

    Sorry for my bad English.
    03-04-2017 07:30 PM
  3. atuldpatil's Avatar
    I had this issue and was causing me real headache. I initially thought it was hardware failure of my phone but later I found reason is something else.

    For some reason I had changed Wireless Security of my WiFi router from WPA2 Personal to something else (I guess WEP).
    That was causing my phone (intex cloud 4g) often to turn on and off WiFi on its own. I changed the Wireless Security back to WPA2 Personal and phone is now back to normal (not turning WiFi on and off on its own)
    04-14-2017 08:32 AM
  4. cattracks31's Avatar
    Jahani- Your post is what solved my problem. I tried everything suggested with the location stuff and the switch. Nothing worked. We recently switched to 5G. I had the wife cut off 5G and linked to 2.4 and it stopped switching. Thanks for bringing this up.

    Now, the issue is still out there. 5G worked for 2 weeks before the problem started so what caused it to suddenly freak-out?

    Thanks again for your post.
    06-01-2017 05:37 AM
  5. JC4every1's Avatar
    Well, here's what solved it for me (I have a galaxy s5 by the way).

    1. Go settings ==> connections ==> Location (turn on location if it isn't already, of course) ===> "Improve accuracy" and turn on "Wi-Fi scanning" to initiate the bug process.
    2. Then go back to Location, and, in the list of apps under "Recent location requests", tap one and go to "Permissions" and disable the "Location" permission for each one, one a time (IMPORTANT).
    3. If after disabling the location permission of one of the apps it doesn't fix the problem (check the wifi connection behavior), move on to disable location permission for the next app on the list ("Recent location requests"). Eventually, after disabling the location permission of the glitchy app, the bug will stop

    For me it was the T-Mobile app so I simply left it with permission disabled. I kind of had a feeling that Android would not let any of their apps or other big Play Store apps get away with this kind of huge glitch. I honestly wish I could uninstall T-Mobile app since I never use it and it kind of sucks but ah well, don't wanna root my phone for now.

    Anyways, hope this helps.
    This worked for me, thanks! Thank God it was the 2nd app I tried turning off location which is Android Pay. I enabled everthing back except location permission for Android Pay and my wifi is now steady. (This was my last attempt to fix but I also previously did clear cache and Android system reboot.) I have Note 5.
    08-06-2017 07:51 AM
  6. Annamalai Chettiar's Avatar
    I tried everything mentioned here and nothing works, every time i turn on wifi, my S7 EDGE powers off.

    I tried the following

    Settings, location, improve accuracy and turn off wi-fi.

    cleared the cache for all apps

    turned on Location method to "High accuracy".
    turned Location "ON"

    Turned off developer mode

    Settings/Wi-FI,the Smart network switch is unchecked and WiFi is turned on.

    disabling the location permission all apps

    went to Settings>Privacy and safety>Location>Improve Accuracy> and Disable Wi-Fi Scanning. didn't work

    didn't know how to turn off wifi direct

    ohnenomen likes this.
    10-10-2017 02:31 AM
  7. Onyedika Benjamin Jideani's Avatar
    I had this exact problem. I fixed it this way: Settings, location, improve accuracy and turn off wi-fi. So far problem seems to be fixed. I have a Galaxy S5 with ATT. I hope this helps someone.
    This is the solution after long search God bless you
    11-05-2017 01:22 AM
  8. Jim DeLuco's Avatar
    Anyone else been through this? All of a sudden, my wifi keeps switching between off and on every... 5-10 seconds. Any thoughts?

    no recent downloads/changes, running Kk 4.4.2
    I had this problem alot and it kept coming and going. I discovered that my phone had an active app, ATT Smart Wifi, that came with the phone and was turned on by default. After investigating the benefit of turning wifi off and on it appears that they claim it saves battery power, however in my experience by turning this app off and on, it doesn't appear to make a difference with the battery power and with the app off it still uses 4G when wifi is not available.
    12-05-2017 08:42 AM
  9. pius288's Avatar
    Please help me this problem is making me lose brain cells i am running android 4.4.4 kitkat... i don't have the improve accuracy feature neither can i update my phone cause the last version is 4.4.x for my device(lg g flex) i have tried almost all methods + factory reset.. but still the problem is there i have tried location to gps only but everytime i get a message asking to agree using wifi which i disagree... its literally making me rage so hard
    02-21-2018 09:42 AM
84 ... 234

Similar Threads

  1. Spotify and Runtastic?
    By elysm1 in forum Samsung Gear S
    Replies: 10
    Last Post: 11-12-2014, 06:06 PM
  2. Replies: 2
    Last Post: 11-09-2014, 10:52 AM
  3. Replies: 1
    Last Post: 11-08-2014, 10:00 PM
  4. Replies: 1
    Last Post: 11-08-2014, 09:02 PM