08-14-2018 04:14 PM
37 12
tools
  1. Gabagool's Avatar
    On the Galaxy S5, whenever you long-press the Home button, it brings up what appears to be a Google search page or something. Apparently I’m really bad at pressing buttons quickly (either that or the button is malfunctioning) because I keep accidentally bringing up this damn Google search page instead of the home screen. Needless to say, this feature is driving me absolutely insane.

    Is there any possible way to disable the long-press or even just change what it does??? I’ve searched through the phone’s settings and all over the internet and haven’t found anything useful yet.
    11-16-2014 12:20 AM
  2. punk999's Avatar
    I use the menu button (left) to go to the home screen, to keep the home button from wearing out. You can do that by pressing the menu button and then touching the empty space.
    bsettz and RockyMtnRedRaider like this.
    11-16-2014 12:24 AM
  3. Gabagool's Avatar
    Thank you for that suggestion! I’d really prefer to directly solve this issue with the Home button (it really is driving me nucking futs), but I will definitely be employing your method as a workaround to ease my frustration for the time being, lol.
    11-16-2014 12:52 AM
  4. thecomicbookandme's Avatar
    Go to settings - s voice.
    Make sure that "Open via the home key" box is not checked.
    11-16-2014 10:46 AM
  5. Gabagool's Avatar
    S-Voice has already been turned off and isn't causing the problem. S-Voice opens with a double tap. What I'm referring to is the long-press, which opens up some kind of Google page.

    Can I disable the Long-press on the Home Button?-screenshot_2014-11-16-16-40-20.jpg
    11-16-2014 03:42 PM
  6. japark's Avatar
    I'd like to know how to clear that history or preferably tell Google search not to retain a search history.
    11-16-2014 04:09 PM
  7. blain705's Avatar
    Go to application sesettingo and go to Google search and disable it. You will Bo be able to get into it via long preswing the home button but can stil use Google Chrome and stuff....
    01-24-2015 02:10 PM
  8. aztonsupra's Avatar
    I know what you mean, it's so annoying but I found the solution.
    go to settings, application manager, scroll to the right where it says "all" and look for "google app", press it and press "turn off"
    hit "ok" and then "uninstall" once you do that long-press home button and select "always" on the option of "do nothing"

    I hope that I didn't confuse yourself.
    peace
    Lord Xantosh likes this.
    01-27-2015 06:21 PM
  9. Haalcyon's Avatar
    I know what you mean, it's so annoying but I found the solution.
    go to settings, application manager, scroll to the right where it says "all" and look for "google app", press it and press "turn off"
    hit "ok" and then "uninstall" once you do that long-press home button and select "always" on the option of "do nothing"

    I hope that I didn't confuse yourself.
    peace
    I just tried that. On my Note 4 it didn't work. A long press still brings up the Google search. Perhaps it does work on the S5.
    01-27-2015 06:57 PM
  10. pninja1's Avatar
    Go to your app list. Locate the app "google". Drag it to the "disable" icon at the top.
    02-08-2015 09:41 PM
  11. Mlgshadow20's Avatar
    I'm also becoming very frustrated with this. Sometimes when I press the home button quickly, it still brings up the search page and is extremely frustrating. I have disabled Google Search as well as S Voice. I do not see any other applications to disable in the applications manager. The settings in the search function only allow to clear search history. I am running on Android 4.4.4
    02-08-2015 11:34 PM
  12. pninja1's Avatar
    After many hours searching for solution, I restarted my phone and the problem seemed to go away. From what I've been reading, this happens when you have a lot of apps running and will eventually come back if you have apps sucking up ram on your phone. Short press gets interpreted as a long press or something.
    02-09-2015 01:54 AM
  13. artemis_68's Avatar
    I just recently updated the software on my S5 and it started doing this almost every time I hit the home key. I like the search function and use it often so I didn't want to completely disable the whole app. Then I realized the widget got removed after the software update too . Once I put the widget back on one of my screens, it was no longer super touchy. It still pops up when I do a long press, but it had to REALLY be a long press. No idea why the widget would make any difference, but I'll take it
    02-09-2015 02:50 AM
  14. steve Sharra's Avatar
    What I noticed was I had Google launcher / nova/touch wiz installed that would happen to me so I deleted only Google launcher and problem solved for me

    SAMSUNG S5
    02-09-2015 05:15 PM
  15. maxburn's Avatar
    After many hours searching for solution, I restarted my phone and the problem seemed to go away. From what I've been reading, this happens when you have a lot of apps running and will eventually come back if you have apps sucking up ram on your phone. Short press gets interpreted as a long press or something.
    This has been my experience as well, my theory is the phone is lagging so much it interprets the short press as a long press because other processes are getting in the way of the timer function that figures out a short vs long press.

    Too bad this feature can't be disabled, I really don't use it.
    02-14-2015 09:29 AM
  16. Tonberrymagi's Avatar
    I know what you mean, it's so annoying but I found the solution.
    go to settings, application manager, scroll to the right where it says "all" and look for "google app", press it and press "turn off"
    hit "ok" and then "uninstall" once you do that long-press home button and select "always" on the option of "do nothing"

    I hope that I didn't confuse yourself.
    peace
    Worked like a charm my sanity thanks you!
    02-17-2015 12:07 PM
  17. DeBuiser's Avatar
    Wish this worked on my S5. I'm not given an option to "do nothing."

    These last few updates have been really screwy. I'm just glad I can stay on WiFi for longer than 10 seconds now.
    02-20-2015 02:08 AM
  18. Micah Livingston's Avatar
    I think I've got it. Next time it pops up, go to settings-phone search-and unclick all the buttons. Worked so far for me when nothing else did.
    03-04-2015 05:03 PM
  19. HelloMegs's Avatar
    The only way to fix it permanently is to go into your app manager in your phone settings, scroll down to the Google app and then tap "uninstall updates". This will revert the Google app back to factory settings and you won't have to worry about that Google Now crap popping up when you hit your home button.
    03-12-2015 09:08 PM
  20. fractaloon's Avatar
    I found that Tasker has profile to intercept the Home button long press. I created a profile that will capture that and send me to the home page and that seems to work for me so far.
    03-16-2015 04:03 PM
  21. pninja1's Avatar
    Finally fixed it! Open the play store -> search and select the Google app -> select "uninstall". This doesn't actually uninstall the app, just the updates. Been a week without a restart and still working normal.
    03-18-2015 12:26 PM
  22. Timothy Swann's Avatar
    On the Galaxy S5, whenever you long-press the Home button, it brings up what appears to be a Google search page or something. Apparently I’m really bad at pressing buttons quickly (either that or the button is malfunctioning) because I keep accidentally bringing up this damn Google search page instead of the home screen. Needless to say, this feature is driving me absolutely insane.

    Is there any possible way to disable the long-press or even just change what it does??? I’ve searched through the phone’s settings and all over the internet and haven’t found anything useful yet.
    Found a permanent fix. Spoke with a Samsung rep. Turn your device off. From there, turn it on using the recovery option (bootloader.) Navigate down using the volume button to the line that reads "wipe cache partition" and select that with the power button. After that is done, navigate to the line that reads "reboot system now." Select with power button. Once the system reboots, you should no longer have an issue with the home key.
    03-25-2015 07:40 PM
  23. DaarkOne's Avatar
    This procedure to Force stop, disable and uninstall worked for my S5 with current software to date. Now if I hold the home key down I feel a haptic feedback but nothing happens.

    Thanks
    07-15-2015 03:00 PM
  24. lexee's Avatar
    Download SwipeLaunch Disabler app from Google Play. Once you install it, it will become one of the options when you long-press Home. So next time, choose it as the option, press Always. Congratulations, you are done. The app will be invoked when you long-press Home, but it's designed to just do nothing, so it gives you the behavior you want.
    Allonia Day and imnotminkus like this.
    09-16-2015 03:46 PM
  25. Andreas Lantz's Avatar
    S-Voice has already been turned off and isn't causing the problem. S-Voice opens with a double tap. What I'm referring to is the long-press, which opens up some kind of Google page.

    Click image for larger version. 

Name:	Screenshot_2014-11-16-16-40-20.jpg 
Views:	146 
Size:	108.6 KB 
ID:	148497
    Go to settings->about phone ->engage "advanced mode".
    Go back to settings->buttons ->pick action for longpress.
    10-26-2015 07:13 AM
37 12

Similar Threads

  1. made the switch
    By akcowboi in forum Samsung Galaxy S5 Active
    Replies: 7
    Last Post: 12-06-2014, 08:40 AM
  2. Anyone use Smart IR w/ the G3's IR blaster?
    By redsandvb in forum LG G3
    Replies: 4
    Last Post: 11-17-2014, 07:48 PM
  3. Did you move to the Nexus 9 from the Nexus 7 2013 version
    By nocaldawg in forum Google Nexus 9
    Replies: 10
    Last Post: 11-17-2014, 11:40 AM
  4. Why won't my Samsung Galaxy Tab 3 receive the internet?
    By broomwade in forum Ask a Question
    Replies: 1
    Last Post: 11-16-2014, 08:19 AM
  5. What is a good root guide for the Verizon Note 3?
    By Matthew Motamedi in forum Samsung Galaxy Note 3
    Replies: 0
    Last Post: 11-15-2014, 11:22 PM
LINK TO POST COPIED TO CLIPBOARD